Welcome to the North American Subaru Impreza Owners Club Monday October 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-13-2012, 05:41 PM   #1
wrxmike
Scooby Newbie
 
Member#: 13800
Join Date: Jan 2002
Chapter/Region: MAIC
Location: MarylanD
Vehicle:
2013 Impreza Sport
DGM

Default Gas gauge reading on 2013 Impreza Sport

So I just got home with my new DGM Impreza Sport Premium. The dealer filled it up (I was with salesman at gas station and the nozzle clicked) but when I got home the gas gauge was one square/notch below full.

How can this be when I saw the gas nozzle click to signal a full tank, twice?
Does it make a difference the key was left in the ignition?

I'm baffled. Called dealer and they told me to drive it around and fill up the next time to full. And if the gauge still doesn't read full to bring it in and they'll try resetting it.

Any one got any ideas?
* Registered users of the site do not see these ads.
wrxmike is offline   Reply With Quote
Old 12-13-2012, 06:23 PM   #2
aeoporta
Scooby Specialist
 
Member#: 334126
Join Date: Oct 2012
Chapter/Region: Tri-State
Location: New York
Vehicle:
2013 5mt Sp Premium
Venetian Red & Dark Gray

Default

Air the other odorless clear gas
aeoporta is offline   Reply With Quote
Old 12-13-2012, 06:26 PM   #3
lymphomaniac
Scooby Specialist
 
Member#: 334451
Join Date: Oct 2012
Chapter/Region: VIC
Location: YVR
Vehicle:
2013 Impreza2.0i CVT
DGM (sedan)

Default

I guess the key question is: how far was the distance travelled between the fuel station and when you got home?
lymphomaniac is online now   Reply With Quote
Old 12-13-2012, 06:29 PM   #4
aeoporta
Scooby Specialist
 
Member#: 334126
Join Date: Oct 2012
Chapter/Region: Tri-State
Location: New York
Vehicle:
2013 5mt Sp Premium
Venetian Red & Dark Gray

Default

Clearly this car is not getting the EPA numbers j/k. Lol
aeoporta is offline   Reply With Quote
Old 12-13-2012, 06:39 PM   #5
motorace
Scooby Newbie
 
Member#: 339003
Join Date: Nov 2012
Default

my car had one notch less when picked up, with 5 miles on it. havent filled it up yet, as i'm only 100 miles deep

Last edited by motorace; 12-13-2012 at 09:20 PM.
motorace is offline   Reply With Quote
Old 12-13-2012, 07:26 PM   #6
wrxmike
Scooby Newbie
 
Member#: 13800
Join Date: Jan 2002
Chapter/Region: MAIC
Location: MarylanD
Vehicle:
2013 Impreza Sport
DGM

Default

Quote:
Originally Posted by lymphomaniac View Post
I guess the key question is: how far was the distance travelled between the fuel station and when you got home?
5 miles between dealer and home. Honestly, I don't think it moved after it got filled up.
wrxmike is offline   Reply With Quote
Old 12-13-2012, 07:51 PM   #7
gt601
Scooby Newbie
 
Member#: 308387
Join Date: Jan 2012
Vehicle:
2012 Impreza Sport
white

Default

My old 06 Grand Vitatra would not even register the fuel if you left the ignition switch in the on position while filling. It would take several hours of driving to correct itself. Maybe that is what is going on?

Paul
gt601 is offline   Reply With Quote
Old 12-13-2012, 08:20 PM   #8
wrxmike
Scooby Newbie
 
Member#: 13800
Join Date: Jan 2002
Chapter/Region: MAIC
Location: MarylanD
Vehicle:
2013 Impreza Sport
DGM

Default

Quote:
Originally Posted by gt601 View Post
My old 06 Grand Vitatra would not even register the fuel if you left the ignition switch in the on position while filling. It would take several hours of driving to correct itself. Maybe that is what is going on?

Paul
Oddly enough, I think this may be the reason. I've been doing general searches online and other vehicles, from VW to Ford have had issues where the fuel gauge won't move if the key's left in the ignition?!? Talk about firsts...

Well, good excuse to keep driving it around a lot until I gotta fill up again...this time w/the key out of the ignition.
wrxmike is offline   Reply With Quote
Old 12-13-2012, 11:02 PM   #9
danstheman7
Scooby Newbie
 
Member#: 331089
Join Date: Sep 2012
Chapter/Region: Tri-State
Location: Bellmore NY
Vehicle:
2012 Impreza Base
DGM/Dark Grey Metallic

Default

Quote:
Originally Posted by wrxmike View Post
Oddly enough, I think this may be the reason. I've been doing general searches online and other vehicles, from VW to Ford have had issues where the fuel gauge won't move if the key's left in the ignition?!? Talk about firsts...

Well, good excuse to keep driving it around a lot until I gotta fill up again...this time w/the key out of the ignition.
Not sure of the exact thread link, but there are a few people that reported the issue of the computer not reading the fuel when the car was in the ACC position (or on).

If you bring it to the dealer and tell them they might re-flash the car, but it's nothing to worry about. It might go away as well, because those threads seemed to only pop up with newly-purchased imprezas.
danstheman7 is offline   Reply With Quote
Old 12-14-2012, 10:12 PM   #10
wrxmike
Scooby Newbie
 
Member#: 13800
Join Date: Jan 2002
Chapter/Region: MAIC
Location: MarylanD
Vehicle:
2013 Impreza Sport
DGM

Default

Yeah, yesterday the dealer said if it doesn't correct itself after a few fill-ups to come in and they'll reflash it.
wrxmike is offline   Reply With Quote
Old 12-28-2012, 05:10 PM   #11
wrxmike
Scooby Newbie
 
Member#: 13800
Join Date: Jan 2002
Chapter/Region: MAIC
Location: MarylanD
Vehicle:
2013 Impreza Sport
DGM

Default

UPDATE: SO, i finally had to fill up today. about 320 miles since I brought her home and had one notch left on the gas gauge. Fill up today with the key OUT of the ignition and TADA...gas gauge reads all the way up to the F mark. The oddest thing if you ask me.
wrxmike is offline   Reply With Quote
Old 12-28-2012, 10:55 PM   #12
lymphomaniac
Scooby Specialist
 
Member#: 334451
Join Date: Oct 2012
Chapter/Region: VIC
Location: YVR
Vehicle:
2013 Impreza2.0i CVT
DGM (sedan)

Default

So I guess the moral of the story is: don't leave your key in while you're filling up your gas tank?
lymphomaniac is online now   Reply With Quote
Old 12-29-2012, 09:49 PM   #13
CLL_OBP
Scooby Specialist
 
Member#: 310435
Join Date: Feb 2012
Location: Fayettenam, NC
Vehicle:
2012 Sport Limited
Obsidian Black Pearl

Default

It's been mentioned a few times in other threads and it happened to me several months ago where the gas gauge didn't change at all. Just turn the key in the off position before you fill.
CLL_OBP is offline   Reply With Quote
Old 12-30-2012, 02:27 PM   #14
wrxmike
Scooby Newbie
 
Member#: 13800
Join Date: Jan 2002
Chapter/Region: MAIC
Location: MarylanD
Vehicle:
2013 Impreza Sport
DGM

Default

"Off" position. Noted. All these years with cars that have push button start, I always catch myself either trying to turn the ignition w/o key or looking for the start button.
wrxmike is offline   Reply With Quote
Old 02-12-2013, 12:01 AM   #15
CLL_OBP
Scooby Specialist
 
Member#: 310435
Join Date: Feb 2012
Location: Fayettenam, NC
Vehicle:
2012 Sport Limited
Obsidian Black Pearl

Default

Oh well, it happened again and it had nothing to do with the key in the off position or out of the ignition. I put the keys in my pocket as I always do to fill up today and afterwards I sat there for a few minutes to post info in my Gas Buddy and GasTracker (Fuelly) app. I turned the key forward to start the car and the gas gauge still had the old reading. Took the key out for 10-15 seconds and tried again....full. Go figure
CLL_OBP is offline   Reply With Quote
Old 02-12-2013, 08:57 AM   #16
myrt1987
Scooby Specialist
 
Member#: 323103
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: toms river, nj
Vehicle:
2012 Limited 2.0i
Dreamy Gray Mistress

Default

^ This happened to me too. I thought the gas station ripped me off! but it went to full after a minute or whatever.
myrt1987 is offline   Reply With Quote
Old 02-12-2013, 10:26 AM   #17
CLL_OBP
Scooby Specialist
 
Member#: 310435
Join Date: Feb 2012
Location: Fayettenam, NC
Vehicle:
2012 Sport Limited
Obsidian Black Pearl

Default

This is the third time in 86 fill ups (3%). Not a major concern for now as it doesn't happen that often and off/on again fixes it.
Here's something interesting I found. This guy with a BRZ had the same thing happen but his never corrected itsef, even after a few days: http://www.subarubrzforum.com/9-suba...uge-issue.html
CLL_OBP is offline   Reply With Quote
Old 02-12-2013, 11:59 PM   #18
emac08
Scooby Newbie
 
Member#: 346355
Join Date: Feb 2013
Chapter/Region: SCIC
Location: Ontario, California
Vehicle:
2014 Forester XT
DGM

Default

I say to make sure, fill it up again with the key NOT in the off position and see if it doesnt go all the way to the full mark.
emac08 is offline   Reply With Quote
Old 03-10-2013, 05:18 PM   #19
CLL_OBP
Scooby Specialist
 
Member#: 310435
Join Date: Feb 2012
Location: Fayettenam, NC
Vehicle:
2012 Sport Limited
Obsidian Black Pearl

Default

It happened again today with key out of the ignition, as usual. The gauge still read half tank when I turned the key forward prior to starting. Took it out for a minute, same thing. Repeated this 5 times and nothing. Finally, I said f**k it and started it up. As soon as it started, the bars filled up one by one in a span of about 3 seconds vs just appearing as full when starting. Strange stuff....
CLL_OBP is offline   Reply With Quote
Old 03-10-2013, 06:16 PM   #20
aeoporta
Scooby Specialist
 
Member#: 334126
Join Date: Oct 2012
Chapter/Region: Tri-State
Location: New York
Vehicle:
2013 5mt Sp Premium
Venetian Red & Dark Gray

Default

your car is obviously possessed, you should see a priest
aeoporta is offline   Reply With Quote
Old 03-10-2013, 06:54 PM   #21
CLL_OBP
Scooby Specialist
 
Member#: 310435
Join Date: Feb 2012
Location: Fayettenam, NC
Vehicle:
2012 Sport Limited
Obsidian Black Pearl

Default

I don't feed it gas after midnight so it could be driving a Gremlin and not know it. :0)
CLL_OBP is offline   Reply With Quote
Old 04-24-2013, 08:10 AM   #22
winglik
Scooby Newbie
 
Member#: 317022
Join Date: Apr 2012
Chapter/Region: Tri-State
Location: NYC
Vehicle:
2013 Impreza Sport
Dark Grey Metallic

Default

I had the same issue when fill up my car. with the key in but at off position. It always 2 bars short of full. After contacted with the dealer, he suggest me to remove the key completely during fillup. I tried today and fuel gauge reading was complete full. so that's very stupid thing in a new car.
winglik is offline   Reply With Quote
Old 04-24-2013, 10:02 AM   #23
aeoporta
Scooby Specialist
 
Member#: 334126
Join Date: Oct 2012
Chapter/Region: Tri-State
Location: New York
Vehicle:
2013 5mt Sp Premium
Venetian Red & Dark Gray

Default

every new car does that, computer no likey when you have power and filling up, could be worse you could always have had an annoying fuel cap message and beeps as other cars like to do when you do the same exact thing.
aeoporta is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:12 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.