Welcome to the North American Subaru Impreza Owners Club Sunday November 29, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 03-14-2013, 04:33 PM   #1
Scooby Newbie
Member#: 348552
Join Date: Feb 2013
Default Bad clutch? Or no problem at all?

I noticed when I turn on my car (11 wrx,44k miles) from a cold start it idles at 1500.. And as it heats up it drops to idle around 900. But lately when driving from a cold start going from 1st or 2nd to neutral / stop. If I'm around 3k rpm. It will drop to 2k with the clutch all the way in. And stay there for a second or two then drop down. Also sometimes not all, when I push the clutch in it takes a few seconds for it to disengage.. It never took more than a second and I've noticed this. Is it normal? Also maybe a month ago I went to Subaru and Because sometimes when going to idle reve would drop to around 5 or under and the car would shake like it was stalling. It's my first manual and am a little confused.
* Registered users of the site do not see these ads.
Vegaswrx11 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-14-2013, 05:03 PM   #2
Scooby Newbie
Member#: 350069
Join Date: Mar 2013
Chapter/Region: MAIC
Location: EC, MD
2007 WRX STi
Awesome Blue


Can you rewrite that? I got dizzy trying to read everything going on and imagining what your doing.
DependableDave is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 07:00 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.