Welcome to the North American Subaru Impreza Owners Club Friday August 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-16-2013, 12:33 PM   #1
chrisp0192
Scooby Newbie
 
Member#: 350191
Join Date: Mar 2013
Chapter/Region: MWSOC
Vehicle:
2003 WRX
Sonic yellow

Exclamation 03 WRX Transmission problem, HELP!

so here is the start to finish, maybe someone can tell me what the issue is?

to begin with i have a 2003 WRX 2.0l some mild-med modifications.
i am now having a transmission problem (stock 5 speed)

do driving one day i shift into 2nd, it has a slight grind going in and then my rpm's shoot up with now push from tyranny to engine at all while in 2nd i get some grinding noise but no actual use of the gear it seems.
i drive on this for a month just skipping over 2nd gear (didnt have cash to fix at the time) and going straight into 3rd, now about a week ago i started to have issues with 3rd gear now, to get into 3rd i have to now double clutch? like i said just a stock tranny.

questions:
1. does anyone have a clue what could be wrong with my transmission?
2. does it seem like a gear issue or syncs and barrings?
3. i would greatly like all and any information that anyone could give me, im working on a tight budget but with room to work with as well.

thank you in advance if you have an idea that could help me, or even just info on what could be wrong.
chrisp0192 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:26 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.