Welcome to the North American Subaru Impreza Owners Club Thursday April 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-19-2012, 10:33 AM   #1
STIDAWG
Scooby Newbie
 
Member#: 298850
Join Date: Oct 2011
Chapter/Region: MWSOC
Vehicle:
2007 STI
Black

Default Clutch "clicking" in 2012 wrx

I have a 2012 wrx limited hatch with 1,800+ miles on it and just started to notice a slight "click" when I push the clutch peddle about an inch or two in. I don't Remeber the car doing it before a couple days ago. Does anyone know what it might be or is it normal?
* Registered users of the site do not see these ads.
STIDAWG is offline   Reply With Quote
Old 01-19-2012, 10:35 AM   #2
2011WRblueSTi
Scooby Specialist
 
Member#: 275851
Join Date: Mar 2011
Chapter/Region: E. Canada
Location: ON, Canada
Vehicle:
2013 BRZ Sport Tech
WRB

Default

That happened on both my 2009 wrx and 2011 STi. It came and went. Took it to dealership and they said it sounded/looked like the spring on the pedal was making the noise. Never bothered to replace it cause as I drove the cars that noise was droned out by other rattles and creaks and then all was trumped by exhaust once I began the mod process.
2011WRblueSTi is offline   Reply With Quote
Old 01-19-2012, 10:44 AM   #3
STIDAWG
Scooby Newbie
 
Member#: 298850
Join Date: Oct 2011
Chapter/Region: MWSOC
Vehicle:
2007 STI
Black

Default

Quote:
Originally Posted by 2011WRblueSTi View Post
That happened on both my 2009 wrx and 2011 STi. It came and went. Took it to dealership and they said it sounded/looked like the spring on the pedal was making the noise. Never bothered to replace it cause as I drove the cars that noise was droned out by other rattles and creaks and then all was trumped by exhaust once I began the mod process.

Ya I'm no stranger to the noises the car makes, I sold my 07 Sti to get this car. But never experienced the noise with that car. But it won't cause problems will it?
STIDAWG is offline   Reply With Quote
Old 01-21-2012, 11:16 AM   #4
2011WRblueSTi
Scooby Specialist
 
Member#: 275851
Join Date: Mar 2011
Chapter/Region: E. Canada
Location: ON, Canada
Vehicle:
2013 BRZ Sport Tech
WRB

Default

No problems that ever happened to either of my cars. In fact I think it went away all together on my STi over time.
I never had this noise but many others in my 2004 STi and actually my 2007 STi (which I still have under 2k miles) had no odd noises. It's a factory freak.
2011WRblueSTi is offline   Reply With Quote
Old 01-21-2012, 06:47 PM   #5
mmenet
Scooby Newbie
 
Member#: 191736
Join Date: Oct 2008
Chapter/Region: MWSOC
Location: madison wisconsin
Vehicle:
2009 WRX Hatch
grey

Default

if you look at the master cyllinder in the engine bay and it is now moving a great deal and you can hear the click in there, this could mean that a weld on your firewall has broken and you are hearing the weld seams rub against each other. I am about to drop my car off to get this fixed, it is a more frequent problem than SOA wants to admit to because it is very expensive to fix. Im not sure this is the issue, but keep it in mind, because the dealers will not find/admit to this being an issue.
mmenet is offline   Reply With Quote
Old 01-21-2012, 09:40 PM   #6
2011WRX
Scooby Newbie
 
Member#: 251807
Join Date: Jul 2010
Default

typical issue, same on my 11 wrx. Dealer lube it and it went away since
2011WRX is offline   Reply With Quote
Old 03-16-2013, 01:56 PM   #7
Capt_Hindsight
Scooby Newbie
 
Member#: 350049
Join Date: Mar 2013
Location: US of A
Vehicle:
2012 WRX

Default

Quote:
Originally Posted by 2011WRX View Post
typical issue, same on my 11 wrx. Dealer lube it and it went away since
I am having this issue now. Does anybody know where to lube the clutch in order to get rid of this noise?
Capt_Hindsight is offline   Reply With Quote
Old 03-16-2013, 11:22 PM   #8
MaddMax
Scooby Specialist
 
Member#: 9264
Join Date: Aug 2001
Location: Kansas City
Vehicle:
2012 WRX 5dr
Ice Silver

Default

I had this issue. It has nothing to do with the broken weld issue experienced in the 08-10 models.

In my car, the click could be felt more than heard. It was almost like a pop and I could feel it in the brake pedal when I depressed the clutch while my right foot was on the brake.

I traced the source to somewhere in the pivot assembly of the clutch pedal. The assembly has two pivots. One above the clutch and then a bar runs across the dash to just above the accelerator from which there's another pivot which when drives the slave cylinder rod. In my case, it was most definitely not the clutch spring. I pulled the pedal left and right and then gave it a yank upwards (towards the driver's seat). The sound never came back
MaddMax is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
6spd sti clutch/flywheel in 5spd wrx tranny? Benjamin Tang Transmission (AT/MT) & Driveline 68 05-03-2013 08:18 AM
Weird clutch issue in 09 wrx..please help!! rspillman88 Transmission (AT/MT) & Driveline 3 06-23-2011 07:18 PM
06 clutch/flywheel in 02 wrx Boarder325 Transmission (AT/MT) & Driveline 2 11-04-2008 07:35 PM
sti 6 spd clutch &flywheel in 5spd wrx trans ECUtuneOne Transmission (AT/MT) & Driveline 9 09-06-2006 07:34 PM
clutch dragging in 5mt wrx Benjamin Tang Transmission (AT/MT) & Driveline 17 02-03-2005 09:44 AM


All times are GMT -4. The time now is 12:24 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.