Welcome to the North American Subaru Impreza Owners Club Wednesday September 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-17-2013, 07:53 PM   #176
trbill2003
Scooby Newbie
 
Member#: 322643
Join Date: Jun 2012
Chapter/Region: W. Canada
Vehicle:
2012 Imprezza Tourin
Deep Cherry Pearl

Default

Thanks all for this thread. I performed this on my 2012 Imprezza Touring. It has the six speaker Clarion CM621UB HU. Significant difference, now I don't need to change my speakers and or my HU. While not a audiophiles dream it is now adequate for the car. Many thanks to those who discovered the hidden menu and posted it. This is so much better.
* Registered users of the site do not see these ads.
trbill2003 is offline   Reply With Quote
Old 03-19-2013, 11:50 AM   #177
Simmadownnow
Scooby Newbie
 
Member#: 350699
Join Date: Mar 2013
Default New unit won't work w/ codes

I recently bought the 2013 crosstrek with HD RADIO but head unit I have is the CM631UD not the 621. Any help on codes to changes settings?

-Jared
Simmadownnow is offline   Reply With Quote
Old 03-19-2013, 04:42 PM   #178
Rymar
Scooby Newbie
 
Member#: 310672
Join Date: Feb 2012
Vehicle:
2012 Impreza Ltd 5Dr
Dark Gray Metallic

Default

Quote:
Originally Posted by Simmadownnow View Post
I recently bought the 2013 crosstrek with HD RADIO but head unit I have is the CM631UD not the 621. Any help on codes to changes settings?

-Jared
Look at the second posting in this thread... also remember to repeat the process 2 more times to get to the loudness and eq menus.

Last edited by Rymar; 03-20-2013 at 02:12 AM. Reason: Added info on loudness and eq menus
Rymar is online now   Reply With Quote
Old 03-20-2013, 05:28 AM   #179
Simmadownnow
Scooby Newbie
 
Member#: 350699
Join Date: Mar 2013
Default

Thanks you. Got into the eq and loudness settings. Any help on sedan/wagon/through settings for head unit?
Simmadownnow is offline   Reply With Quote
Old 03-20-2013, 07:03 AM   #180
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by Simmadownnow View Post
Thanks you. Got into the eq and loudness settings. Any help on sedan/wagon/through settings for head unit?
There is only 1 eq, it is either on or off
flyboy1100 is offline   Reply With Quote
Old 04-14-2013, 10:01 AM   #181
Mike02z
Scooby Newbie
 
Member#: 342283
Join Date: Jan 2013
Default

I can also confirm that this works on the 2014 Forester with the Premium radio (no Nav).
Thanks! Sounds much better.
Mike02z is offline   Reply With Quote
Old 05-06-2013, 05:25 PM   #182
Eskimo1
Scooby Newbie
 
Member#: 184198
Join Date: Jul 2008
Location: Central PA
Vehicle:
2013 XV Crosstrek
Orange!

Default

I know this deals with the non-nav head unit, but none of the hidden menus I've been able to find thus far address audio on the nav.

However, it's CLEAR that there's a Loudness setting that's on, and it's driving me insane! Anyone found the setting for the nav HU's? Please? please??
Eskimo1 is offline   Reply With Quote
Old 05-07-2013, 11:00 AM   #183
luan87us
Scooby Specialist
 
Member#: 335013
Join Date: Oct 2012
Chapter/Region: RMIC
Location: SL,UT
Vehicle:
2013 Premium WRX 5dr
WRB

Default

Quote:
Originally Posted by Eskimo1 View Post
I know this deals with the non-nav head unit, but none of the hidden menus I've been able to find thus far address audio on the nav.

However, it's CLEAR that there's a Loudness setting that's on, and it's driving me insane! Anyone found the setting for the nav HU's? Please? please??
I think it's just the bad sound processor the Nav HU has. There is no option for loudness at all. And playing around with the eq actually gave me much better bass response now. I don't get distorted bass anymore on some song. Those bass notes are now a bit quiter but feel like bass and not ripped speakers. I'll take a picture of my EQ setting for you if you want.
luan87us is offline   Reply With Quote
Old 05-07-2013, 10:14 PM   #184
erixon84
Scooby Newbie
 
Member#: 354850
Join Date: Apr 2013
Chapter/Region: Tri-State
Location: Long Island, NY
Vehicle:
2013 WRX Sedan

Default

I tried this on my 2013 WRX premium.
However when I pressed 1+2+tune all that comes out is SEDAN.
Am I missing something?
erixon84 is offline   Reply With Quote
Old 05-08-2013, 06:02 AM   #185
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by erixon84 View Post
I tried this on my 2013 WRX premium.
However when I pressed 1+2+tune all that comes out is SEDAN.
Am I missing something?
1+3, or 1+4 I believe
flyboy1100 is offline   Reply With Quote
Old 05-28-2013, 10:09 PM   #186
DarkProphet
Scooby Newbie
 
Member#: 299707
Join Date: Nov 2011
Chapter/Region: Tri-State
Location: Pa
Vehicle:
2011 Wrx 5-Door
DGM

Default

BUMP so others can see this
DarkProphet is offline   Reply With Quote
Old 05-28-2013, 10:18 PM   #187
Eskimo1
Scooby Newbie
 
Member#: 184198
Join Date: Jul 2008
Location: Central PA
Vehicle:
2013 XV Crosstrek
Orange!

Default

For the record (I knew it was coming, but I'm a glutton for punishment..) SoA denies there being ANY menus of this type in ANY of their head units... Even after being shown an excerpt from a thread like this
Eskimo1 is offline   Reply With Quote
Old 05-28-2013, 10:45 PM   #188
Jayp5150
Scooby Newbie
 
Member#: 308768
Join Date: Feb 2012
Chapter/Region: MWSOC
Location: Columbus, OH
Vehicle:
2012 WRX Hatch PBP
2012 Ralliart

Default

Quote:
Originally Posted by Eskimo1 View Post
For the record (I knew it was coming, but I'm a glutton for punishment..) SoA denies there being ANY menus of this type in ANY of their head units... Even after being shown an excerpt from a thread like this
Yeah, I e-mailed them before the menus were found for the base model to find out if there was a software update or anything that could be done and got the "We're terribly sorry you are displeased..." spiel. I almost replied after I found out about the hidden features lol.
Jayp5150 is offline   Reply With Quote
Old 05-29-2013, 12:52 AM   #189
silverboost0303
Scooby Specialist
 
Member#: 83266
Join Date: Mar 2005
Chapter/Region: NESIC
Location: Springfield, MA
Vehicle:
2011 WRX Sedan
SWP

Default

Super helpful! Thanks to everyone involved to make these crap head units sound better!
silverboost0303 is offline   Reply With Quote
Old 06-08-2013, 12:33 PM   #190
Pickler
Scooby Newbie
 
Member#: 301247
Join Date: Nov 2011
Location: Toronto
Vehicle:
09 Impreza 2.5i MT
White

Default

few months now since i deactivated sedan mode and went to pass through. Although my amplifier started clipping there was less bass overall. my subwoofer died recently due to melted coils. it seems that even though i had a high pass filter set to a safe 40hz and very conservative power settings the HU managed to overdrive the voltage. i think the sedan/wagon eq protect against unsafe frequencies that can damage speakers. i recommend that the loudness be turned off if you dont like the boominess but i would stick with sedan settings for better sound ovrall with aftermarket speakers and amp. it also doesnt overdrive my speakers.
Pickler is offline   Reply With Quote
Old 06-08-2013, 12:38 PM   #191
Tripintaz
Scooby Specialist
 
Member#: 245218
Join Date: Apr 2010
Chapter/Region: South East
Location: FL
Vehicle:
2013 STI Limited

Default

^^you should rethink your theory. You're wrong.
Tripintaz is offline   Reply With Quote
Old 06-12-2013, 11:24 AM   #192
theEZV
Scooby Newbie
 
Member#: 324205
Join Date: Jun 2012
Chapter/Region: MAIC
Location: Germantown, MD
Vehicle:
'13 WRX 5 door
SWP

Default

Did this in my hatch. Sounds a bit better. I think.
theEZV is offline   Reply With Quote
Old 07-10-2013, 09:17 AM   #193
ABQautoxer
Scooby Specialist
 
Member#: 198231
Join Date: Dec 2008
Location: Albuquerque, NM
Vehicle:
2007 Not a Subaru

Default

Has anyone with the 10" OEM subwoofer tried this to see if the complaints of the bass being too overpowering being remedied? Specifically the hatch owners. Sounds to me if you turned off loudness and the EQ you'd be able to control the sub better and get a decent match?
ABQautoxer is offline   Reply With Quote
Old 07-18-2013, 11:40 AM   #194
DarkProphet
Scooby Newbie
 
Member#: 299707
Join Date: Nov 2011
Chapter/Region: Tri-State
Location: Pa
Vehicle:
2011 Wrx 5-Door
DGM

Default

Just bumping so people can see this info!
DarkProphet is offline   Reply With Quote
Old 08-08-2013, 02:16 PM   #195
joebreeves
Scooby Newbie
 
Member#: 280811
Join Date: Apr 2011
Chapter/Region: MAIC
Location: West Virginia
Vehicle:
2013 STi Limited
WR Blue

Default

Quote:
Originally Posted by ABQautoxer View Post
Has anyone with the 10" OEM subwoofer tried this to see if the complaints of the bass being too overpowering being remedied? Specifically the hatch owners. Sounds to me if you turned off loudness and the EQ you'd be able to control the sub better and get a decent match?

I have the 10" Trunk Sub in a SEDAN, and it sounds much much better. Not as... warbly? It feels like it's sending what it's supposed to.

For now I am Loudness Off and Through Mode.

Additionally - someone mentioned a BRIGHTNESS and CONTRAST change... where are these? I got it to CONTRAST once, but the setting didn't seem to stick.

Also bump.

Last edited by joebreeves; 08-08-2013 at 07:28 PM.
joebreeves is offline   Reply With Quote
Old 10-14-2013, 02:20 PM   #196
slowcheetah1
Scooby Newbie
 
Member#: 366732
Join Date: Aug 2013
Chapter/Region: South East
Location: Yulee, FL
Vehicle:
2013 WRX
DGM

Default

Just did this on my 2013 WRX HU w/o Nav. Definitely an improvement.
slowcheetah1 is offline   Reply With Quote
Old 10-14-2013, 02:48 PM   #197
STiScooby213
Scooby Newbie
 
Member#: 263036
Join Date: Nov 2010
Chapter/Region: SCIC
Location: Los Angeles
Vehicle:
2005 WRX STi *sold*
2013 PBP WRX STI

Default

Quote:
Originally Posted by joebreeves View Post

Additionally - someone mentioned a BRIGHTNESS and CONTRAST change... where are these?
+1 for this. I'd like to know as well so i can drive at night with my cluster at max brightness without my hud blinding my eyes off.
STiScooby213 is online now   Reply With Quote
Old 10-29-2013, 02:14 AM   #198
nightVzn
Scooby Newbie
 
Member#: 291558
Join Date: Aug 2011
Location: Ithaca, NY
Vehicle:
2010 Impreza 2.5GT
silver

Default Improved hidden HU settings with OEM subs

I've had my 2010 2.5GT sedan for over three years now, and I just learned about these hidden settings in the last 24 hours. Unbelievable! All this time, I've been so immensely disappointed with the stereo, especially coming from my 2006 WRX Limited which at least claimed to have a premium sound system (140 watts? meh ... better than 80). I always found it adequate at best, but compared to my 2010, it was pretty damn good.

I'm not sure if these settings completely make up the difference, but so far it's a very noticeable improvement. Definitely liking "Through Mode." I'm on the fence about "Loud" ... as others in this thread have mentioned, without the EQ to compound it, "Loud" actually can sound good.

But I am wondering about subs...

Quote:
Originally Posted by joebreeves View Post
I have the 10" Trunk Sub in a SEDAN, and it sounds much much better. Not as... warbly? It feels like it's sending what it's supposed to.

For now I am Loudness Off and Through Mode.
I eagerly got the Kicker sub two years ago, and was very disappointed that I had to have it removed after a couple weeks. The bass was just too boomy, too percussive, too uncomfortable on my ears. Your description sounds promising. Would you say the improvement with Through Mode and/or Loudness off would be likely to negate the discomfort? I realize it's rather subjective, but I'd like to gather others' impressions.

I need to try out the new settings for a while, but it's crossed my mind that they might be good enough for me to reinstall (and actually enjoy) my Kicker. I just don't want to commit to that unless there's a good chance it'll be a success. Having it installed and removed once already was bad enough.

Also, is anybody using the OEM underseat sub? I've had it since I got the car and occasionally screw around with the gain and high cut, but have never found settings I really liked. Settings that work well for some songs produce a milder-but-still-irritating version of the Kicker's boominess with others. But now with the ability to go to a flat EQ and toggle Loudness, there may be new hope. (Contrary to SoA literature, it can be used just fine along with the Kicker.)

Anybody find settings for the OEM underseat sub that work well with the hidden HU settings? At moment I'm running the factory-recommended gain (3:00 on the trim pot) with zero high cut. I confess I'm not sure why I would want to turn high cut up or down in general (I welcome people's input), but I feel like I'm getting more bass with less ear discomfort if I have it down. My usual tone controls are B:4 to 6, M:0, T:0, although I've tried even higher bass with Loudness off.

Adjusting the sub is such a joy. Screwdriver head in one hand, flashlight in the other, blood rushing to my face...
nightVzn is offline   Reply With Quote
Old 10-30-2013, 09:16 AM   #199
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by nightVzn View Post
I need to try out the new settings for a while, but it's crossed my mind that they might be good enough for me to reinstall (and actually enjoy) my Kicker. I just don't want to commit to that unless there's a good chance it'll be a success. Having it installed and removed once already was bad enough.
You could test the OEM Kicker sub without actually "burying" its long cable -- just lay it out from the HU opening directly over/around the seats to the sub.

You may still find that that sub needs its own volume control, but it's not difficult to build one.
SVXdc is offline   Reply With Quote
Old 10-31-2013, 01:15 PM   #200
AcquaCow
NASIOC Supporter
 
Member#: 36838
Join Date: May 2003
Chapter/Region: MAIC
Location: Reston VA
Vehicle:
2000 RS, 2001 RSTi,
and a 2011 WRX hatch...

Default

Hmm, any info for the headunits with NAV? The nav headunit has a fairly adjustable EQ in it, but has anyone tested the outputs with everything zeroed?

-- Dave
AcquaCow is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2011+ Impreza head unit into 2009? codingparadox Car Audio, Video & Security 6 12-31-2011 12:48 AM
2011 Stock Head Unit Audio Playlist Options cheezmunky Car Audio, Video & Security 2 12-02-2011 10:09 AM
WTB : WTB - non-navi 2011+ OEM Head Unit with Bluetooth. ofspunk7 Private 'Wanted' Classifieds 2 10-25-2011 12:40 PM
2011 STi head unit w/o nav RCA PORTS? sk8dc10 Car Audio, Video & Security 5 11-06-2010 10:01 PM
2011 stock head unit wiring question subiebosch Car Audio, Video & Security 10 10-08-2010 09:21 AM


All times are GMT -4. The time now is 01:29 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.