Welcome to the North American Subaru Impreza Owners Club Saturday November 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-18-2013, 08:53 PM   #551
Jcoleman134
Scooby Newbie
 
Member#: 337463
Join Date: Nov 2012
Chapter/Region: MAIC
Location: Glen Burnie Maryland
Vehicle:
03 Wrx
WRB

Default

Is it possible to have the exterior lights flash on the basic keyless entry? I have a 03 wrx. Sorry if this has already been answered in here I didn't see it!
* Registered users of the site do not see these ads.
Jcoleman134 is offline   Reply With Quote
Old 03-21-2013, 02:55 PM   #552
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by Jcoleman134 View Post
Is it possible to have the exterior lights flash on the basic keyless entry? I have a 03 wrx. Sorry if this has already been answered in here I didn't see it!
My exterior lights no longer flash when I lock/unlock with the remote:

The vehicle is in VALET MODE
**Make sure the alarm is disarmed.
**Open the drivers side door.
**Press and hold unlock on the remote until the security light on the dash stops flashing.

EDIT: If you used to have an older style remote for MY 02-06, the trunk release button on the replacement (teardrop) remote can also be used to put the alarm in and out of valet mode.

NOTE: To put back in VALET MODE, repeat the above steps.
RexyGirl is offline   Reply With Quote
Old 03-22-2013, 12:34 AM   #553
Jcoleman134
Scooby Newbie
 
Member#: 337463
Join Date: Nov 2012
Chapter/Region: MAIC
Location: Glen Burnie Maryland
Vehicle:
03 Wrx
WRB

Default

Quote:
Originally Posted by RexyGirl View Post
My exterior lights no longer flash when I lock/unlock with the remote:

The vehicle is in VALET MODE
**Make sure the alarm is disarmed.
**Open the drivers side door.
**Press and hold unlock on the remote until the security light on the dash stops flashing.

EDIT: If you used to have an older style remote for MY 02-06, the trunk release button on the replacement (teardrop) remote can also be used to put the alarm in and out of valet mode.

NOTE: To put back in VALET MODE, repeat the above steps.
From what I understand that is for the factory alarm. I just have factory keyless entry on my 03 bugeye.
Jcoleman134 is offline   Reply With Quote
Old 04-13-2013, 02:51 PM   #554
artemis89
Scooby Newbie
 
Member#: 319784
Join Date: May 2012
Default

Sweet, thanks for all the good info.
artemis89 is offline   Reply With Quote
Old 04-16-2013, 06:05 PM   #555
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by Jcoleman134 View Post
From what I understand that is for the factory alarm. I just have factory keyless entry on my 03 bugeye.
It works the same way, and more than likely, you have an alarm. Most WRX's did.

If you have your VIN, you can PM me and I will check for you
RexyGirl is offline   Reply With Quote
Old 04-23-2013, 10:34 PM   #556
lrocha88
Scooby Newbie
 
Member#: 352354
Join Date: Apr 2013
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2002 WRX
PSM

Default

Just bought my 02 wrx this month and it did not come with a keyless entry remote. But after some research I found out it has keyless entry not sure about an alarm. My car is on valet mode, but even after disconnecting the battery for a few mins it stays on valet mode and I cannot program my fob. Any input on this would be greatly appreciated.
lrocha88 is offline   Reply With Quote
Old 05-03-2013, 04:20 AM   #557
boostin23
Scooby Specialist
 
Member#: 204172
Join Date: Feb 2009
Location: NorCal
Vehicle:
---- 05 STi

Default

bump


ive got an 2002 wrx sedan. My original key fob broke YEARS ago. A friend just gave me his key fob from his old 2005 forester. These are the teardrop shape ones (like in the pic below).


This fob should be programmable for my car correct? Since the do not sell the original fobs for replacements anymore.

Ive done the directions in the OP for the MY 01-06.
The directions say the car will chirp after about 10 key cycles. My car chirps after 3 or so key cycles. So is that the chirp to move onto the next step, or do I continue to cycle the key more?

Thats the furthest ive gotten so far. After the 3 cycles I open/close the door and hit a button on the remote and I get nothing after that
boostin23 is offline   Reply With Quote
Old 05-03-2013, 01:12 PM   #558
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by boostin23 View Post
bump


ive got an 2002 wrx sedan. My original key fob broke YEARS ago. A friend just gave me his key fob from his old 2005 forester. These are the teardrop shape ones (like in the pic below).


This fob should be programmable for my car correct? Since the do not sell the original fobs for replacements anymore.

Ive done the directions in the OP for the MY 01-06.
The directions say the car will chirp after about 10 key cycles. My car chirps after 3 or so key cycles. So is that the chirp to move onto the next step, or do I continue to cycle the key more?

Thats the furthest ive gotten so far. After the 3 cycles I open/close the door and hit a button on the remote and I get nothing after that
Are you sure it's not an aftermarket alarm?

Open up the remote....there should be a white sticker in there. If it has 8 numbers (only) then that remote will not work. If it has a combination of numbers and letters, then it should program to your car because that is the replacement for the oblong remotes.
RexyGirl is offline   Reply With Quote
Old 05-03-2013, 01:39 PM   #559
boostin23
Scooby Specialist
 
Member#: 204172
Join Date: Feb 2009
Location: NorCal
Vehicle:
---- 05 STi

Default

Im pretty sure it is a factory alarm. Is there any way I would be able to check and see?

Ill check the inside of the remotes in a few, thanks
boostin23 is offline   Reply With Quote
Old 05-03-2013, 02:22 PM   #560
boostin23
Scooby Specialist
 
Member#: 204172
Join Date: Feb 2009
Location: NorCal
Vehicle:
---- 05 STi

Default

Ok i just opened up the fob and it does in fact have a number/letter combo, so it should work.
boostin23 is offline   Reply With Quote
Old 05-11-2013, 10:07 AM   #561
TogeTouge2.0
Scooby Newbie
 
Member#: 342681
Join Date: Jan 2013
Chapter/Region: NESIC
Location: Boston
Vehicle:
02 Wrx
Red

Default

I'll pose the question again since no one has at least given me a reason as to why I may be having a problem or maybe I'm doing something wrong. OR I'm just a complete blockhead which is at times very possible .

From what I read in the forums and manual. You can silence the alarm/chirp on the 02 bugeyes. I've even had a few people who own Subaru's try and they couldn't really understand why it didn't/wouldn't work. Now I need a new fob and I'm wondering if I'll be even able to program it.
TogeTouge2.0 is offline   Reply With Quote
Old 05-13-2013, 05:11 AM   #562
Roy3000gt
Scooby Newbie
 
Member#: 333650
Join Date: Sep 2012
Chapter/Region: PRSIC
Location: Japan
Vehicle:
2000 Lecacy Blitzen
Black

Exclamation 2000 Subaru Legacy Blitzen Remote

I lost my keys of my subaru some time ago. I have a copy and I managed to get another key remote (the B4 or Blitzen model I have is Japanese version and the system posses the key attach to the remote and is a black square shape). I tried several techniques such as the lock-on cycle 10 times in less than 15 seconds and no honk. Is there a way to program this remote, please help. Thanks.
Roy3000gt is offline   Reply With Quote
Old 05-15-2013, 04:57 PM   #563
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by TogeTouge2.0 View Post
I'll pose the question again since no one has at least given me a reason as to why I may be having a problem or maybe I'm doing something wrong. OR I'm just a complete blockhead which is at times very possible .

From what I read in the forums and manual. You can silence the alarm/chirp on the 02 bugeyes. I've even had a few people who own Subaru's try and they couldn't really understand why it didn't/wouldn't work. Now I need a new fob and I'm wondering if I'll be even able to program it.
Are you just trying to turn off the beep or put it in valet mode?

To turn off the beep, press and hold BOTH buttons on the (OEM) remote until the horn honks.....turn it back on the same way. It takes about 3 seconds or so of continuosly holding the buttons
RexyGirl is offline   Reply With Quote
Old 05-25-2013, 08:22 AM   #564
TogeTouge2.0
Scooby Newbie
 
Member#: 342681
Join Date: Jan 2013
Chapter/Region: NESIC
Location: Boston
Vehicle:
02 Wrx
Red

Default

Quote:
Originally Posted by RexyGirl View Post
Are you just trying to turn off the beep or put it in valet mode?

To turn off the beep, press and hold BOTH buttons on the (OEM) remote until the horn honks.....turn it back on the same way. It takes about 3 seconds or so of continuosly holding the buttons

Finally, Help has arrived!!! Thanks for the reply.

I'm just trying to turn off the beep/chirp.
I've attempted the holding of BOTH buttons on the remote and nothing. It will chirp/beep but then it will be 3 times instead of twice when I lock/unlock it. This is the OEM remote with the gray buttons for the bugeye. Seems as if no one can turn of the beep/chirp aside from taking a trip to the dealer.

I have to be doing something wrong.
TogeTouge2.0 is offline   Reply With Quote
Old 06-03-2013, 06:40 PM   #565
Rialb22
Scooby Newbie
 
Member#: 352342
Join Date: Apr 2013
Chapter/Region: VIC
Location: North Vancouver
Vehicle:
2000 2.5rs coupe
Blue Ridge Pearl

Default

solved

Last edited by Rialb22; 06-04-2013 at 05:58 PM. Reason: solved
Rialb22 is offline   Reply With Quote
Old 06-04-2013, 11:46 AM   #566
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by TogeTouge2.0 View Post
Finally, Help has arrived!!! Thanks for the reply.

I'm just trying to turn off the beep/chirp.
I've attempted the holding of BOTH buttons on the remote and nothing. It will chirp/beep but then it will be 3 times instead of twice when I lock/unlock it. This is the OEM remote with the gray buttons for the bugeye. Seems as if no one can turn of the beep/chirp aside from taking a trip to the dealer.

I have to be doing something wrong.
Make sure nothing is open, doors, trunk, hood. It should only beep twice when locking and unlocking. If it is doing it 3 times, it's possible that someone hooked up an aftermarket alarm in addition to the factory system.

Holding both buttons, with all the doors/windows/trunk/hood shut should turn it on and off......
RexyGirl is offline   Reply With Quote
Old 06-11-2013, 01:38 PM   #567
the_toaster
Scooby Newbie
 
Member#: 358883
Join Date: Jun 2013
Chapter/Region: NESIC
Vehicle:
2008 WRX Hatchback
Silver

Default

I recently purchased a 2008 Subaru Impreza WRX Hatchback. It was purchased at auction and did not include a keyless entry transmitter, so I obtained one from the dealer who sold me the car. I followed these directions, and these directions to program the new remote, but neither one worked.

When I complete the steps in the first source, the car locks and then unlocks the doors to indicate that the process of programming the system was successful. The remote does not communicate with the car, though -- pressing the "lock" and "unlock" buttons does not lock or unlock the doors.

When I try following the steps in the second source, it fails near the beginning; I turn the key ten times within fifteen seconds to enter programming mode, but instead of the horn beeping twice there is an electronic beep that comes through the speakers. It enters the programming mode described in the previous paragraph.

I even purchased a second remote on ebay, followed the same directions (entering the different code), and got the same result.

Is it possible that the receiver in the car is malfunctioning?

How does this system work?

Has anyone dealt with this issue before? My search yielded no results, but perhaps I was not using the correct search terms.

I'd appreciate any insight anyone has to offer.

Thanks!
the_toaster is offline   Reply With Quote
Old 06-13-2013, 05:42 PM   #568
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by the_toaster View Post
I recently purchased a 2008 Subaru Impreza WRX Hatchback. It was purchased at auction and did not include a keyless entry transmitter, so I obtained one from the dealer who sold me the car. I followed these directions, and these directions to program the new remote, but neither one worked.

When I complete the steps in the first source, the car locks and then unlocks the doors to indicate that the process of programming the system was successful. The remote does not communicate with the car, though -- pressing the "lock" and "unlock" buttons does not lock or unlock the doors.

When I try following the steps in the second source, it fails near the beginning; I turn the key ten times within fifteen seconds to enter programming mode, but instead of the horn beeping twice there is an electronic beep that comes through the speakers. It enters the programming mode described in the previous paragraph.

I even purchased a second remote on ebay, followed the same directions (entering the different code), and got the same result.

Is it possible that the receiver in the car is malfunctioning?

How does this system work?

Has anyone dealt with this issue before? My search yielded no results, but perhaps I was not using the correct search terms.

I'd appreciate any insight anyone has to offer.

Thanks!

You need to follow the second set of instructions. The beep is telling you that there are additional steps that need to be taken. It is a very long and tedious process. It might just be worth it to take it to a dealer and have them program it with the computer, which will take about 20 minutes.
RexyGirl is offline   Reply With Quote
Old 06-14-2013, 01:59 PM   #569
the_toaster
Scooby Newbie
 
Member#: 358883
Join Date: Jun 2013
Chapter/Region: NESIC
Vehicle:
2008 WRX Hatchback
Silver

Default

Quote:
Originally Posted by RexyGirl View Post
You need to follow the second set of instructions. The beep is telling you that there are additional steps that need to be taken. It is a very long and tedious process. It might just be worth it to take it to a dealer and have them program it with the computer, which will take about 20 minutes.
Thanks for the reply! The problem is that the horn doesn't beep. After I turn the key from "Lock" to "On" ten times and then open the door, I get the 30 second long electronic tone (as described in the first set of directions). This led me to believe that the first set of instructions were the correct ones.

I was hoping to avoid the cost and hassle of taking it to a dealer (the earliest appointment I could get is two weeks from now), but I think that's what I'll end up doing. Unlocking the doors with the key is getting old.
the_toaster is offline   Reply With Quote
Old 06-23-2013, 01:19 AM   #570
Rialb22
Scooby Newbie
 
Member#: 352342
Join Date: Apr 2013
Chapter/Region: VIC
Location: North Vancouver
Vehicle:
2000 2.5rs coupe
Blue Ridge Pearl

Default

Hello all,

I am a new member here on Nasioc after buying my 2000 2.5rs a couple months ago and have I ever been enjoying it. Been dreaming of having this car for a long time. One of the things I was so happy to have was keyless entry. It's awesome! Well... until it stops working! A couple weeks ago it just quit on me. Everything in the car works except for the remote lock and unlock. So I've gone into electrical troubleshooting;
Replaced both fob batteries,
Charged and load tested car battery,
Replaced corroded battery ends and then got really into it.. Made completely new ground cable's for the entire engine bay. (Thought bad ground was the problem)
Checked all the fuses in the engine bay box and the under dash box as well as the harness to the keyless entry control module.
On and on and on untill I'm up-to my eyeballs in wiring!

http://i1332.photobucket.com/albums/...g?t=1371960846

So here's what I've worked it down to:
Disconnect the connector that is in front of the dead pedal in the picture, reconnect it, then the keyless buttons work again! But as soon as I stop pressing buttons it stops responding until I unplug it again. In the world of electricity world, what does this mean?

I have been reading posts for weeks now and studying wiring diagrams and just not giving up! But I need a hand. Can anyone shed some of their electrical insight please?
Rialb22 is offline   Reply With Quote
Old 07-05-2013, 01:42 PM   #571
TogeTouge2.0
Scooby Newbie
 
Member#: 342681
Join Date: Jan 2013
Chapter/Region: NESIC
Location: Boston
Vehicle:
02 Wrx
Red

Default

Quote:
Originally Posted by RexyGirl View Post
Make sure nothing is open, doors, trunk, hood. It should only beep twice when locking and unlocking. If it is doing it 3 times, it's possible that someone hooked up an aftermarket alarm in addition to the factory system.

Holding both buttons, with all the doors/windows/trunk/hood shut should turn it on and off......
Thanks Rexy. But there was no aftermarket alarm system installed. I guess I may have to live with chirp. But all ideas are welcomed. Thanks again RexyGirl.
TogeTouge2.0 is offline   Reply With Quote
Old 07-18-2013, 12:03 AM   #572
ToddMcF2002
Scooby Specialist
 
Member#: 135007
Join Date: Dec 2006
Location: Plymouth, MA
Vehicle:
2014 STi Hatch
Crystal Black Silica

Default

OK I bought a 2002 Wrx that has power locks and the keyless entry module (I just found it next to fuse box) but I have no remotes. I'm buying remote blanks and I was trying to get it into programming mode following the directions. Unfortunately after multiple attempts I'm still getting no horn sound. Since there is no alarm I'm assuming there is no valet issue here. Any thoughts? Great thread BTW...
ToddMcF2002 is offline   Reply With Quote
Old 07-22-2013, 06:29 PM   #573
subygiirl91
Scooby Newbie
 
Member#: 363032
Join Date: Jul 2013
Vehicle:
2002 legacy
blue

Default

I just bought a 2002 Subaru legacy - and I was just wondering if the instructions would work for mine?
subygiirl91 is offline   Reply With Quote
Old 07-25-2013, 02:25 PM   #574
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by ToddMcF2002 View Post
OK I bought a 2002 Wrx that has power locks and the keyless entry module (I just found it next to fuse box) but I have no remotes. I'm buying remote blanks and I was trying to get it into programming mode following the directions. Unfortunately after multiple attempts I'm still getting no horn sound. Since there is no alarm I'm assuming there is no valet issue here. Any thoughts? Great thread BTW...
Disconnect the battery for a few minutes and then follow the steps in the first post.

Also, keep turning the key quickly....sometimes you have to turn it more than 10
RexyGirl is offline   Reply With Quote
Old 07-25-2013, 02:26 PM   #575
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by subygiirl91 View Post
I just bought a 2002 Subaru legacy - and I was just wondering if the instructions would work for mine?
Yes....as long as it is a factory Subaru system
RexyGirl is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Factory Alarm + Keyless entry from 04 FXT Skidd Interior/Dressup/Audio & Security 0 01-22-2009 09:26 PM
Factory alarm/keyless entry install - Anyone want to help?! NickWRX Tri-State Area Forum 3 07-06-2008 10:22 PM
All you need to know about ass hair. WRick Off-Topic 22 01-23-2006 08:22 PM
Factory Alarm / Keyless entry Woody Vancouver Impreza Club Forum -- VIC 3 04-22-2002 12:51 AM
Factory alarm/keyless entry on MY01 Safir Car Audio, Video & Security 1 02-08-2001 02:01 PM


All times are GMT -4. The time now is 08:50 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.