Welcome to the North American Subaru Impreza Owners Club Thursday July 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-07-2013, 02:21 AM   #26
My_06WRX
Scooby Newbie
 
Member#: 344000
Join Date: Jan 2013
Default

thats because its not a honda! lol jk guys. hope it works out for ya.
* Registered users of the site do not see these ads.
My_06WRX is offline   Reply With Quote
Old 02-07-2013, 12:04 PM   #27
insaneimpreza
Scooby Newbie
 
Member#: 83291
Join Date: Mar 2005
Location: NE PA
Vehicle:
1998 Subaru RSTi
Red

Default

Ive had that happen with bad valve springs on old school NA cars. Not sure if that helps your or not, but it was just like that!
insaneimpreza is offline   Reply With Quote
Old 02-07-2013, 02:47 PM   #28
ecbmxer
Scooby Newbie
 
Member#: 228059
Join Date: Oct 2009
Chapter/Region: MAIC
Location: Pittsburgh, PA
Vehicle:
2010 WRX
Spark Silver Metallic

Default

Are you maxing out your MAF scaling?
ecbmxer is offline   Reply With Quote
Old 03-23-2013, 01:48 AM   #29
banshee04
Scooby Specialist
 
Member#: 179014
Join Date: May 2008
Location: Oklahoma City, OK
Vehicle:
'06 WRX/STi
Built Motor/6766/E85

Default

So I pulled the motor out of the car the other day and found something that shocked me. The rear intake cam cap bolts were loose! Im willing to bet this was the problem.

banshee04 is offline   Reply With Quote
Old 03-23-2013, 10:01 AM   #30
Leafy
Scooby Specialist
 
Member#: 330625
Join Date: Aug 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2006 WRX
WRB

Default

Um wow, did expect that one.
Leafy is offline   Reply With Quote
Old 03-26-2013, 12:09 PM   #31
banshee04
Scooby Specialist
 
Member#: 179014
Join Date: May 2008
Location: Oklahoma City, OK
Vehicle:
'06 WRX/STi
Built Motor/6766/E85

Default

Quote:
Originally Posted by Leafy View Post
Um wow, did expect that one.
Me either. Hoping this is the fix!
banshee04 is offline   Reply With Quote
Old 06-02-2013, 11:12 PM   #32
banshee04
Scooby Specialist
 
Member#: 179014
Join Date: May 2008
Location: Oklahoma City, OK
Vehicle:
'06 WRX/STi
Built Motor/6766/E85

Default

Finally got the car back together about a week ago and the problem is gone!

The stock valve springs had seen better days. I could almost fully compress some of them by hand!

Now the car revs all the way to 8000rpms!
banshee04 is offline   Reply With Quote
Old 06-03-2013, 08:31 AM   #33
Leafy
Scooby Specialist
 
Member#: 330625
Join Date: Aug 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2006 WRX
WRB

Default

Ah, valve float. Normally that makes such a terrible racket that its obvious.
Leafy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.