Welcome to the North American Subaru Impreza Owners Club Monday December 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-21-2013, 12:36 PM   #1
xdarkn3ss
Scooby Newbie
 
Member#: 180912
Join Date: May 2008
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2004 WRX
PSM

Question Boost oscillation (yes I've searched and nothing helped)

So before someone posts "google search" or "just search for oscillation duh!" I have done so extensively and found nothing that helped.

04 wrx sedan 120k miles
Injen CAI
5zigen CBE
grimmspeed coated UP
finely tuned MAF myself
replaced boost control T hose and restrictor pill (so yes I KNOW it is there)
Factory BCS seems to be working fine
Recently cleaned MAF sensor and IACV (2-3k miles ago)
WG arm has never been lengthened or shortened

Boost is oscillating wildly at WOT, it will spike up a little past .1mpa (yes I have the stupid lamco gauge) and then fly back to .5mpa and repeat constantly.

The oscillation is slightly less violent with higher ambient air temps. Log posted, any help is appreciated.

https://docs.google.com/file/d/0B9np...it?usp=sharing

https://docs.google.com/file/d/0B9np...it?usp=sharing
* Registered users of the site do not see these ads.
xdarkn3ss is offline   Reply With Quote
Old 03-21-2013, 01:21 PM   #2
insaneimpreza
Scooby Newbie
 
Member#: 83291
Join Date: Mar 2005
Location: NE PA
Vehicle:
1998 RSTi
Ej257 GTX3576r

Default

Log WGDC%, target boost, actual boost and compare them to your file. You are likely overshooting on the WGDC%.
insaneimpreza is offline   Reply With Quote
Old 03-21-2013, 01:40 PM   #3
xdarkn3ss
Scooby Newbie
 
Member#: 180912
Join Date: May 2008
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2004 WRX
PSM

Default

Quote:
Originally Posted by insaneimpreza View Post
Log WGDC%, target boost, actual boost and compare them to your file. You are likely overshooting on the WGDC%.
I am overshooting target boost BUT my WGDC is below its specified value at some points on the table, for example at 4k rpm my map says to use up to 69.9% WGDC to reach a target boost of 13.61psi at WOT...but in reality at an RPM of 4507 my car reached close to its target boost (13.93psi) at 72.55% WGDC (second link line 59) and then WGDC starts to slowly taper down but boost keeps climbing rapidly and by 4750 with WOT my car is only using 43.53% WGDC and its still hitting 16.25psi, meanwhile continuous TD is saying "NO STOP" and attempting to correct by lowering WGDC by -4.84% (second link line 66)

So am I supposed to go drop my WGDC table drastically to compensate or do I change my TD tables?

More importantly why would this happen? I am not heavily modded and the mods I do have shouldn't be effecting boost this drastically right? A nice UP will increase spool time that's about it as far as I know.
xdarkn3ss is offline   Reply With Quote
Old 03-21-2013, 02:10 PM   #4
endrswrd
Scooby Specialist
 
Member#: 323908
Join Date: Jun 2012
Chapter/Region: MWSOC
Location: Dayton Ohio
Vehicle:
2013 BRZ ltd
ISM

Default

Either your WG tables are wacked out or your TD tables are jacked. If you are stock turbo I would return those tables to stock and see what happens.
endrswrd is offline   Reply With Quote
Old 03-21-2013, 02:12 PM   #5
medamullet
Scooby Guru
 
Member#: 99442
Join Date: Oct 2005
Chapter/Region: International
Location: Man of Mystery
Vehicle:
2006 SGM STI
I'm on CORN YO!

Default

put on a MBC and see if it goes away. if so throw away your stock EBC
medamullet is offline   Reply With Quote
Old 03-21-2013, 02:18 PM   #6
xdarkn3ss
Scooby Newbie
 
Member#: 180912
Join Date: May 2008
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2004 WRX
PSM

Default

Quote:
Originally Posted by endrswrd View Post
Either your WG tables are wacked out or your TD tables are jacked. If you are stock turbo I would return those tables to stock and see what happens.
All boost related tables (target boost, wgdc, TD, and all compensations) are at stock values and have never been tampered with. I even verified this by comparing to OEM ROM tables.
xdarkn3ss is offline   Reply With Quote
Old 03-21-2013, 03:20 PM   #7
jbulls93
Scooby Newbie
 
Member#: 315840
Join Date: Apr 2012
Chapter/Region: Tri-State
Location: New York
Vehicle:
2000 2.5rs

Default

Quote:
Originally Posted by medamullet View Post
put on a MBC and see if it goes away. if so throw away your stock EBC
I completely agree with this post. Stock EBCS is an avoidable headache if you are looking for power levels greater than stock.
jbulls93 is offline   Reply With Quote
Old 03-21-2013, 03:28 PM   #8
xdarkn3ss
Scooby Newbie
 
Member#: 180912
Join Date: May 2008
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2004 WRX
PSM

Default

Quote:
Originally Posted by jbulls93 View Post
I completely agree with this post. Stock EBCS is an avoidable headache if you are looking for power levels greater than stock.
I actually never said I was trying for power levels over stock I have an overboosting and oscillation issue. I'm not trying to gain power I'm trying to fix a problem.

If I were going for power gains I would grab a prodrive 3 port like I had on my last WRX and just use the maps I have from that car. This is a stock boost setup and I intend to keep it that way for awhile.
xdarkn3ss is offline   Reply With Quote
Old 03-23-2013, 07:46 PM   #9
Black94Snake
Scooby Specialist
 
Member#: 274499
Join Date: Feb 2011
Chapter/Region: NESIC
Location: RI
Vehicle:
1994 5.8T Cobra
565rwhp @ 10psi

Default

Quote:
Originally Posted by xdarkn3ss View Post

I actually never said I was trying for power levels over stock I have an overboosting and oscillation issue. I'm not trying to gain power I'm trying to fix a problem.

If I were going for power gains I would grab a prodrive 3 port like I had on my last WRX and just use the maps I have from that car. This is a stock boost setup and I intend to keep it that way for awhile.
There is no need for a 3 port, you just need to adjust your wgdc table properly. If you want some help, pm me and ill get you going in the right direction.
Black94Snake is online now   Reply With Quote
Old 03-24-2013, 08:56 AM   #10
quazimoto
Scooby Guru
 
Member#: 70395
Join Date: Sep 2004
Chapter/Region: MAIC
Location: Da-boonies,Va
Default

Are you running the stock DP and stock boost levels? Post your ROM up on Romraider and link it back here.
quazimoto is online now   Reply With Quote
Old 03-24-2013, 04:03 PM   #11
xdarkn3ss
Scooby Newbie
 
Member#: 180912
Join Date: May 2008
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2004 WRX
PSM

Default

Quote:
Originally Posted by Black94Snake View Post

There is no need for a 3 port, you just need to adjust your wgdc table properly. If you want some help, pm me and ill get you going in the right direction.
I've been getting help from a guy on rom raider forums, adjusting the TD tables down by about 50% got me holding pretty steady boost now working on the WGDC table since my stock bcs seems to be making more than stock boost which is actually pretty sweet lol.

Quote:
Originally Posted by quazimoto View Post
Are you running the stock DP and stock boost levels? Post your ROM up on Romraider and link it back here.
Indeed I am running the stock DP and boost levels.
xdarkn3ss is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:56 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.