Welcome to the North American Subaru Impreza Owners Club Saturday December 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-15-2013, 03:04 PM   #401
Ultimateone
Scooby Guru
 
Member#: 48025
Join Date: Nov 2003
Chapter/Region: NESIC
Location: By the Ocean, MA
Vehicle:
2015 WRX
ISM

Default

My Axxess SWC has completely gone crazy the last few weeks, I take a turn the volume goes up, hit a bump I lose all controls and my steering wheel buttons do nothing. I have reset the Aswc so many times and the wiring seems fine. I have no idea what to do?
* Registered users of the site do not see these ads.
Ultimateone is offline   Reply With Quote
Old 03-15-2013, 03:07 PM   #402
slowhat
Scooby Newbie
 
Member#: 304175
Join Date: Dec 2011
Location: Richmond, VA
Vehicle:
2012 WRX Limited
PBP

Default

Quote:
Originally Posted by Ultimateone View Post
My Axxess SWC has completely gone crazy the last few weeks, I take a turn the volume goes up, hit a bump I lose all controls and my steering wheel buttons do nothing. I have reset the Aswc so many times and the wiring seems fine. I have no idea what to do?
strange. sounds to me like there may be a physical issue with the actual buttons on the steering wheel. has you wheel ever been taken apart?

maybe pop out the aftermarket H/U and hook up the stock one and see if the problem repeats itself?
slowhat is offline   Reply With Quote
Old 03-15-2013, 07:12 PM   #403
Ultimateone
Scooby Guru
 
Member#: 48025
Join Date: Nov 2003
Chapter/Region: NESIC
Location: By the Ocean, MA
Vehicle:
2015 WRX
ISM

Default

Nope, I dont have the stocker anymore. Can the aswc not work right if its moving around? like not attached to something?
Ultimateone is offline   Reply With Quote
Old 03-15-2013, 07:28 PM   #404
aod12
Scooby Specialist
 
Member#: 282701
Join Date: May 2011
Chapter/Region: Tri-State
Location: New York
Vehicle:
2008 FXT
WRB

Default

Did you solder or crimp? Crimping can lead to it disconnecting on bumps since its not so secure
aod12 is offline   Reply With Quote
Old 03-16-2013, 08:41 PM   #405
Ultimateone
Scooby Guru
 
Member#: 48025
Join Date: Nov 2003
Chapter/Region: NESIC
Location: By the Ocean, MA
Vehicle:
2015 WRX
ISM

Default

solder, I checked the plug into the aswc and it wasn't super tight I think that was the trick
Ultimateone is offline   Reply With Quote
Old 03-26-2013, 04:01 PM   #406
foolycooly
Scooby Specialist
 
Member#: 260545
Join Date: Oct 2010
Chapter/Region: MAIC
Vehicle:
2011 WRX Limited 4dr
WRB

Default

This thread was very helpful. A couple of questions:

If I don't have a soldering iron of any kind, is this still a DIY with the correct harnesses? I consider myself above average capable for projects like these, but have never done any car audio work.

Also, how would this unit compare to the other models I'm seeing such as the AVH X3500, 4500, 5500, etc.? I am having trouble finding a decent comparison. It seems like the 5500 might have better resolution than the P4400, but I'm not certain.

Current reviews suggest that the x5500bhs is iphone 5 friendly and it doesn't seem like I would need the accessory cable if all I wanted to do was stream audio (song information is apparently pushed over BT on this model).

I appreciate any input.
foolycooly is offline   Reply With Quote
Old 03-26-2013, 04:06 PM   #407
slowhat
Scooby Newbie
 
Member#: 304175
Join Date: Dec 2011
Location: Richmond, VA
Vehicle:
2012 WRX Limited
PBP

Default

Quote:
Originally Posted by foolycooly View Post
This thread was very helpful. A couple of questions:

If I don't have a soldering iron of any kind, is this still a DIY with the correct harnesses? I consider myself above average capable for projects like these, but have never done any car audio work.

Also, how would this unit compare to the other models I'm seeing such as the AVH X3500, 4500, 5500, etc.? I am having trouble finding a decent comparison. It seems like the 5500 might have better resolution than the P4400, but I'm not certain.

Current reviews suggest that the x5500bhs is iphone 5 friendly and it doesn't seem like I would need the accessory cable if all I wanted to do was stream audio (song information is apparently pushed over BT on this model).

I appreciate any input.
This does not require soldering. I'm lazy and have used only crimps on about a dozen stereo installs. I've never had a problem with the connection.

unfortunately, i can't speak on the model comparisons.
slowhat is offline   Reply With Quote
Old 03-26-2013, 04:10 PM   #408
foolycooly
Scooby Specialist
 
Member#: 260545
Join Date: Oct 2010
Chapter/Region: MAIC
Vehicle:
2011 WRX Limited 4dr
WRB

Default

Quote:
Originally Posted by slowhat View Post
This does not require soldering. I'm lazy and have used only crimps on about a dozen stereo installs. I've never had a problem with the connection.

unfortunately, i can't speak on the model comparisons.
Great--thanks. Can you link me to what you would consider the appropriate tools and/or hardware to cut and crimp the necessary wires between the stock/pioneer/xdc harnesses?
foolycooly is offline   Reply With Quote
Old 03-26-2013, 08:42 PM   #409
BWX
Scooby Specialist
 
Member#: 236305
Join Date: Jan 2010
Location: South Central.. NY
Vehicle:
2009 2.5i 4dr 5spd
Newport Blue Pearl

Default

Yeah crimps are fine if you crimp them properly with the proper sized crimps and correct crimping tool.

This is the last bag I bought.. I have some from different stores around town too..

http://www.sonicelectronix.com/item_...BC1614SNB.html

BWX is offline   Reply With Quote
Old 03-26-2013, 11:40 PM   #410
foolycooly
Scooby Specialist
 
Member#: 260545
Join Date: Oct 2010
Chapter/Region: MAIC
Vehicle:
2011 WRX Limited 4dr
WRB

Default

Change of plans, gonna go ahead and solder/heat shrink. Borrowing my friend's legit one instead of going for the $15 amazon special.

Thanks for the help--i'll post pics when it's done.
foolycooly is offline   Reply With Quote
Old 03-27-2013, 11:36 AM   #411
soobie doo
Scooby Newbie
 
Member#: 324017
Join Date: Jun 2012
Location: Philly Burbs
Vehicle:
2012 Impreza 2.0i
Ice Silver Metallic

Default

So I'm installing the 3500 BHS, four new door speakers, and a backup camera in my 2012 Impreza on Saturday. Trying to decide if I should just do the parking brake bypass at the same time. I may try just living with the restrictions, and put in the bypass at a later date if they really bug me.

Does anyone have a definitive list of what functions are blocked while driving? The only things I've seen mentioned are watching video and dialing a phone number using the bluetooth keypad. Neither of those things sound like they'd be a major inconvenience to me.

I'll post some photos and my general impressions with the upgrades later this weekend.
soobie doo is offline   Reply With Quote
Old 03-27-2013, 11:41 AM   #412
foolycooly
Scooby Specialist
 
Member#: 260545
Join Date: Oct 2010
Chapter/Region: MAIC
Vehicle:
2011 WRX Limited 4dr
WRB

Default

Quote:
Originally Posted by soobie doo View Post
So I'm installing the 3500 BHS, four new door speakers, and a backup camera in my 2012 Impreza on Saturday. Trying to decide if I should just do the parking brake bypass at the same time. I may try just living with the restrictions, and put in the bypass at a later date if they really bug me.

Does anyone have a definitive list of what functions are blocked while driving? The only things I've seen mentioned are watching video and dialing a phone number using the bluetooth keypad. Neither of those things sound like they'd be a major inconvenience to me.

I'll post some photos and my general impressions with the upgrades later this weekend.
Did you get the harness from SVXdc?
foolycooly is offline   Reply With Quote
Old 03-27-2013, 12:04 PM   #413
yudangorgor
Scooby Newbie
 
Member#: 151107
Join Date: Jun 2007
Location: Toronto
Vehicle:
2011 WRX
SWP

Default

i have the x4500bt install and my stock speakers sound wonderful.. still thinking if i should put in speakers.

i got the bypass installed at the same time so i don't have to take it out and install again..
i didn't get the bypass so i can watch video while i drive, but it was more for the keypad.. rather than scrolling through my phone to dial, i can just dial on the HU which in my opinion is safer than scrolling through the phone
yudangorgor is online now   Reply With Quote
Old 03-27-2013, 01:51 PM   #414
soobie doo
Scooby Newbie
 
Member#: 324017
Join Date: Jun 2012
Location: Philly Burbs
Vehicle:
2012 Impreza 2.0i
Ice Silver Metallic

Default

Quote:
Originally Posted by foolycooly View Post
Did you get the harness from SVXdc?
Nope, I have a Metra harness.

Also, I have a base model, so I don't have to deal with steering wheel controls.

Last edited by soobie doo; 03-27-2013 at 02:07 PM.
soobie doo is offline   Reply With Quote
Old 03-27-2013, 03:12 PM   #415
foolycooly
Scooby Specialist
 
Member#: 260545
Join Date: Oct 2010
Chapter/Region: MAIC
Vehicle:
2011 WRX Limited 4dr
WRB

Default

Ah, got it.

On an unrelated note--for the parking brake bypass, I understand the 3 wires that need to be connected. From a technique standpoint, can anyone give some insight into how you would connect/solder the wires in a "T" configuration? I understand the correct way to "twist" opposing wires for a one to one connection before soldering, but what would be the best way to connect 3 or more wires?

On the bypass, the light green "parking" wire is the only one that seems to terminate at the bypass itself. The other two wires (ground and blue) seem to only tap into the existing harness connections.

Hopefully this will all be clearer when I have all of the harnesses in front of me. I'm just having some trouble getting through to SVXdc.
foolycooly is offline   Reply With Quote
Old 03-27-2013, 07:28 PM   #416
freddyo_0
Scooby Newbie
 
Member#: 339277
Join Date: Nov 2012
Vehicle:
2011 WRX STI Limited
SWP

Default

Quote:
Originally Posted by foolycooly View Post
Hopefully this will all be clearer when I have all of the harnesses in front of me. I'm just having some trouble getting through to SVXdc.
Did you e-mail him? He'll reply for sure, just give him a bit. As for the parking brake bypass, I'd do the recommended twisting then bring in the extra wire and try to weave it between the grooves of the two twisted wires. Soldering everything will hold the wiring very well.
freddyo_0 is offline   Reply With Quote
Old 03-28-2013, 11:55 AM   #417
foolycooly
Scooby Specialist
 
Member#: 260545
Join Date: Oct 2010
Chapter/Region: MAIC
Vehicle:
2011 WRX Limited 4dr
WRB

Default

Quote:
Originally Posted by freddyo_0 View Post
Did you e-mail him? He'll reply for sure, just give him a bit. As for the parking brake bypass, I'd do the recommended twisting then bring in the extra wire and try to weave it between the grooves of the two twisted wires. Soldering everything will hold the wiring very well.
Yep, I got through to him and placed an order for the harness and ASWC. Was anyone able to successfully mount the aftermarket BT mic to the stock location in the map light cluster? If so, what interior panels did you have to remove (other than the cluster cover itself)?

I would really like it to stay hidden, so I'm thinking of trying to go out from the HU down into the footwell, across somewhere clear of the pedals, up the A-pillar and across/tucked into the head liner to map light cluster. I'm just not sure how easily removable the stock mic is.
foolycooly is offline   Reply With Quote
Old 03-30-2013, 12:19 AM   #418
yes4idol
Scooby Newbie
 
Member#: 316621
Join Date: Apr 2012
Chapter/Region: MWSOC
Location: Buffalo Grove, IL
Vehicle:
2012 WRX Hatch Stg 1
Cobb SF Intake, SPT CBE

Default

AVH-X3500BHS Installed. These 2013 models come with Appradio where you can connect your smartphone to use Advanced Apps on the radio itself such as Google Maps, Calendar, Pandora and other supported app.
Removing the heating duct really helps if you want to feed the USB/iPhone cables under the center console. I kept the SWC BT buttons as +/- and Mute instead of the standard phone functions.
The radio gives the stock speakers a really good workout. Much better sound now. Install took a total of 3 hours with about 2.5 hrs scratching my head and trying to solder everything perfectly. There's so much room in the back of the center console behind the radio. You can probably fit another radio or two in there. No joke.
yes4idol is offline   Reply With Quote
Old 03-30-2013, 12:29 AM   #419
Imprezzedwitsubies
Scooby Newbie
 
Member#: 216116
Join Date: Jul 2009
Chapter/Region: South East
Location: Tampa, FL
Vehicle:
2015 BRZ Limited
14' Triumph America

Default

Very Nice. Pioneer makes quality H/U's. i have an Avic U310BT with nav, bluetooth, and ipod connection and its still running strong 4 years later!
Imprezzedwitsubies is offline   Reply With Quote
Old 03-30-2013, 02:41 AM   #420
foolycooly
Scooby Specialist
 
Member#: 260545
Join Date: Oct 2010
Chapter/Region: MAIC
Vehicle:
2011 WRX Limited 4dr
WRB

Default

Awesome...I ordered the X5500BHS and harnesses recently and can't wait for them to get here. I don't think I'll ever use the appradio function so I skipped the iphone cable (i do all my music via BT).

Where did you end up mounting the mic?
foolycooly is offline   Reply With Quote
Old 03-30-2013, 01:27 PM   #421
yes4idol
Scooby Newbie
 
Member#: 316621
Join Date: Apr 2012
Chapter/Region: MWSOC
Location: Buffalo Grove, IL
Vehicle:
2012 WRX Hatch Stg 1
Cobb SF Intake, SPT CBE

Default

Quote:
Originally Posted by foolycooly View Post
Awesome...I ordered the X5500BHS and harnesses recently and can't wait for them to get here. I don't think I'll ever use the appradio function so I skipped the iphone cable (i do all my music via BT).

Where did you end up mounting the mic?
I got the iPhone cable on ebay for 14 bucks so it was well worth it considering AppRadio gives you Apps for navigation. It also charges the phone so that saves me from plugging in another charging cable to the cigarette lighter.

http://www.ebay.com/itm/400428005357...84.m1439.l2649


I mounted the mic right in front of my steering wheel (same as Slowhat's mounting position on the 1st page of this thread)
yes4idol is offline   Reply With Quote
Old 04-02-2013, 03:01 AM   #422
BizzarBoxerXt
Scooby Specialist
 
Member#: 77200
Join Date: Dec 2004
Chapter/Region: NESIC
Location: Groton, CT
Vehicle:
2002 WRX
WRB w/BoBo trunk monkey

Default

So I'm going to be honest and didnt feel like reading through 17 pages.

But has anyone had issues with the mic not picking up very well? (yes I have mic volume all the way up) But whenever I'm on the road I have to just about yell at the top of my lungs or the other person cant hear me very well.

That being said my car has about 24sq ft of dynamat in the doors and doesnt have an incredibly loud exhaust (cobb). Any advice would be awesome. I've tried mounting the mic by the main cluster (behind steering wheel), top of A-Pillar, Behind visor and a couple other places.
BizzarBoxerXt is offline   Reply With Quote
Old 04-03-2013, 09:46 PM   #423
foolycooly
Scooby Specialist
 
Member#: 260545
Join Date: Oct 2010
Chapter/Region: MAIC
Vehicle:
2011 WRX Limited 4dr
WRB

Default

My AVH-X5500BHS came in today and I decided to start working on wiring the harness up with the ASWC and parking brake bypass. This is my first time doing anything like this and wanted to confirm my ground connections. I figured that there would be time where I would need to tie 3 wires together, but I ended up with FIVE ground wires connecting at this point:



These are:

1. Ground from Pioneer Harness
2. Ground from SvxDC 20-pin forward harness
3. Brown/Black from SvxDC 20-pin forward harness
4. Ground from ASWC
5. Ground from Parking Brake Bypass

Will this present any issues? I am still waiting on my soldering iron to arrive, but will I be ok just soldering this cluster together? Anything special I should do in this case? I am just putting heat shrink in place and hand tying everything to confirm connections for now.

I appreciate any input.
foolycooly is offline   Reply With Quote
Old 04-04-2013, 03:36 PM   #424
yes4idol
Scooby Newbie
 
Member#: 316621
Join Date: Apr 2012
Chapter/Region: MWSOC
Location: Buffalo Grove, IL
Vehicle:
2012 WRX Hatch Stg 1
Cobb SF Intake, SPT CBE

Default

Looks fine to me. That's exactly how I wired mine up.
yes4idol is offline   Reply With Quote
Old 04-05-2013, 05:37 AM   #425
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

The wire twist looks OK. But you need to think ahead on how the heat shrink will work. (hint -- you'll want to pre-position the HS tube so that you can slide it over the junction after you've soldered it.

So in your picture, the tube at the bottom won't work.

You want a tube around the two wires at the upper-left. Or change the tube at the bottom to include the wire going off to the right.

Slide the HS far enough away so that it doesn't start shrinking while you're soldering.

Here's a good guide I found on how to twist and solder wires together:
http://www.whoolie.com/solder.htm
To join more than 2, start with the first two as shown there, and then spiral each additional wire around the initial junction, ending up with all wires parallel. Remember to slide heat shrink over all of the wires on one side before you start. Then solder the whole set together at one time.
SVXdc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch "clicking" in 2012 wrx STIDAWG Transmission (AT/MT) & Driveline 7 03-17-2013 12:22 AM
Where to ground in 2012 wrx hatch? slowhat Car Audio, Video & Security 3 02-25-2012 12:35 AM
pioneer avh-p4000 install in 06sti nation1979 Car Audio, Video & Security 25 02-26-2009 02:47 AM
Pictures of Hid's installed in '02 WRX :) paultg New England Impreza Club Forum -- NESIC 7 12-16-2001 05:22 PM
Found out a short throw shifter wasn't installed in my WRX.. cout Bay Area Impreza Club Forum -- BAIC 5 05-03-2001 06:59 PM


All times are GMT -4. The time now is 02:50 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.