Welcome to the North American Subaru Impreza Owners Club Tuesday November 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-24-2013, 10:16 PM   #2801
PearlRex11
Scooby Specialist
 
Member#: 284420
Join Date: Jun 2011
Chapter/Region: SWIC
Location: Lakewood, Ca
Vehicle:
2011 WRX Sedan
SWP

Default

Quote:
Originally Posted by _davin View Post

I hope not, I'm about to order a Mach V EBCS and install my AVO TMIC and Perrin turbo inlet...
I would definitely take it into consideration. I've seen 2 shops have issues tuning a setup like I mentioned, one of them was Cobb Socal.
* Registered users of the site do not see these ads.
PearlRex11 is online now   Reply With Quote
Old 03-24-2013, 10:21 PM   #2802
_davin
Scooby Specialist
 
Member#: 260501
Join Date: Oct 2010
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
2011 WRX 5dr SWP Ltd

Default

Oh well, I guess we'll find out. Worst case scenario I have an excuse to order the downpipe I really wanted.

Actually now that I think about it, it would cost about the same to just get the new EWG setup from Cobb.
_davin is online now   Reply With Quote
Old 03-24-2013, 10:28 PM   #2803
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

lol EWG
Celery GT-5 is offline   Reply With Quote
Old 03-25-2013, 01:35 AM   #2804
tcoffin014
Scooby Newbie
 
Member#: 173734
Join Date: Mar 2008
Chapter/Region: South East
Location: Denham Springs, Louisiana
Vehicle:
2011 WRX
Sexy White Princess

Default

I had ebcs, catless dp, cat back exhaust, intake and a high flow intercooler for a while with a tp tune and no problems. I just recently sold the intercooler to get some extra money and everything still works fine. They do have high and low wastegate duty cycle ots maps that I hear usually fix the over boost and under boost issues. I have a friend with the spearco intercooler, ebcs, intake, cat back exhaust running 20 psi on Erics stage 3 map and he's never had a problem with over boosting either except for once when there were 5 people in the car and he got on it in 4th at low revs
tcoffin014 is offline   Reply With Quote
Old 03-25-2013, 02:11 AM   #2805
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

I think the whole problem is blown out of proportion
Celery GT-5 is offline   Reply With Quote
Old 03-30-2013, 11:03 AM   #2806
tcoffin014
Scooby Newbie
 
Member#: 173734
Join Date: Mar 2008
Chapter/Region: South East
Location: Denham Springs, Louisiana
Vehicle:
2011 WRX
Sexy White Princess

Default

Well something is going on with my clutch again. It's starting to make the squeak noise like the firewall welds are breaking. I hope that's not the case. I'm gonna check it out later when I have the time
tcoffin014 is offline   Reply With Quote
Old 04-11-2013, 02:34 PM   #2807
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

so has anyone blown the end tanks off their stock tmic?
Celery GT-5 is offline   Reply With Quote
Old 04-11-2013, 02:41 PM   #2808
SWP is Sexy
Scooby Specialist
 
Member#: 302389
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Houston
Vehicle:
2011 WRX
I'm a stormtrooper pewpew

Default

I got the BP kit preemptively, so not me
SWP is Sexy is online now   Reply With Quote
Old 04-11-2013, 03:39 PM   #2809
Asharus
Scooby Specialist
 
Member#: 276300
Join Date: Mar 2011
Vehicle:
2015 Ford Mustang GT
Oxford White

Default

i got a PW TMIC when i went stage 2, didnt wanna risk it. i did not verify whether or not the plastic endtank myth is a reality
Asharus is offline   Reply With Quote
Old 04-11-2013, 05:01 PM   #2810
SWP is Sexy
Scooby Specialist
 
Member#: 302389
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Houston
Vehicle:
2011 WRX
I'm a stormtrooper pewpew

Default

I can testify that the press-on clips looked like they had been under pressure and starting to pull away when I put the BP kit on, but nothing gave out.
SWP is Sexy is online now   Reply With Quote
Old 04-11-2013, 05:24 PM   #2811
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

hrm

so I was bored today, put my cobbs SF back on and did some before and after virtual dyno pulls. I did two graphs because it got too crowded and also the pulls were done in 2 different spots





seems to hold a bit more boost up top
I think the IAT was a bit higher with cobb

Last edited by Celery GT-5; 04-11-2013 at 05:39 PM.
Celery GT-5 is offline   Reply With Quote
Old 04-11-2013, 07:40 PM   #2812
_davin
Scooby Specialist
 
Member#: 260501
Join Date: Oct 2010
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
2011 WRX 5dr SWP Ltd

Default

I started having a problem with my e-brake yesterday, or maybe it's not a problem. When I release the lever it feels loose, like the cable is slack and the brake is still engaged. But it doesn't seem to be. After I drive around for awhile it seems to tighten back up, but happens again the next time I use it. When I first noticed it I drove for a bit and then touched the rear rotors and didn't burn myself so hopefully I'm not wearing anything out.
_davin is online now   Reply With Quote
Old 04-12-2013, 02:22 AM   #2813
PearlRex11
Scooby Specialist
 
Member#: 284420
Join Date: Jun 2011
Chapter/Region: SWIC
Location: Lakewood, Ca
Vehicle:
2011 WRX Sedan
SWP

Default

Quote:
Originally Posted by tcoffin014 View Post
Well something is going on with my clutch again. It's starting to make the squeak noise like the firewall welds are breaking. I hope that's not the case. I'm gonna check it out later when I have the time
Mine was squeaking really bad at the last inch of the pedal being pushed all the way in. I pushed the pedal in with my hand and squirted white lithium grease inside where the clutch linkage goes through the firewall. Seems to have fixed it now.
PearlRex11 is online now   Reply With Quote
Old 04-12-2013, 02:24 AM   #2814
PearlRex11
Scooby Specialist
 
Member#: 284420
Join Date: Jun 2011
Chapter/Region: SWIC
Location: Lakewood, Ca
Vehicle:
2011 WRX Sedan
SWP

Default

Quote:
Originally Posted by SWP is Sexy View Post
I can testify that the press-on clips looked like they had been under pressure and starting to pull away when I put the BP kit on, but nothing gave out.
I keep telling myself I'm going to buy this. Did you use the zip ties or bolts?
PearlRex11 is online now   Reply With Quote
Old 04-12-2013, 02:51 AM   #2815
SWP is Sexy
Scooby Specialist
 
Member#: 302389
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Houston
Vehicle:
2011 WRX
I'm a stormtrooper pewpew

Default

The stainless zip ties, theyre even just an excess measure though. The rails are so tight it took a rubber mallet to get them on all the way lol
SWP is Sexy is online now   Reply With Quote
Old 04-12-2013, 10:15 AM   #2816
PearlRex11
Scooby Specialist
 
Member#: 284420
Join Date: Jun 2011
Chapter/Region: SWIC
Location: Lakewood, Ca
Vehicle:
2011 WRX Sedan
SWP

Default

Quote:
Originally Posted by SWP is Sexy View Post
The stainless zip ties, theyre even just an excess measure though. The rails are so tight it took a rubber mallet to get them on all the way lol
Cool, I think it looks cleaner with the zip ties. Thanks
PearlRex11 is online now   Reply With Quote
Old 04-12-2013, 11:52 AM   #2817
SWP is Sexy
Scooby Specialist
 
Member#: 302389
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Houston
Vehicle:
2011 WRX
I'm a stormtrooper pewpew

Default

Agreed, if you're not paying attention you wouldn't notice it at all. I forget it's on there sometimes lol
SWP is Sexy is online now   Reply With Quote
Old 04-12-2013, 12:03 PM   #2818
PearlRex11
Scooby Specialist
 
Member#: 284420
Join Date: Jun 2011
Chapter/Region: SWIC
Location: Lakewood, Ca
Vehicle:
2011 WRX Sedan
SWP

Default

Yeah I want to get it, I do think $90 seems a little steep for the materials in the kit. It does however appear to be a fix for the stock tmic so that would justify the cost Imo.
PearlRex11 is online now   Reply With Quote
Old 04-12-2013, 01:20 PM   #2819
tcoffin014
Scooby Newbie
 
Member#: 173734
Join Date: Mar 2008
Chapter/Region: South East
Location: Denham Springs, Louisiana
Vehicle:
2011 WRX
Sexy White Princess

Default

Quote:
Originally Posted by PearlRex11 View Post

Mine was squeaking really bad at the last inch of the pedal being pushed all the way in. I pushed the pedal in with my hand and squirted white lithium grease inside where the clutch linkage goes through the firewall. Seems to have fixed it now.
I think that's where my problem is too. It stopped doing it the other day and hadn't really come back yet but I'm gonna grease it up if it comes back. Thanks
tcoffin014 is offline   Reply With Quote
Old 04-12-2013, 11:24 PM   #2820
SWP is Sexy
Scooby Specialist
 
Member#: 302389
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Houston
Vehicle:
2011 WRX
I'm a stormtrooper pewpew

Default

Quote:
Originally Posted by PearlRex11 View Post
Yeah I want to get it, I do think $90 seems a little steep for the materials in the kit. It does however appear to be a fix for the stock tmic so that would justify the cost Imo.
It is, but if you're planning on just running an ots map it's one of the best options for sure.
SWP is Sexy is online now   Reply With Quote
Old 04-12-2013, 11:26 PM   #2821
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

can't you just get some metal brackets yourself and bolt them on?
Celery GT-5 is offline   Reply With Quote
Old 04-12-2013, 11:29 PM   #2822
SWP is Sexy
Scooby Specialist
 
Member#: 302389
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Houston
Vehicle:
2011 WRX
I'm a stormtrooper pewpew

Default

If you can size them right, sure. I'm happy with the kit, is nice thick aluminum. Iirc it's cnc'd too. Pretty much as stable as you're practically gonna get
SWP is Sexy is online now   Reply With Quote
Old 04-12-2013, 11:34 PM   #2823
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

a guy I talk to on another forum said most 08+ tmic's have slight leaks even before the sides blow off. Not sure if I believe him, he said he would prove it the next time one comes through his shop. I think he knows his stuff but he is a much bigger troll than I am so idk..lol
Celery GT-5 is offline   Reply With Quote
Old 04-12-2013, 11:56 PM   #2824
SWP is Sexy
Scooby Specialist
 
Member#: 302389
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Houston
Vehicle:
2011 WRX
I'm a stormtrooper pewpew

Default

After seeing how those clips start to separate I believe it
SWP is Sexy is online now   Reply With Quote
Old 04-12-2013, 11:59 PM   #2825
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

yeah weaksauce
Celery GT-5 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Differences of 2011 wrx motor and 2011 sti motor stpkenton Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 3 03-06-2012 12:03 PM
Differences of 2011 wrx motor and 2011 sti motor stpkenton Newbies & FAQs 3 05-12-2011 10:27 PM
2011 Subaru shifter fitment! All TWM Shifters still fit! TWM Performance Vendor Announcements 14 02-28-2011 04:27 PM
iPod 3g DLO Jam Jacket (clear) and Radtech 3g Indigo Podsleev 10gb/15gb agentmaxwell Private 'For Sale' Classifieds 1 05-24-2006 08:41 PM
Attn: Clayton, Ben and all others involved in the 6MT discussion. sherifx Mid West Subaru Owners Club Forum -- MWSOC 1 07-31-2002 04:00 AM


All times are GMT -4. The time now is 07:17 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.