Welcome to the North American Subaru Impreza Owners Club Sunday September 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-27-2013, 10:55 AM   #9926
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2009 Impreza 2.5i 5D
Sunlight Gold Opal

Default

Quote:
Originally Posted by Sellars21 View Post
You have 5sp or 4eat?
5sp


Quote:
The message you have entered is too short. Please lengthen your message to at least 5 characters.
* Registered users of the site do not see these ads.
JourdanWithaU is online now   Reply With Quote
Old 03-27-2013, 12:05 PM   #9927
Silver08Waggs
Scooby Specialist
 
Member#: 283606
Join Date: May 2011
Chapter/Region: Tri-State
Location: Red Bank,NJ
Vehicle:
2008 Impreza 2.5i
Silver

Default

If anyone is interested I might sell the access port only work with 5speed pm me with any questions
Silver08Waggs is offline   Reply With Quote
Old 03-28-2013, 07:07 AM   #9928
Cmac13
Scooby Newbie
 
Member#: 312011
Join Date: Feb 2012
Location: Ontario Canada
Vehicle:
2009 impreza 2.5i
white

Default

My driver side hid keeps ****ting the bed :@ but when I turn it off then back on it's fine, does that mean its about to die?
Cmac13 is offline   Reply With Quote
Old 03-28-2013, 07:26 AM   #9929
BSP671
Scooby Newbie
 
Member#: 288190
Join Date: Jul 2011
Location: Guam
Vehicle:
2009 Impreza 2.5i
Spark Silver

Default

ballast maybe?
BSP671 is online now   Reply With Quote
Old 03-28-2013, 07:30 AM   #9930
Sellars21
Scooby Specialist
 
Member#: 304055
Join Date: Dec 2011
Location: Canada
Vehicle:
2008 2.5i Rallisport
UEL Headers Magnaflow CBE

Default

Quote:
Originally Posted by Cmac13
My driver side hid keeps ****ting the bed :@ but when I turn it off then back on it's fine, does that mean its about to die?
I found they didn't always fire right up if you leave your lights on the automatic position. So now after driving I turn the lights to off position, and when I turn them on I make sure they fire.

If left in on position while not lit, they can be damaged. If it won't turn on first try ever, it may be damaged.

Try swapping the ballasts to see you can narrow down the problem. And check the bulbs for darkness, shadows or cracks along the exterior wire.

If its still not working, let me know. I have a second kit collecting dust.

Last edited by Sellars21; 03-28-2013 at 08:38 AM.
Sellars21 is offline   Reply With Quote
Old 03-28-2013, 09:38 AM   #9931
Cmac13
Scooby Newbie
 
Member#: 312011
Join Date: Feb 2012
Location: Ontario Canada
Vehicle:
2009 impreza 2.5i
white

Default

Quote:
Originally Posted by Sellars21 View Post

I found they didn't always fire right up if you leave your lights on the automatic position. So now after driving I turn the lights to off position, and when I turn them on I make sure they fire.

If left in on position while not lit, they can be damaged. If it won't turn on first try ever, it may be damaged.

Try swapping the ballasts to see you can narrow down the problem. And check the bulbs for darkness, shadows or cracks along the exterior wire.

If its still not working, let me know. I have a second kit collecting dust.
Alright thanks! Ill let you know!
Cmac13 is offline   Reply With Quote
Old 03-28-2013, 10:22 AM   #9932
Silver08Waggs
Scooby Specialist
 
Member#: 283606
Join Date: May 2011
Chapter/Region: Tri-State
Location: Red Bank,NJ
Vehicle:
2008 Impreza 2.5i
Silver

Default

Heres the AP im trying to sell
Price is $215 shipped pm me or email me at V.Spinnato1@gmail.com

heres all the pictures i have








heres pictures of the maps




Silver08Waggs is offline   Reply With Quote
Old 03-28-2013, 03:52 PM   #9933
Fendyman
Scooby Specialist
 
Member#: 21542
Join Date: Jul 2002
Chapter/Region: BAIC
Location: San Francisco, CA
Vehicle:
2011 Impreza 2.5i
Dark Gray Metallic

Default

Quote:
Originally Posted by Silver08Waggs View Post
Heres the AP im trying to sell
Price is $215 shipped pm me or email me at V.Spinnato1@gmail.com
Does it work for 2011 model?
Fendyman is offline   Reply With Quote
Old 03-28-2013, 03:57 PM   #9934
Silver08Waggs
Scooby Specialist
 
Member#: 283606
Join Date: May 2011
Chapter/Region: Tri-State
Location: Red Bank,NJ
Vehicle:
2008 Impreza 2.5i
Silver

Default

Quote:
Originally Posted by Fendyman View Post

Does it work for 2011 model?
No only 5speed 2005-2008
Silver08Waggs is offline   Reply With Quote
Old 03-28-2013, 10:57 PM   #9935
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Spotted this just now in Los altos.



I know its one of the 2.5is on here... lol
theoutbackdream is offline   Reply With Quote
Old 03-29-2013, 07:17 AM   #9936
.HaVoK.
Scooby Specialist
 
Member#: 229726
Join Date: Nov 2009
Chapter/Region: Tri-State
Location: Westchester County
Vehicle:
'09 2.Slow
OBP

Default

^^
Jesus what kind of calculator did you take those pictures with?
.HaVoK. is offline   Reply With Quote
Old 03-29-2013, 08:16 AM   #9937
NH8991
Scooby Newbie
 
Member#: 197937
Join Date: Dec 2008
Chapter/Region: E. Canada
Location: Montreal, QC
Vehicle:
2009 Impreza 2.5i
Mk7 Golf R incoming

Default

Quote:
Originally Posted by .HaVoK. View Post
^^
Jesus what kind of calculator did you take those pictures with?
Maybe there was an earthquake going on at the time.
NH8991 is offline   Reply With Quote
Old 03-29-2013, 10:32 AM   #9938
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Quote:
Originally Posted by .HaVoK. View Post
^^
Jesus what kind of calculator did you take those pictures with?
Quote:
Originally Posted by NH8991 View Post

Maybe there was an earthquake going on at the time.
Lololol

It was a private lot so I took pics fastttt haha
theoutbackdream is offline   Reply With Quote
Old 03-29-2013, 08:56 PM   #9939
Tmangt650
Scooby Newbie
 
Member#: 277258
Join Date: Mar 2011
Chapter/Region: BAIC
Location: Bay Area, CA
Vehicle:
2008 Hatch 2.5i
DGM

Default

Quote:
Originally Posted by theoutbackdream View Post
Spotted this just now in Los altos.

I know its one of the 2.5is on here... lol
That my friend is mine! Spotted! Friend of bill w's?
Tmangt650 is offline   Reply With Quote
Old 03-29-2013, 09:13 PM   #9940
Imprezzedwitsubies
Scooby Newbie
 
Member#: 216116
Join Date: Jul 2009
Chapter/Region: South East
Location: Tampa, FL
Vehicle:
09 Impreza 2.5I
14' Triumph America

Default

Quote:
Originally Posted by Silver08Waggs View Post
No only 5speed 2005-2008
Damn that sucks I have an 09'
Imprezzedwitsubies is offline   Reply With Quote
Old 03-30-2013, 04:54 AM   #9941
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Quote:
Originally Posted by Tmangt650 View Post
That my friend is mine! Spotted! Friend of bill w's?
Sweet!

Nope, I was strolling down that street and i see a modded subie, which is very easy to spot in los altos, so i pull in and take pics, and realize ive seen it on nasioc.


You live in this area?
theoutbackdream is offline   Reply With Quote
Old 03-30-2013, 10:40 AM   #9942
Tmangt650
Scooby Newbie
 
Member#: 277258
Join Date: Mar 2011
Chapter/Region: BAIC
Location: Bay Area, CA
Vehicle:
2008 Hatch 2.5i
DGM

Default

Quote:
Originally Posted by theoutbackdream View Post

Sweet!

Nope, I was strolling down that street and i see a modded subie, which is very easy to spot in los altos, so i pull in and take pics, and realize ive seen it on nasioc.

You live in this area?
Oh gotcha. But don't live down there, up in San Mateo, just was there for a meeting..
Tmangt650 is offline   Reply With Quote
Old 03-30-2013, 12:32 PM   #9943
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Quote:
Originally Posted by Tmangt650 View Post

Oh gotcha. But don't live down there, up in San Mateo, just was there for a meeting..
Oh haha
theoutbackdream is offline   Reply With Quote
Old 03-30-2013, 07:14 PM   #9944
DownhillSubie
Scooby Newbie
 
Member#: 342985
Join Date: Jan 2013
Chapter/Region: Tri-State
Default

Any of you guys run a Curt trailer hitch on your 08-10 Sedans? I'm currently going through the 30 page tow thread on NASIOC but figured i'd ask those of you with my exact platform car.

Thanks!
DownhillSubie is offline   Reply With Quote
Old 03-30-2013, 10:05 PM   #9945
DirknJirkn13
Scooby Specialist
 
Member#: 249696
Join Date: Jun 2010
Chapter/Region: South East
Location: FL
Vehicle:
2010 Outback Sport
Black

Default

I finally installed a shorty antenna. I don't understand why the stock one has to be so long!
DirknJirkn13 is offline   Reply With Quote
Old 03-31-2013, 12:13 AM   #9946
Navysesal
Scooby Specialist
 
Member#: 305008
Join Date: Dec 2011
Chapter/Region: BAIC
Location: Bay Area
Vehicle:
2008 outback sport
Newport Blue Pearl

Default

Quote:
Originally Posted by DirknJirkn13 View Post
I finally installed a shorty antenna. I don't understand why the stock one has to be so long!
Notice any loss of reception?
Navysesal is offline   Reply With Quote
Old 03-31-2013, 03:19 AM   #9947
Slow Scoobie
Scooby Specialist
 
Member#: 320464
Join Date: May 2012
Chapter/Region: Tri-State
Location: Monmouth, NJ
Vehicle:
09 2.S"low"
Dark Gray Metallic

Default

It might be just me but I like the look of the stock antenna. I dont know why but I think the stocker looks just right.

Edit. After looking my stock antenna looks different than your stocker.
Slow Scoobie is online now   Reply With Quote
Old 03-31-2013, 03:23 AM   #9948
JourdanWithaU
Scooby Specialist
 
Member#: 146287
Join Date: Apr 2007
Chapter/Region: BAIC
Location: NOR-CAL (South Bay Area)
Vehicle:
2009 Impreza 2.5i 5D
Sunlight Gold Opal

Default

Sharkfin > *

I'm actually surprised by how well it works. Granted, I only use it to listen to Sharks games. But I can hear the game extremely clear.
JourdanWithaU is online now   Reply With Quote
Old 03-31-2013, 04:02 AM   #9949
BWX
Scooby Specialist
 
Member#: 236305
Join Date: Jan 2010
Location: South Central.. NY
Vehicle:
2009 2.5i 4dr 5spd
Newport Blue Pearl

Default

The stock antenna looks better if you tilt it back another 20 or so degrees too.. plus that one looks longer than mine, unless you just have tiny hands.
BWX is offline   Reply With Quote
Old 03-31-2013, 08:23 AM   #9950
DirknJirkn13
Scooby Specialist
 
Member#: 249696
Join Date: Jun 2010
Chapter/Region: South East
Location: FL
Vehicle:
2010 Outback Sport
Black

Default

Quote:
Originally Posted by Navysesal View Post
Notice any loss of reception?
I haven't had much of a chance to test it yet, but I didn't notice any difference from stock in my short testing.

Quote:
Originally Posted by Slow Scoobie View Post
It might be just me but I like the look of the stock antenna. I dont know why but I think the stocker looks just right.

Edit. After looking my stock antenna looks different than your stocker.
It doesn't look terrible, but I like the smaller one a little better. What's the difference between yours and mine?

Quote:
Originally Posted by JourdanWithaU View Post
Sharkfin > *

I'm actually surprised by how well it works. Granted, I only use it to listen to Sharks games. But I can hear the game extremely clear.
The Sharkfin is nice, but it's quite expensive imo. I only paid $5 for this one off someone on here, granted it is just an eBay model.

Oh and Pens > Sharks

Quote:
Originally Posted by BWX View Post
The stock antenna looks better if you tilt it back another 20 or so degrees too.. plus that one looks longer than mine, unless you just have tiny hands.
I used to tilt it down, but it would move every time I went through the car wash.

My hands are average size, and the stocker is 7 inches. Could just be that it being right next to the 2 inch shorty makes it look longer.
DirknJirkn13 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
08 2.5i and 08 Sti Suspension WRXbrother Brakes, Steering & Suspension 7 03-24-2012 02:14 PM
Will an 08 WRX intake fit an 08 2.5i? Racing101 Normally Aspirated Powertrain 26 01-19-2012 11:57 AM
08 STI Wing on 08 2.5i impreza juny102004 Interior & Exterior Modification 13 01-18-2012 09:46 AM
Will 08+ WRX gauges swap into 08+ 2.5i? Simeon Priest Interior & Exterior Modification 10 03-26-2010 02:17 PM
08 2.5i mod question deunique1 Impreza Forum 1 10-03-2007 02:35 PM


All times are GMT -4. The time now is 10:33 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.