Welcome to the North American Subaru Impreza Owners Club Tuesday July 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-07-2013, 04:28 PM   #1
PhotographerSteven
Scooby Newbie
 
Member#: 317761
Join Date: Apr 2012
Location: Pittsburgh, PA
Vehicle:
2012 WRX
OBP

Default squeaking noise when clutch pedal is fully released

So like the title says, my 2012 wrx is making a squeaking sound when at idle. I'm sure its either a throwout bearing or a rubbing/rattling fork, but wanted to make this thread to help out someone else down the road...

Here's what I know so far

About twice a week, usually after spirited, but not hard driving, I can feel a slight vibration while depressing the clutch pedal. I don't know if this is related to the sound I hear or not...

There is a squeaking noise that isn't terribly loud, but definitely audible with windows up. This noise was first noticed at 9000 miles. As soon as I could, I dropped the car off at the dealer, they couldn't replicate the noise and therefore didn't do anything...

Between then (jan 2013) and now (april 2013) I've noticed the squeaking three other times. Almost always it goes away after the car sits overnight.
Now at 13,400 miles, it started squeaking again, so I took some video with my phone for proof for my stealership...

http://www.youtube.com/watch?v=BPZSNzey0DA&feature=youtu.be
PhotographerSteven is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:34 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.