Welcome to the North American Subaru Impreza Owners Club Sunday September 14, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-08-2013, 03:25 PM   #1
brett192
Scooby Specialist
 
Member#: 274252
Join Date: Feb 2011
Chapter/Region: W. Canada
Location: Vancouver Island, BC
Vehicle:
2002 WRX Sedan PSM
Stage 2 w/ 6 speed

Default 2002 WRX trans might be toast, advice on 04 sti trans swap needed.

Hey guys, yesterday I took a right hand corner pretty slowly and leisurely, and heard a pop sound from under the car about half way around the corner. Since this happened, I am hearing a clunking/rattling noise when I am driving above 20 mph in gear with clutch pushed in OR in neutral.

I can also hear the noise when I am in gear with little to no load on the transmission, but once I accelerate or decelerate to a degree it will quiet then go away. Car drives and feels fine except this clunking noise.

I haven't gone over 50 mph, the sound gets worse the faster you go, coasting down a hill at 40 mph in neutral sounds terrible.

Last transmission fluid change was last February at 101700 kms, and I found a full tooth on the magnet plug.

I just turned 139,500 kms today and drained the fluid to find a suprisingly small amount of metal, or atleast a lot less than I expected..



I have asked on my local forum and the general consensus is to start sourcing a replacement transmission.. what do you all think?

If a new trans is needed, one local guy says he has a 2004 STI trans with around 90k kms. Since the 04 STI is 5x100 hubs, would a transmission swap need different axles or driveshaft and rear diff? Or is it a direct bolt on?

Thanks
brett192 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:55 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.