Welcome to the North American Subaru Impreza Owners Club Wednesday July 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-07-2013, 05:09 PM   #1
atyourfuneral
Scooby Newbie
 
Member#: 264167
Join Date: Nov 2010
Chapter/Region: MAIC
Location: York, PA
Vehicle:
2005 Impreza STi
CGM

Default High pitch noise almost like belts but not belts??

Friday my car started to make this really high pitch noise after I drive for about about 2 minutes. It is very similar to belt noise but is not the belts. It is very faint on idle and then off idle is when you really hear it. I took off belts also replaced the alternator and idle pulley for ac today and noise is still there. Will not make the noise until you drive maybe a mile down the road. Then every time you give it has its there.

I have read a few things about uppipe leaks making a noise but I figured that would be mainly when I'm under boost or really giving it gas. It has gt spec headers and up pipe, downpipe, intake, turbo inlet. This is on my 2002 wrx. Sound similar to anyone's experience? Thanks in advance.
* Registered users of the site do not see these ads.
atyourfuneral is offline   Reply With Quote
Old 04-07-2013, 09:12 PM   #2
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

a gasket leak can sound like a whistle or a 'kazoo'
Uncle Scotty is offline   Reply With Quote
Old 04-07-2013, 10:17 PM   #3
philly15
Scooby Specialist
 
Member#: 223137
Join Date: Sep 2009
Chapter/Region: MWSOC
Location: Appleton, WI
Vehicle:
14' super ultimate
race car project

Default

take the belts off all together and start it quick see if it makes noise if it doesnt its something run by the belts, also is it a constant noise or does it get louder/faster with acceleration
philly15 is offline   Reply With Quote
Old 04-08-2013, 03:12 PM   #4
atyourfuneral
Scooby Newbie
 
Member#: 264167
Join Date: Nov 2010
Chapter/Region: MAIC
Location: York, PA
Vehicle:
2005 Impreza STi
CGM

Default

Took both belts off and still have noise. Believe its coming from the timing belt. I had an oil change done and see where some oil must have spilled on the timing cover. Do you think that oil on the timing belt could cause noise. When I get the car put back together ill make a recording of the noise.
atyourfuneral is offline   Reply With Quote
Old 04-09-2013, 01:59 PM   #5
wrxpotter
Scooby Newbie
 
Member#: 344825
Join Date: Jan 2013
Chapter/Region: Tri-State
Location: York, PA
Vehicle:
2002 WRX
PSM

Default

I have been experiencing a similar issue. I'm getting a "squeak" noise randomly at idle that is indiscriminate of RPM and also very randomly while driving. My belts are all in excellent shape. Interested to see what you find out. I will be investigating further tomorrow.
wrxpotter is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:26 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.