Welcome to the North American Subaru Impreza Owners Club Saturday April 25, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-20-2013, 11:40 AM   #1
Pinned
Scooby Specialist
 
Member#: 152707
Join Date: Jun 2007
Chapter/Region: NESIC
Location: Western MA
Default Amp choices

So, my amp seems to have died...oh well.

I've got Focal components up front, some Boston composites as rear fill (though they've been disconnected, and I don't think I need them in a coupe), and 2 8" woofers in the rear side panels.

Looking at buying a used JL 300/4 for about $150 and then finding a JL 250/1 to run the subs. Or I could spend $300 and get a brand new, in box JL 600/4.

Can the 600/4 run the fronts and the subs without the subs being too much louder than the fronts? I really only use the subs as low end fill and don't want super loud bass. Would it be smarter to go with 2 separate amps or something that has a dedicated sub channel?

Thanks for any input.
Pinned is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:37 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.