Welcome to the North American Subaru Impreza Owners Club Thursday November 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-21-2013, 11:50 PM   #1
Ronen91
Scooby Newbie
 
Member#: 324810
Join Date: Jul 2012
Chapter/Region: MWSOC
Vehicle:
2013 STi
DGM

Have a Nice Day? '13 STi car stalling and sounded like engine is falling out O.O

2013 STi Base Sedan
4,950 miles

So I had this issue today, after coming back from getting gas, I was on the highway, getting off the on ramp.

There was bumper traffic, and I need to get in the other lane

At this point I was 2nd gear. I shift into neutral and managed to squeeze in a spot and came to a stop

Car was still on I put the clutch in, 1st gear, it felt as if the parking brake was on, and the car would not go

It sounded like the transmission was falling out of the car, and there was a loud smacking

It was as if the car stalled but didn't. I had to turn the car off and put it back into gear

I was terrified stuck in traffic

I managed to get a block from my house at the stop sign

1st->2nd rolling to my driveway, I put it in neutral and same loud smacking, and the car acted like it was dying.

I am terrified to drive the car, and I have a service appointment tomorrow.

I am coming in for some regular maintenance and now this =(

Anyone else have this similar issue?
Ronen91 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:30 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.