Welcome to the North American Subaru Impreza Owners Club Thursday July 30, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-21-2013, 04:42 PM   #1
roadtrip1098
Scooby Newbie
 
Member#: 185688
Join Date: Jul 2008
Chapter/Region: NESIC
Location: Maine
Vehicle:
2006 STi
WR Blue

Default Screaming noise after Perrin EL header install.

I just traded my GrimmSpeed headers to a friend for a set of Perrin EL headers. The car runs great, but when I get into boost, there's this screaming noise. I've checked for leaks, replaced all the gaskets, ect like it said to in other posts, but the screaming noise is still there... Any suggestions? The only thing I can think of is that he had an EWG in them that we welded shut, and it might not be 10000% smooth on the inside.
* Registered users of the site do not see these ads.
roadtrip1098 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-21-2013, 05:29 PM   #2
roadtrip1098
Scooby Newbie
 
Member#: 185688
Join Date: Jul 2008
Chapter/Region: NESIC
Location: Maine
Vehicle:
2006 STi
WR Blue

Default

NVM it was my wife.
roadtrip1098 is offline   Reply With Quote
Old 04-21-2013, 06:37 PM   #3
Francois_
Scooby Specialist
 
Member#: 284101
Join Date: May 2011
Chapter/Region: Tri-State
Location: Hawthorne, NJ
Vehicle:
2004 STI
world rally blue

Default

Quote:
Originally Posted by roadtrip1098 View Post
NVM it was my wife.
A+ thread. Would read again
Francois_ is offline   Reply With Quote
Old 04-22-2013, 10:25 PM   #4
art@grimmspeed
NASIOC Vendor
 
Member#: 301037
Join Date: Nov 2011
Chapter/Region: MWSOC
Location: Minneapolis, MN
Vehicle:
2004 Forester XT
Aspen White

Default

Now that's funny!
art@grimmspeed is offline   Reply With Quote
Old 04-22-2013, 10:30 PM   #5
Dmochowski
Scooby Specialist
 
Member#: 306478
Join Date: Jan 2012
Chapter/Region: South East
Location: chattanooga, TN
Vehicle:
2012 WRX limited
305whp/360tq TSM tuned

Default

didnt know gs made headers... and that screaming will stop after you put something in her mouth
Dmochowski is online now   Reply With Quote
Old 04-22-2013, 11:08 PM   #6
Uncle Scotty
Visiting NASIOC Timeout
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK buy Nates beans
westcoastroasting.com

Default

leak...
Uncle Scotty is offline   Reply With Quote
Old 04-23-2013, 01:24 AM   #7
scoobasaurusrex
Scooby Specialist
 
Member#: 255114
Join Date: Aug 2010
Chapter/Region: Tri-State
Vehicle:
2007 wrb wrx wagon
93oct vf43 ewg

Default

Quote:
Originally Posted by Dmochowski View Post
didnt know gs made headers... and that screaming will stop after you put something in her mouth
that's because they don't make headers, they just offer a PnP service on your stock mani.

OP, congrats on the interwebz for today!!! lolol
scoobasaurusrex is offline   Reply With Quote
Old 04-23-2013, 11:29 AM   #8
themaus
Scooby Newbie
 
Member#: 321211
Join Date: May 2012
Chapter/Region: South East
Default

10/10 would read again
themaus is offline   Reply With Quote
Old 04-24-2013, 10:30 AM   #9
nickysigz06sti
Scooby Newbie
 
Member#: 354054
Join Date: Apr 2013
Default

Lmao I get the same noises I think. ... would explain alot
nickysigz06sti is offline   Reply With Quote
Old 04-24-2013, 10:39 AM   #10
sultan81
Scooby Newbie
 
Member#: 309943
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Hampton Va
Vehicle:
2012 STi
OBP

Default

who put this on reddit?
sultan81 is offline   Reply With Quote
Old 04-24-2013, 10:40 AM   #11
nelso2sd
Scooby Newbie
 
Member#: 326285
Join Date: Jul 2012
Chapter/Region: RMIC
Location: Greenwood Village CO
Vehicle:
2010 WRX
Dark Grey Metallic

Default

Sultan gets an upvote
nelso2sd is offline   Reply With Quote
Old 04-24-2013, 10:50 AM   #12
voltic
Scooby Newbie
 
Member#: 310385
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Fredericksburg, VA
Vehicle:
2013 Rising Blue
4D Golf R

Default

I dunno but I upvoted! Comedy gold.
voltic is offline   Reply With Quote
Old 04-24-2013, 11:29 AM   #13
sultan81
Scooby Newbie
 
Member#: 309943
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Hampton Va
Vehicle:
2012 STi
OBP

Default

My wife actually saw it and sent me the link like an hour after i saw the thread.
sultan81 is offline   Reply With Quote
Old 04-24-2013, 11:48 AM   #14
PSSSHHH
Scooby Newbie
 
Member#: 227187
Join Date: Oct 2009
Chapter/Region: TXIC
Vehicle:
2004 WRX Premium
PSM

Default

Best of Nasioc!
PSSSHHH is offline   Reply With Quote
Old 04-24-2013, 11:08 PM   #15
sexyyrex
Scooby Specialist
 
Member#: 128022
Join Date: Oct 2006
Chapter/Region: Tri-State
Location: Danbury, CT
Vehicle:
2011 Infiniti G37x
Sedan

Default

Quote:
Originally Posted by roadtrip1098 View Post
I just traded my GrimmSpeed headers to a friend for a set of Perrin EL headers. The car runs great, but when I get into boost, there's this screaming noise. I've checked for leaks, replaced all the gaskets, ect like it said to in other posts, but the screaming noise is still there... Any suggestions? The only thing I can think of is that he had an EWG in them that we welded shut, and it might not be 10000% smooth on the inside.
Quote:
Originally Posted by roadtrip1098 View Post
NVM it was my wife.
best. thread. ever.
sexyyrex is offline   Reply With Quote
Old 08-08-2014, 09:39 AM   #16
Dill-Ag13
Scooby Newbie
 
Member#: 316535
Join Date: Apr 2012
Chapter/Region: TXIC
Location: The Woodlands, TX
Vehicle:
2007 WRX (Sold 2.0i)
Silver

Default

bump
Dill-Ag13 is offline   Reply With Quote
Old 08-08-2014, 10:35 AM   #17
Speedme3
Scooby Newbie
 
Member#: 378926
Join Date: Jan 2014
Chapter/Region: SWIC
Location: Gilbert, AZ
Vehicle:
2004 Baja Turbo
Silver

Default

Would read again
Speedme3 is offline   Reply With Quote
Old 08-11-2014, 12:32 PM   #18
MoRex
Scooby Specialist
 
Member#: 231966
Join Date: Dec 2009
Chapter/Region: VIC
Location: Victoria, BC
Vehicle:
2003 WRX
Pure Silver Metallic

Default

read this ages ago, was funny then.
A local subaru owner shared in our FB group.
Read again just now.
Still very good, passes the funny a year later test
MoRex is offline   Reply With Quote
Old 08-12-2014, 06:17 PM   #19
BroBroBroBroBro
Scooby Newbie
 
Member#: 338211
Join Date: Nov 2012
Chapter/Region: E. Canada
Location: Pemeal Bacon
Vehicle:
2011 wrx
12.9 @ 107

Default

it was the wifes puzzy queefing
BroBroBroBroBro is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:48 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.