Welcome to the North American Subaru Impreza Owners Club Wednesday November 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Vancouver Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Vancouver Impreza Club Forum -- VIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-26-2013, 12:20 AM   #1
renegade_obs
Scooby Newbie
 
Member#: 354527
Join Date: Apr 2013
Default good mechanic needed

hey guys im nathan. i need a good subaru mechanic on vancouver island. well to be honest i need the best subaru mechanic on the island. my 98 Impreza OBS has been one night mare for over a year now. im to the point where it needs to go into a shop and just be fixed or at least properly diagnosed.
* Registered users of the site do not see these ads.
renegade_obs is offline   Reply With Quote
Old 04-26-2013, 12:22 AM   #2
Bruere
Scooby Newbie
 
Member#: 353523
Join Date: Apr 2013
Chapter/Region: VIC
Vehicle:
1998 STi RA V-Ltd
Super Mica Blue

Default

Quote:
Originally Posted by renegade_obs View Post
hey guys im nathan. i need a good subaru mechanic on vancouver island. well to be honest i need the best subaru mechanic on the island. my 98 Impreza OBS has been one night mare for over a year now. im to the point where it needs to go into a shop and just be fixed or at least properly diagnosed.
Tons of excellent mechanics read this forum so you could maybe solicit some free advice by stating what issues you're having.

I don't know particularly of any excellent shops on the island.
Bruere is offline   Reply With Quote
Old 04-26-2013, 01:56 PM   #3
brett192
Scooby Specialist
 
Member#: 274252
Join Date: Feb 2011
Chapter/Region: W. Canada
Location: Vancouver Island, BC
Vehicle:
2002 WRX Sedan PSM
VF39 + 6 speed

Default

Where do you live on the island? Do you want to take it to a subaru dealership or a general mechanic?

I have had some good experiences with Three Point Motors Nanaimo. And have heard horror stories from Saunders in Victoria.
brett192 is offline   Reply With Quote
Old 04-26-2013, 05:55 PM   #4
renegade_obs
Scooby Newbie
 
Member#: 354527
Join Date: Apr 2013
Default

weather its a dealer or a general mechanic dosent matter. im in parksville. ive been to 3 point once for 3 hours and got no where. but from what i know 3 point is first and foremost a Mercedes dealer. i wasnt actually all that impressed with them. and one of my friends who does car detailing told me saunders seems to be good. and when ever i need info on parts and where things are hiddenly located on the car three point never gets back to me and saunders is always on the ball. even if there busy and say the'll call me back in a certain time they always call on time. but if its going to go to a general mechanic i need one who is fantastic with subarus.
renegade_obs is offline   Reply With Quote
Old 04-26-2013, 06:26 PM   #5
renegade_obs
Scooby Newbie
 
Member#: 354527
Join Date: Apr 2013
Default

the issue with the car was that about 2 years ago it started to develop a hesitation. it would idle fine and once you got the rpms above 2500 it was fine but between that it would try to bog and have no power at all. the only way i could at that time get it up to 2500rpm was to tap on the throttle really lightly and quickly and it would slowly pick up rpms. it threw a miss fire code on cyl 4. i got that cleared and when it went in to three point the miss fire code showed up on cyl's 1 & 2. now from what ive researched if its going to miss on more than one cyl its supposed to miss on 1&3 or 2&4. so the miss is kind of randomating it self. since then its sat and id get it fired up every month or so just to keep things some what lubricated and every now and then see if i could make any head way on the problem. the hesitation got to the point where it was too dangerous to drive. since parking it ive replaced the fuel filter, fuel pressure regulator, plugs & wires cleaned the TPS & IAC. run seafoam through most of the vacuum lines. done a fuel pressure test (tester was put on the hose from the fuel filter going to the hardline that runs under the intake. pressures were * vacuum hose attached to regulator 35-38 * vacuum hose detached from regulator 39. those were the numbers i got on the gauge we used. at that point it would still at least fire up and idle. then i replaced the vacuum line and T fitting that goes from the intake to the fuel pressure regulator and some other kinda redish brown piece on the passenger side shock tower. but in dooing so i deleted this little round thing that looks like its white plastic with foam in the line that goes to the piece in the shock tower. the next day i tried to fire it up and i couldnt get it to run. so i put the original vacuum hose with all the proper pieces back in and it still wouldnt fire up. on cranking every now and then it tries but it dosent quite fire enough to get it running at idle, it just stumbles momentarily to make me think its gunna fire up. .

heres word for word the list of things three point motors managed to check when i had it in to them.
*scanned car - came up miss fire on 1&2 checked plugs, wires, and coil they were ok. pulled out o2 sensor to check if exause was plugged, it wasnt. checked throttle plate checked EGR operation checked MAF sensor checked Oxygen sensor. will contact coustmer after talking to subaru expert. (in other words... they had to call subaru teck support back east)

so now im stuck with it not running at all. but when i could get it fired up it would idle fine, it would rev fine once above 2500 rpm but between idle and 2500rpm it wouldnt wana go, and if you dropped below that 2500 rpm then your back to square one.

any ideas?
renegade_obs is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:20 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.