Welcome to the North American Subaru Impreza Owners Club Thursday April 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-27-2013, 08:52 AM   #1
c-hush
Scooby Newbie
 
Member#: 330399
Join Date: Aug 2012
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2010 STI
Blanco

Default FATT April 26th photos

A few Subarus out there... unfortunately only the BRZ's sounded like they weren't having trouble engine-wise.















* Registered users of the site do not see these ads.
c-hush is offline   Reply With Quote
Old 04-29-2013, 10:13 AM   #2
DickEB
Scooby Newbie
 
Member#: 338509
Join Date: Nov 2012
Chapter/Region: MAIC
Location: Fairfax, VA
Vehicle:
2009 WRX Sedan
Silver

Default

That's me in the Silver '09 sedan. Did my car sound like it was having engine trouble? I wish I could just hear my car AT ALL out there on track...def need an exhaust. Your profile says you have a white STI, did you have it up there? Don't remember any white subies...
DickEB is offline   Reply With Quote
Old 04-29-2013, 02:58 PM   #3
phenryiv1
NASIOC Supporter
 
Member#: 91212
Join Date: Jul 2005
Chapter/Region: MAIC
Location: Martinsburg, WV
Vehicle:
2011 WRX 5DR
Satin White Pearl

Default

I need to get my track car finished and up to one of these...
phenryiv1 is offline   Reply With Quote
Old 04-30-2013, 10:08 AM   #4
c-hush
Scooby Newbie
 
Member#: 330399
Join Date: Aug 2012
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2010 STI
Blanco

Default

DickEB, I was there with my boss with the black 07 STI with #361 plastered all over it... I have yet to take mine out, just tag along and take some photos/videos.

Your car did not sound like it was having trouble, but you're right, it's not very loud.
c-hush is offline   Reply With Quote
Old 04-30-2013, 12:09 PM   #5
DickEB
Scooby Newbie
 
Member#: 338509
Join Date: Nov 2012
Chapter/Region: MAIC
Location: Fairfax, VA
Vehicle:
2009 WRX Sedan
Silver

Default

Quote:
Originally Posted by c-hush View Post
DickEB, I was there with my boss with the black 07 STI with #361 plastered all over it... I have yet to take mine out, just tag along and take some photos/videos.

Your car did not sound like it was having trouble, but you're right, it's not very loud.
Yeah I definitely checked out your bosses car...it looks like a beast! Can't believe you could cram that much tire underneath a WRX.
I talked with the guy who had the late model black STI. He claimed that noise it was making was just his wastegate. It was loud, whatever it was! He has a lot done to it - aftermarket turbo, exhaust, etc.
It is kind of annoying to not hear your own car out there, but I can hear my tires at least. I wasn't accidentally redlining or anything so it could be worse.
DickEB is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:17 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.