Welcome to the North American Subaru Impreza Owners Club Wednesday September 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 05-05-2013, 11:02 PM   #1
VonElling
Scooby Newbie
 
Member#: 344112
Join Date: Jan 2013
Location: East Grand Forks, MN
Vehicle:
2004 Impreza WRX STI
Aspen White

Default Opinions please

I have an 04 sti. The car has 117xxx miles and I have only owned it for about 10k of that. Over the last 10k miles I have made only one mod, the Cobb AP stage 1. Recently I have started to think the clutch is in need of replacement.

As far as I know it is stock. I read the FAQ on clutches, and shifting... In the shifting FAQ drdrum's shifting guide says to let the clutch out slowly and the car should get rolling... However in my car this is impossible.

While driving and shifting I notice the engagement it slow, and extremely soft. I often find it difficult to make a "perfect shift" under normal driving. I almost always notice I engage with not enough, or too much rpms. It doesn't seem to matter if I engage slowly or quickly.

I have driven manual trans cars before... But only a mustang (99 cobra) and a Camaro (01 SS). I never had any trouble.

How quickly should I be engaging the clutch under normal driving? Ease into it slowly, or rush it?

Does it sound like I need a new clutch, are there any ways to test for this?

I'm sorry to ask so much... I am honestly just lost here and desperate for an answer.

Thank you,
Travis.
VonElling is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:49 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.