Welcome to the North American Subaru Impreza Owners Club Tuesday December 1, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 05-08-2013, 12:20 AM   #1
Scooby Newbie
Member#: 312331
Join Date: Mar 2012
Chapter/Region: Tri-State
Location: Johnson City NY
2002 WRX
Sedona Red

Default Vibration and noise after bushing install

Hey guys, I have an issue I suppose we could call it with my 02 WRX with roughly 95k miles on it.

About 3 weeks ago I installed my Kartboy front and rear stays, as well as the TIC pivot bushing, I noticed about a week or so ago, that in gears 3-4 while engine braking/coasting around 2500RPMS I get a very loud rattle and vibration in the shift knob itself (STi piston style shifter) as well as noise, I tried driving without the knob on and I still hear it, it seems to get worse when I squeeze the knob or shifter arm.

Goes away mostly once I get on the gas, or upshift and the RPM drops to about 2k. The car was at the dealer for other work, and the tech said he tightened up the bolt for the front stay, which did nothing(noise was present before taking it in for work)

Other info for full disclosure, I kept bouncing my hand/arm off the cat heat shield quite a bit, while fighting with those stupid bushings, so I'm not sure if maybe I disturbed that.

Just trying to see if a vibration/rattle noise, while coasting is common after doing these mods.

Clutch kit was done about 2k miles before this so I don't believe its pilot bearing related.

Thanks guys.
* Registered users of the site do not see these ads.
Tavery92 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 09:15 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.