Welcome to the North American Subaru Impreza Owners Club Sunday September 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-04-2013, 06:07 PM   #1
RallyB
Scooby Newbie
 
Member#: 294247
Join Date: Sep 2011
Location: Pennsylvania
Vehicle:
2007 Impreza

Default 2.5i burning smell?

I have a 2007 impreza and legacy 2.5i, whenever I accelerate hard in either car I get a harsh burning smell that smells like burning oil but not completely. Any thoughts? Both cars are over 100k miles and have both had the head gaskets replaced
* Registered users of the site do not see these ads.
RallyB is offline   Reply With Quote
Old 05-04-2013, 11:55 PM   #2
Counterfit
Scooby Guru
 
Member#: 124254
Join Date: Aug 2006
Chapter/Region: NESIC
Location: Rhode Island
Vehicle:
2006 06 SGM Slowbaru
"The Scoobinator"

Default

Small oil leak, old or loose belt slipping and heating up. I don't remember if the Legacy had AVLS like the Impreza, but some of the external hardware for it has been known to leak.
Counterfit is offline   Reply With Quote
Old 05-06-2013, 09:59 AM   #3
wonder squirrel
Scooby Newbie
 
Member#: 176133
Join Date: Mar 2008
Default

I have a 2002 Subaru Legacy that I would get that oil burning smell from even though there were no oil leaks. Turns out the passenger side CV boot tore and slung grease out onto the exhaust, after driving for a bit, the exhaust would get hot and start burning the grease.
wonder squirrel is offline   Reply With Quote
Old 05-06-2013, 12:19 PM   #4
RallyB
Scooby Newbie
 
Member#: 294247
Join Date: Sep 2011
Location: Pennsylvania
Vehicle:
2007 Impreza

Default

Yeah I think its most likely oil related, the crush washer on the impreza is seeping out oil so thats probably where the smell is coming from on that. I had passed a camaro yesterday driving like an idiot but the same smell was coming from his car too so tbh im not going to worry about it
RallyB is offline   Reply With Quote
Old 05-06-2013, 04:15 PM   #5
Counterfit
Scooby Guru
 
Member#: 124254
Join Date: Aug 2006
Chapter/Region: NESIC
Location: Rhode Island
Vehicle:
2006 06 SGM Slowbaru
"The Scoobinator"

Default

I doubt a slightly leaky crush washer would result in a smell. The only thing it could drip on is the ground.
Counterfit is offline   Reply With Quote
Old 05-06-2013, 05:28 PM   #6
evilWagon
Scooby Newbie
 
Member#: 128739
Join Date: Oct 2006
Location: Ontario
Vehicle:
07 2.5i SE Wagon
OBP

Default

Do a visual check of your oil filter and see if there's drips on it. There's been problems with oil filters leaking under hard acceleration (high RPM's).
evilWagon is offline   Reply With Quote
Old 05-06-2013, 06:13 PM   #7
RallyB
Scooby Newbie
 
Member#: 294247
Join Date: Sep 2011
Location: Pennsylvania
Vehicle:
2007 Impreza

Default

False, the oil is collecting at the bottom of the oil pan after seeping out of the crush washer and blowing backward during driving, but I do agree it does not make sense anyway. And the filter is fine no trace of oil
RallyB is offline   Reply With Quote
Old 05-06-2013, 06:17 PM   #8
RallyB
Scooby Newbie
 
Member#: 294247
Join Date: Sep 2011
Location: Pennsylvania
Vehicle:
2007 Impreza

Default

Maybe a cat problem? It would be the only sign I have of a bad cat if so
RallyB is offline   Reply With Quote
Old 05-10-2013, 10:57 PM   #9
mathmagic22
Scooby Newbie
 
Member#: 342539
Join Date: Jan 2013
Default

it could be your head gaskets, i had that problem with my 07 2.5i at about 95k miles, did a full tuneup when it happened because of a lot of overlap labor, guess it happens a lot with subaru engines, hopefully it's not that gaskets though otherwise your looking at $1500
mathmagic22 is offline   Reply With Quote
Old 05-12-2013, 04:34 PM   #10
Ctelectrician
Scooby Newbie
 
Member#: 356222
Join Date: May 2013
Default

I just bought an 06 Impreza with the 2.5 and when I test drove the vehicle it had the same issue. Turns out that there are two sensors behind the upper radiator hose, the oil pressure and crank sensor. One of those was leaking oil and the oil was accumulating on the block, heating up and causing the smell. Check there. Hope this helps
Ctelectrician is offline   Reply With Quote
Old 05-12-2013, 05:13 PM   #11
RallyB
Scooby Newbie
 
Member#: 294247
Join Date: Sep 2011
Location: Pennsylvania
Vehicle:
2007 Impreza

Default

Alright I'll deff check there. I realized a few days ago that it happens more randomly now than on hard acceleration so I believe it may be the oil leaking out of my crush washer.

Last edited by RallyB; 05-12-2013 at 06:11 PM.
RallyB is offline   Reply With Quote
Old 05-12-2013, 08:44 PM   #12
Filthy_Mchaggis
Scooby Newbie
 
Member#: 275489
Join Date: Mar 2011
Chapter/Region: Tri-State
Location: Philadelphia
Vehicle:
2011 2.5i Premium
OBP

Default

I am having the same problem with my 2011. It's not just hard acceleration. The smell seems to come through the vents.
Filthy_Mchaggis is offline   Reply With Quote
Old 05-12-2013, 09:09 PM   #13
RallyB
Scooby Newbie
 
Member#: 294247
Join Date: Sep 2011
Location: Pennsylvania
Vehicle:
2007 Impreza

Default

Prob an oil leak somewhere like mine, I get it through the vents too but its worse with the windows down when it does stink
RallyB is offline   Reply With Quote
Old 05-12-2013, 09:10 PM   #14
RallyB
Scooby Newbie
 
Member#: 294247
Join Date: Sep 2011
Location: Pennsylvania
Vehicle:
2007 Impreza

Default

I thought it may just be a subi thing but now that its happening on my car ive been noticing it on all types of other cars too
RallyB is offline   Reply With Quote
Old 05-13-2013, 02:00 AM   #15
T-macks
Scooby Newbie
 
Member#: 350238
Join Date: Mar 2013
Chapter/Region: NWIC
Vehicle:
2008 WRX Hatch
Spark Silver Metallic

Default

Quote:
Originally Posted by mathmagic22 View Post
it could be your head gaskets, i had that problem with my 07 2.5i at about 95k miles, did a full tuneup when it happened because of a lot of overlap labor, guess it happens a lot with subaru engines, hopefully it's not that gaskets though otherwise your looking at $1500
+1 for head gaskets. Mine was doing it too. But not just from hard accerleration/high RPMs. I ignored it for months until I broke down. Turns out I had leaking head gaskets, a dropped valve guide, and a cracked head. So there was a ton of problems for mine, but you should definitely check your head gaskets.
T-macks is offline   Reply With Quote
Old 05-13-2013, 10:43 AM   #16
RallyB
Scooby Newbie
 
Member#: 294247
Join Date: Sep 2011
Location: Pennsylvania
Vehicle:
2007 Impreza

Default

Oh trust me ive checked them again and again and again and they aren't leaking for me. Plus mine were just replaced 15, 000 miles ago
RallyB is offline   Reply With Quote
Old 05-13-2013, 11:44 AM   #17
T-macks
Scooby Newbie
 
Member#: 350238
Join Date: Mar 2013
Chapter/Region: NWIC
Vehicle:
2008 WRX Hatch
Spark Silver Metallic

Default

Quote:
Originally Posted by RallyB View Post
Oh trust me ive checked them again and again and again and they aren't leaking for me. Plus mine were just replaced 15, 000 miles ago
You are very lucky then. Hopefully it's just a leak that's easily fixable.
T-macks is offline   Reply With Quote
Old 05-13-2013, 05:11 PM   #18
RallyB
Scooby Newbie
 
Member#: 294247
Join Date: Sep 2011
Location: Pennsylvania
Vehicle:
2007 Impreza

Default

Just checked them again, passenger side is dry as can be and the drivers side is wet, mind you my oil pan is leaking from the top and thats very close to the driver side head gasket. Cleaned it up and it looks like the driver side one may be seeping a bit. Im told seepage is normal though
RallyB is offline   Reply With Quote
Old 05-13-2013, 05:14 PM   #19
RallyB
Scooby Newbie
 
Member#: 294247
Join Date: Sep 2011
Location: Pennsylvania
Vehicle:
2007 Impreza

Default

And today the burning smell returned on the highway every time I accelerated hard, its becoming more of a exhaust burning smell and I do not see any leaks large enough to cause the amount of stink I have. Car has held a full level of oil for 1000 miles now too and my stink was happening before that last oil change.
RallyB is offline   Reply With Quote
Old 05-14-2013, 05:11 PM   #20
RallyB
Scooby Newbie
 
Member#: 294247
Join Date: Sep 2011
Location: Pennsylvania
Vehicle:
2007 Impreza

Default

Could it be a faulty oil pump at all?
RallyB is offline   Reply With Quote
Old 05-14-2013, 08:24 PM   #21
Ctelectrician
Scooby Newbie
 
Member#: 356222
Join Date: May 2013
Default

Did you look under and behind the alternator and see if the sensors were leaking?
Ctelectrician is offline   Reply With Quote
Old 05-15-2013, 01:52 AM   #22
RallyB
Scooby Newbie
 
Member#: 294247
Join Date: Sep 2011
Location: Pennsylvania
Vehicle:
2007 Impreza

Default

Yeah none of them are leaking, I just give up tbh. Ive been researching the crap out of this and no one has any solutions or fixes
RallyB is offline   Reply With Quote
Old 05-15-2013, 06:25 PM   #23
evilWagon
Scooby Newbie
 
Member#: 128739
Join Date: Oct 2006
Location: Ontario
Vehicle:
07 2.5i SE Wagon
OBP

Default

Why don't you fix the leaking crush washer to eliminate the obvious oil leak... and clean off the oil remnants.

Have you replaced the sparkplug gaskets as well?
evilWagon is offline   Reply With Quote
Old 05-15-2013, 06:39 PM   #24
RallyB
Scooby Newbie
 
Member#: 294247
Join Date: Sep 2011
Location: Pennsylvania
Vehicle:
2007 Impreza

Default

I will once I hit 3000 miles. I dont have the cash to do yet another 1000 mile oil change because of a leak. And no I havent, and cylinder 1 always has oil contamination but its been like that since ive owned the car, this "smell" just recently started
RallyB is offline   Reply With Quote
Old 05-17-2013, 09:06 AM   #25
evilWagon
Scooby Newbie
 
Member#: 128739
Join Date: Oct 2006
Location: Ontario
Vehicle:
07 2.5i SE Wagon
OBP

Default

I've had the (lack of) luck to have several oil leaks/oil burning/smell issues.

-Split Blue OEM oil filter dripping oil that wind pushed onto the header.
-Leaking AVLS sensor on the drivers head replaced under warranty.
-Oil leaking from the crush washer.
-Dealer splashed oil on the outside of the engine after an oil change.
-And spark plug tube seals leaking oil that would fill the cabin with the hot oil smell towards the last half of my hour long commute.
-I had the headgasket issue as well but that didn't contribute to much smell.

I'd suggest getting under there with some simple green after your next oil change and clean everything so you can find it easily if it continues.
evilWagon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:28 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.