Welcome to the North American Subaru Impreza Owners Club Saturday November 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-16-2013, 05:14 PM   #1
4ndy
Scooby Newbie
 
Member#: 279689
Join Date: Apr 2011
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2006 Impreza WRX STi
Black

Default Problem adjusting BC BR Coilover

was trying to lower my front end of my car. loosened up the bottom ring and was attempting to adjust the top out of the three to lower the car but the passenger side wont move at all. Drivers side lowered with no problem but even after using PB Blaster and a decent amount of man power i cant get it to budge.

I don't think its seized because they're only a year old but was wondering what you guys thought?

-Thanks for any input!
* Registered users of the site do not see these ads.
4ndy is offline   Reply With Quote
Old 05-18-2013, 10:43 AM   #2
4ndy
Scooby Newbie
 
Member#: 279689
Join Date: Apr 2011
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2006 Impreza WRX STi
Black

Default

let it soak in PB Blaster over night...still wont budge
4ndy is offline   Reply With Quote
Old 05-18-2013, 10:50 AM   #3
trinistyles
Scooby Specialist
 
Member#: 71627
Join Date: Sep 2004
Chapter/Region: Tri-State
Location: Ny/Nj/Li
Vehicle:
780 Wrx/Fozzy/Legee
Wbp/Dark gray/Bergundy

Default

You can use a dead blow hammer or rubber mallet to tap lightly round the ring or use a chisel and tap with a hammer just to loosing up.
trinistyles is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:11 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.