Welcome to the North American Subaru Impreza Owners Club Monday September 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-16-2013, 02:13 PM   #1
Impreza169
Scooby Newbie
 
Member#: 356558
Join Date: May 2013
Location: Oregon
Vehicle:
2007 Impreza 2.5i
Silver

Default 2.5i making rattling sound around 3k rpm

Anyone else ever have this problem? Doesn't seem to happen all the time but frequent enough to worry me. It's an 07 with 100k miles.
* Registered users of the site do not see these ads.
Impreza169 is offline   Reply With Quote
Old 05-16-2013, 02:56 PM   #2
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
QuickSilver Metallic

Default

Exhaust heat shield, perhaps?
Patrick Olsen is online now   Reply With Quote
Old 05-16-2013, 03:58 PM   #3
RecoveringSaabaholic
Scooby Newbie
 
Member#: 250265
Join Date: Jun 2010
Chapter/Region: NESIC
Location: Portland, ME
Vehicle:
2006 Impreza 2.5i
Blue

Default

Hopefully it is the exhaust. Try to have someone reproduce it while you walk around and get under the car. That will enable you to isolate where it is coming from. There are many different things that can cause a rattle on a car. Figuring out where it is coming from is the first step to solving the problem.

Good Luck!
RecoveringSaabaholic is offline   Reply With Quote
Old 05-16-2013, 05:47 PM   #4
Impreza169
Scooby Newbie
 
Member#: 356558
Join Date: May 2013
Location: Oregon
Vehicle:
2007 Impreza 2.5i
Silver

Default

It only seems to happen when I'm driving. In neutral, revving my engine I can't seem to mimic the noise.
Impreza169 is offline   Reply With Quote
Old 05-16-2013, 10:18 PM   #5
JohnM10
Scooby Newbie
 
Member#: 244231
Join Date: Apr 2010
Chapter/Region: NESIC
Location: Providence, RI, USA
Vehicle:
2006 Impreza 2.5i 5M
Crystal Grey Metallic

Default

My shifter rattles like crazy at high revs. I am pretty sure I have the heat shield rattles as well. I will be checking them again this weekend when I do a timing belt change.
JohnM10 is offline   Reply With Quote
Old 05-16-2013, 10:46 PM   #6
Impreza169
Scooby Newbie
 
Member#: 356558
Join Date: May 2013
Location: Oregon
Vehicle:
2007 Impreza 2.5i
Silver

Default

My shifter does the same! & alright. I need to do my timing belt soon too. Are you doing it yourself?
Impreza169 is offline   Reply With Quote
Old 05-17-2013, 10:18 AM   #7
chuds
Scooby Newbie
 
Member#: 245141
Join Date: Apr 2010
Chapter/Region: NESIC
Location: MA
Vehicle:
07 2.5i
cgm

Default

Just fixed my friends heat shield rattle on his legacy. Get under the car when its cool and give the shield and the entire exhaust system a good wiggle.
chuds is offline   Reply With Quote
Old 05-17-2013, 02:45 PM   #8
evilWagon
Scooby Newbie
 
Member#: 128739
Join Date: Oct 2006
Location: Ontario
Vehicle:
07 2.5i SE Wagon
OBP

Default

Quote:
Originally Posted by Impreza169 View Post
It only seems to happen when I'm driving. In neutral, revving my engine I can't seem to mimic the noise.
That was the same symptoms I had as well and it was the heat shield. A large pipe clamp around the heat shield beside the o2 sensor fixed it right up.
evilWagon is offline   Reply With Quote
Old 05-17-2013, 05:42 PM   #9
f4umt
Scooby Newbie
 
Member#: 283246
Join Date: May 2011
Chapter/Region: MWSOC
Location: Oshkosh
Vehicle:
06 OutbackSport SE

Default

I got the same thing on mine and I figure it's the heat shield on the headers. It's annoying but it doesn't bother me.
f4umt is offline   Reply With Quote
Old 05-17-2013, 05:46 PM   #10
Rudgers73
Scooby Newbie
 
Member#: 141433
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Rochester, NY
Vehicle:
2006 Impreza 2.5i
Obsidian Black

Default

I have a heat shield rattle at idle and it took me forever to figure out my rattle at 3000-4500 RPM on the highway was my shifter.

Try this: when it starts making the noise grab you shifter and put slight pressure to the left or right and see if it changes pitch or goes away
Rudgers73 is offline   Reply With Quote
Old 05-17-2013, 06:37 PM   #11
motohippy
Scooby Newbie
 
Member#: 225882
Join Date: Oct 2009
Location: Central NJ
Vehicle:
2000 OBS
'88 BMW K75S

Default

Got rid if the heat shield rattle with hose clamps, too...10k or so and they're still holding...
About that shifter rattle...did you find a way to quiet that down, it's getting to be annoying...
motohippy is offline   Reply With Quote
Old 05-17-2013, 09:28 PM   #12
Bluefoton
Scooby Specialist
 
Member#: 141373
Join Date: Feb 2007
Chapter/Region: E. Canada
Location: Quebec, QC
Vehicle:
2008 2.5i-hatch -
now with a HID retrofit

Default

The bloody shifter rattles on every damn 2.5l N/A around 4000 rpm, even more so if you change to a S.S. I flooded it with oil, made a huge tight knot with a rubber vacuum hose around the linkage area, attached a half-a-pound piece of metal to make everything heavier (and therefore dampen or change the frequency of the resonance) and wrapped all of that in electric tape. The leather boot barely fits over the shifter which is now harder to move, but the rattling ALMOST went away. I'd take a picture, but it's humiliating
Bluefoton is offline   Reply With Quote
Old 05-17-2013, 11:31 PM   #13
Agonist
Scooby Newbie
 
Member#: 356750
Join Date: May 2013
Chapter/Region: NESIC
Location: Southcoast MA
Vehicle:
05 WRX
Silver

Default

I had a similar rattle around 3k rpm in my 2008 2.5i a/t. any consensus on what it is?
Agonist is offline   Reply With Quote
Old 05-18-2013, 01:30 AM   #14
Impreza169
Scooby Newbie
 
Member#: 356558
Join Date: May 2013
Location: Oregon
Vehicle:
2007 Impreza 2.5i
Silver

Default

Quote:
Originally Posted by Bluefoton View Post
The bloody shifter rattles on every damn 2.5l N/A around 4000 rpm, even more so if you change to a S.S. I flooded it with oil, made a huge tight knot with a rubber vacuum hose around the linkage area, attached a half-a-pound piece of metal to make everything heavier (and therefore dampen or change the frequency of the resonance) and wrapped all of that in electric tape. The leather boot barely fits over the shifter which is now harder to move, but the rattling ALMOST went away. I'd take a picture, but it's humiliating
Haha! I'm not willing to go through all that to get rid of a little rattle. I always thought it was change in my cup holder or something until about last week.
Impreza169 is offline   Reply With Quote
Old 05-18-2013, 03:21 PM   #15
Pickler
Scooby Newbie
 
Member#: 301247
Join Date: Nov 2011
Location: Toronto
Vehicle:
09 Impreza 2.5i MT
White

Default

i have something like a rattle below 2500rpm on warm days:


No dealership or mechanic shop i took it to could fix it. They clamped my heatshields and tightened all the headers and bolts and whatever down there. It has not improved one bit. Funny thing is it doesn't happen in cold days.
Pickler is offline   Reply With Quote
Old 05-28-2013, 10:23 PM   #16
wkoscielny
Scooby Newbie
 
Member#: 357785
Join Date: May 2013
Default

I've heard the only option is the remove the heat shielding around the exhaust.
wkoscielny is offline   Reply With Quote
Old 06-03-2013, 09:32 PM   #17
evilWagon
Scooby Newbie
 
Member#: 128739
Join Date: Oct 2006
Location: Ontario
Vehicle:
07 2.5i SE Wagon
OBP

Default

Quote:
Originally Posted by wkoscielny View Post
I've heard the only option is the remove the heat shielding around the exhaust.
Or do what I mentioned and add a pipe clamp to squeeze the two pieces together gently and stop them vibrating. Ghetto slightly, but I didn't want to loose the heat shield and for $0.99 it was a great fix.
evilWagon is offline   Reply With Quote
Old 06-03-2013, 09:54 PM   #18
RaceFaceXC
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: stupid Florida
Vehicle:
2007 No YELLING
on the bus!

Default

Quote:
Originally Posted by Bluefoton View Post
The bloody shifter rattles on every damn 2.5l N/A around 4000 rpm, even more so if you change to a S.S. I flooded it with oil, made a huge tight knot with a rubber vacuum hose around the linkage area, attached a half-a-pound piece of metal to make everything heavier (and therefore dampen or change the frequency of the resonance) and wrapped all of that in electric tape. The leather boot barely fits over the shifter which is now harder to move, but the rattling ALMOST went away. I'd take a picture, but it's humiliating
take 20 mins to change the $3 bushings and be done with it
RaceFaceXC is offline   Reply With Quote
Old 06-04-2013, 02:01 AM   #19
tony_vu
Scooby Newbie
 
Member#: 358423
Join Date: Jun 2013
Default

nice work
tony_vu is offline   Reply With Quote
Old 06-06-2013, 08:53 PM   #20
Bluefoton
Scooby Specialist
 
Member#: 141373
Join Date: Feb 2007
Chapter/Region: E. Canada
Location: Quebec, QC
Vehicle:
2008 2.5i-hatch -
now with a HID retrofit

Default

Which bushings, RaceFace?
Bluefoton is offline   Reply With Quote
Old 06-06-2013, 10:41 PM   #21
RaceFaceXC
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: stupid Florida
Vehicle:
2007 No YELLING
on the bus!

Default

Quote:
Originally Posted by Bluefoton View Post
Which bushings, RaceFace?
Shift lever. There are a couple on the lever/linkage connection under the shifter boot.

There are also some on the linkage under the shifter where it anchors to the body and where it braces near the transmission bellhousing, but i doubt those are the source of the rattle.
RaceFaceXC is offline   Reply With Quote
Old 06-07-2013, 11:47 AM   #22
Bluefoton
Scooby Specialist
 
Member#: 141373
Join Date: Feb 2007
Chapter/Region: E. Canada
Location: Quebec, QC
Vehicle:
2008 2.5i-hatch -
now with a HID retrofit

Default

True, but it's not as if they were worn out after a few years in a cozy environment - unless I get some of the same format but in rubber...
Bluefoton is offline   Reply With Quote
Old 06-08-2013, 12:39 AM   #23
RaceFaceXC
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: stupid Florida
Vehicle:
2007 No YELLING
on the bus!

Default

Quote:
Originally Posted by Bluefoton View Post
True, but it's not as if they were worn out after a few years in a cozy environment - unless I get some of the same format but in rubber...
Sure they were. They Don't wear because of the environment, it's the constant vibration anytime the engine is running and the small amount of rotation from every gear change. Mine were worn enough to see the slop after 18 months of driving from new.

If you replace with oem, make sure you lube then with something tenacious like a tacky lithium grease or heavy packing grease. Bearing grease doesn't have the staying power to hold in place in an open environment.
RaceFaceXC is offline   Reply With Quote
Old 06-08-2013, 10:40 AM   #24
Bluefoton
Scooby Specialist
 
Member#: 141373
Join Date: Feb 2007
Chapter/Region: E. Canada
Location: Quebec, QC
Vehicle:
2008 2.5i-hatch -
now with a HID retrofit

Default

Thank you, will try it.
Bluefoton is offline   Reply With Quote
Old 06-08-2013, 11:49 AM   #25
MojoSoDope88
Scooby Newbie
 
Member#: 330957
Join Date: Sep 2012
Chapter/Region: Tri-State
Location: Woodberry, NJ
Default

I have the same issue with the heat shield. Rattles at low RPMs but not at idle. Gotta get under my car and fiddle with the exhaust to find it.
MojoSoDope88 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:33 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.