Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Member's Car Gallery

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-19-2013, 11:21 PM   #20426
doeboy23
Scooby Newbie
 
Member#: 358362
Join Date: Jun 2013
Default

Where can I buy the red and clear tail lights for my 2013 STi? Is it a DIY thing or do they other models have different lenses? I really don't like the full clears they put on the new cars.

Thanks everyone. Subaru virgin here.
* Registered users of the site do not see these ads.
doeboy23 is offline   Reply With Quote
Old 06-19-2013, 11:32 PM   #20427
SubieLuvin
Scooby Specialist
 
Member#: 248202
Join Date: May 2010
Chapter/Region: MWSOC
Location: Columbus, Ohio
Vehicle:
2013 WRX Sedan
SWP

Default

Quote:
Originally Posted by doeboy23 View Post
Where can I buy the red and clear tail lights for my 2013 STi? Is it a DIY thing or do they other models have different lenses? I really don't like the full clears they put on the new cars.

Thanks everyone. Subaru virgin here.
Some people DIY others use vinyl overlays. Blue batmobile makes some good ones I believe !
SubieLuvin is offline   Reply With Quote
Old 06-20-2013, 12:10 AM   #20428
doeboy23
Scooby Newbie
 
Member#: 358362
Join Date: Jun 2013
Default

Quote:
Originally Posted by SubieLuvin View Post
Some people DIY others use vinyl overlays. Blue batmobile makes some good ones I believe !

Thanks a lot. I'll have my friend that does window tint do it for me.


Thanks again.
doeboy23 is offline   Reply With Quote
Old 06-20-2013, 12:29 AM   #20429
JSchell1309
Scooby Specialist
 
Member#: 321321
Join Date: May 2012
Chapter/Region: MWSOC
Location: Kansas City, MO
Vehicle:
'11 STI Hatchback
Dom 1.5XTR, E85

Default

A little something I'm coming up with to replace the beat up steel delete on my car.

Going to cut from aluminum.


Currently painted steel.
JSchell1309 is offline   Reply With Quote
Old 06-20-2013, 12:48 AM   #20430
Trustkevin13
Scooby Specialist
 
Member#: 259184
Join Date: Sep 2010
Chapter/Region: MWSOC
Location: Kansas
Vehicle:
2008 Subaru WRX
Silver

Default

^^^ right! you can do that! I may have to hit you up soon!
Trustkevin13 is offline   Reply With Quote
Old 06-20-2013, 12:57 AM   #20431
JSchell1309
Scooby Specialist
 
Member#: 321321
Join Date: May 2012
Chapter/Region: MWSOC
Location: Kansas City, MO
Vehicle:
'11 STI Hatchback
Dom 1.5XTR, E85

Default

Quote:
Originally Posted by Trustkevin13 View Post
^^^ right! you can do that! I may have to hit you up soon!
You can PM me for any questions, but I am not looking to sell on here without a Vendor's license. I will leave it at that.
JSchell1309 is offline   Reply With Quote
Old 06-20-2013, 02:50 AM   #20432
RCubed
Scooby Newbie
 
Member#: 111328
Join Date: Mar 2006
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
2010 STi
SWP

Default

RCubed is offline   Reply With Quote
Old 06-20-2013, 08:29 AM   #20433
Sleeperwagon1
Scooby Newbie
 
Member#: 138901
Join Date: Jan 2007
Chapter/Region: South East
Vehicle:
2012 WRX sedan
ISM

Default

^A little too busy for me, but all in all, very nice car!
Sleeperwagon1 is offline   Reply With Quote
Old 06-20-2013, 08:42 AM   #20434
CASHxMONEYxMIKE
Scooby Specialist
 
Member#: 228719
Join Date: Nov 2009
Chapter/Region: NWIC
Location: Chicago NW Suburbs
Vehicle:
2013 STi
Satin White Pearl

Default

So anyone else had or know how to adjust this issue without resetting anything? As i was driving to work, i made a left turn, didn't go over any bumbs/ glass/ obstructions, etc. I was in second gear at like 15mph and as soon as I came out of the turn my tire pressure sensor light came on. All 4's look fine, couldn't hear or see any leaks. Drove to work another 5 miles or so, checked them again and still fine. Just wondering if our model years have super sensitive or super sh***y sensors in them. Thanks guys
CASHxMONEYxMIKE is offline   Reply With Quote
Old 06-20-2013, 08:48 AM   #20435
Improbus
Scooby Newbie
 
Member#: 278439
Join Date: Mar 2011
Chapter/Region: MAIC
Location: Pa, USA
Vehicle:
2011 WRX 4dr Stage2+
OBP

Default

Quote:
Originally Posted by CASHxMONEYxMIKE View Post
So anyone else had or know how to adjust this issue without resetting anything? As i was driving to work, i made a left turn, didn't go over any bumbs/ glass/ obstructions, etc. I was in second gear at like 15mph and as soon as I came out of the turn my tire pressure sensor light came on. All 4's look fine, couldn't hear or see any leaks. Drove to work another 5 miles or so, checked them again and still fine. Just wondering if our model years have super sensitive or super sh***y sensors in them. Thanks guys
Mine are pretty sensitive. I believe removing the battery terminals is the only way to reset it without the tool but I could be wrong. Mine are typically really sensitive when the temperature outside changes drastically, like its 60 in the morning and then 95 in the afternoon. Usually my solution has always been to let some air out of them and fill them back to around 32-36 PSI and drive for about 15 minutes and it goes away. Check around the valve stem seals as well sometimes those like to leak.

Last edited by Improbus; 06-20-2013 at 09:06 AM. Reason: Grammar
Improbus is offline   Reply With Quote
Old 06-20-2013, 09:00 AM   #20436
CASHxMONEYxMIKE
Scooby Specialist
 
Member#: 228719
Join Date: Nov 2009
Chapter/Region: NWIC
Location: Chicago NW Suburbs
Vehicle:
2013 STi
Satin White Pearl

Default

I'll be sure to check that man thank you. I have to go to my dealership today anyways because I noticed I was missing a plastic clip in the liner and all of this is still under warranty which is good.
CASHxMONEYxMIKE is offline   Reply With Quote
Old 06-20-2013, 09:47 AM   #20437
xluben
Scooby Guru
 
Member#: 261612
Join Date: Oct 2010
Location: Minneapolis, MN
Vehicle:
2012 Forester 2.5X
2002 WRX Sedan

Default

You should actually check the air pressure in your tires and add if necessary. On a local forum a guy was arguing that his sensors were broken. After a few pages of posts he actually checked the pressure and it was low. Filled them up and the light when away after a few minutes of driving. Just because a tire looks OK doesn't mean it has the proper amount of air in it.
xluben is online now   Reply With Quote
Old 06-20-2013, 09:58 AM   #20438
Scnsaracer
Scooby Newbie
 
Member#: 319511
Join Date: May 2012
Chapter/Region: TXIC
Location: McKinney, TX
Vehicle:
2013 STI Sedan
Ice Silver Metallic

Default

My tire light came on and one tire was just a bit low. Once I aired it up, it seemed to take a little while for the light to go off.
Scnsaracer is offline   Reply With Quote
Old 06-20-2013, 11:39 AM   #20439
CASHxMONEYxMIKE
Scooby Specialist
 
Member#: 228719
Join Date: Nov 2009
Chapter/Region: NWIC
Location: Chicago NW Suburbs
Vehicle:
2013 STi
Satin White Pearl

Default

Thanks Ben, and everyone else. I don't have a pressure gauge with me, but ill be having it checked out right away. Nothing serious for now, maybe one is just a tiny bit low.
CASHxMONEYxMIKE is offline   Reply With Quote
Old 06-20-2013, 11:45 AM   #20440
xluben
Scooby Guru
 
Member#: 261612
Join Date: Oct 2010
Location: Minneapolis, MN
Vehicle:
2012 Forester 2.5X
2002 WRX Sedan

Default

It's funny how people assume there is an issue when the system is working exactly the way it should be.
xluben is online now   Reply With Quote
Old 06-20-2013, 11:58 AM   #20441
jjablo6
Scooby Specialist
 
Member#: 265697
Join Date: Dec 2010
Chapter/Region: MWSOC
Location: Chicago
Vehicle:
2011 WRX
Ligtening Red

Default

Quote:
Originally Posted by JSchell1309 View Post
A little something I'm coming up with to replace the beat up steel delete on my car.

Going to cut from aluminum.


Currently painted steel.
dont see any radius or fillet call outs
jjablo6 is offline   Reply With Quote
Old 06-20-2013, 12:07 PM   #20442
jjablo6
Scooby Specialist
 
Member#: 265697
Join Date: Dec 2010
Chapter/Region: MWSOC
Location: Chicago
Vehicle:
2011 WRX
Ligtening Red

Default

my left turning signal started blinking really fast and the right one is still blinking at the same pace. someone mentioned that they blink quickly because one of the lights burned out. checked the lights and they both still work.. any ideas??
jjablo6 is offline   Reply With Quote
Old 06-20-2013, 12:10 PM   #20443
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

Mine did that when I first got it, try wiggling the wires around by the bulb
Celery GT-5 is offline   Reply With Quote
Old 06-20-2013, 12:11 PM   #20444
Improbus
Scooby Newbie
 
Member#: 278439
Join Date: Mar 2011
Chapter/Region: MAIC
Location: Pa, USA
Vehicle:
2011 WRX 4dr Stage2+
OBP

Default

Quote:
Originally Posted by jjablo6 View Post
my left turning signal started blinking really fast and the right one is still blinking at the same pace. someone mentioned that they blink quickly because one of the lights burned out. checked the lights and they both still work.. any ideas??
Turn Signal Bulbs are Dual Filament. If one of the filaments comes loose the light will still work but will blink quickly. The dealer replaced mine under warranty. If not a new turn signal bulb and you'll be good to go.
Improbus is offline   Reply With Quote
Old 06-20-2013, 12:13 PM   #20445
JSchell1309
Scooby Specialist
 
Member#: 321321
Join Date: May 2012
Chapter/Region: MWSOC
Location: Kansas City, MO
Vehicle:
'11 STI Hatchback
Dom 1.5XTR, E85

Default

Quote:
Originally Posted by jjablo6 View Post
dont see any radius or fillet call outs
Haha I'm not here to give out all my secrets

I just sent that generic print for quote so I can get a relative cost of material.
JSchell1309 is offline   Reply With Quote
Old 06-20-2013, 12:16 PM   #20446
jjablo6
Scooby Specialist
 
Member#: 265697
Join Date: Dec 2010
Chapter/Region: MWSOC
Location: Chicago
Vehicle:
2011 WRX
Ligtening Red

Default

Quote:
Originally Posted by Celery GT-5 View Post
Mine did that when I first got it, try wiggling the wires around by the bulb
Quote:
Originally Posted by Improbus View Post
Turn Signal Bulbs are Dual Filament. If one of the filaments comes loose the light will still work but will blink quickly. The dealer replaced mine under warranty. If not a new turn signal bulb and you'll be good to go.
thanks will look into it
jjablo6 is offline   Reply With Quote
Old 06-20-2013, 01:30 PM   #20447
danns
Scooby Newbie
 
Member#: 307197
Join Date: Jan 2012
Location: Southern California
Vehicle:
2011 wrx

Default

danns is offline   Reply With Quote
Old 06-20-2013, 01:31 PM   #20448
besthaticouldo
NASIOC Supporter
 
Member#: 279660
Join Date: Apr 2011
Chapter/Region: MWSOC
Location: STL
Default

^^that looks really good. love the fitment.
besthaticouldo is online now   Reply With Quote
Old 06-20-2013, 02:35 PM   #20449
erik11876
Scooby Specialist
 
Member#: 275888
Join Date: Mar 2011
Chapter/Region: MAIC
Location: Frederick MD
Vehicle:
2011 WRX Limited
SWP

Default

Quote:
Originally Posted by xluben View Post
It's funny how people assume there is an issue when the system is working exactly the way it should be.
I work in calibration, this is the story of my life Ben.
erik11876 is offline   Reply With Quote
Old 06-20-2013, 03:26 PM   #20450
NWsoobie
Scooby Specialist
 
Member#: 289516
Join Date: Jul 2011
Chapter/Region: NWIC
Location: PNW
Vehicle:
2012 WRX
ISM

Default

Damn Dan. This is clean. I want NT03's sooooooooooo f*****g bad.
NWsoobie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
('11+) 2011-2012 wrx/sti picture thread (for real this time) guamanian_powered Impreza Forum 151 04-29-2014 08:35 AM
01-07 wrx and sti drivetrain? xj bmx Newbies & FAQs 13 01-26-2012 03:30 PM
('11+) 2011 wrx/sti picture thread (for real this time) guamanian_powered Impreza Forum 1 11-16-2011 11:51 PM
Anyone have the 06-07 Impreza WRX and STI master part number and picture list STEALTH-WRX Interior & Exterior Modification 0 08-22-2008 02:12 PM
The Official World One STI and SEMA picture thread.. WorldOne Member's Car Gallery 25 11-29-2003 05:21 PM


All times are GMT -4. The time now is 02:40 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.