Welcome to the North American Subaru Impreza Owners Club Friday December 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-17-2013, 08:13 PM   #3701
ST Eye
Scooby Specialist
 
Member#: 73068
Join Date: Oct 2004
Location: MD
Vehicle:
2008 STI Boost Wagon
2014 Honda Accord Hybrid

Default

Quote:
Originally Posted by jr0bb5 View Post
Just a quick update. I had my fourth and (hopefully) last check for my oil consumption test today. Now I have to be patient and wait to hear back from the dealership once they get a response from SOA about the situation.

Honestly, if they tell me anything other than they're going to replace the short block, this car will be gone asap. Im done with the tests and all the BS. I'm done with all the visits to the dealership and that annoying low oil light always coming on!

Guess I'll just have to wait and see what they say.
I would be shocked if get any pushback. You did their tests, you met the criteria, time to make it right! Good luck!
* Registered users of the site do not see these ads.
ST Eye is offline   Reply With Quote
Old 06-19-2013, 09:00 AM   #3702
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Thanks for the update.
Im 500 miles into rd 2 of the second consumption test.
79letour is offline   Reply With Quote
Old 06-20-2013, 11:58 AM   #3703
ans2k
Scooby Specialist
 
Member#: 315631
Join Date: Apr 2012
Location: Bryant, AR
Vehicle:
2012 Impreza Sport

Default

So my light came on about 5000 miles after my last oil change. It was a quart low and I have 27, 000 on the clock. This is the first time it came on.
ans2k is online now   Reply With Quote
Old 06-20-2013, 12:26 PM   #3704
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

I'd say that 1 qt in 5k miles isn't too bad. If it was my car, I'd simply use a 5k mile oil change interval, and perhaps experiment with different oil brands to see if I could find one that would buy me a little cushion beyond 5k so that I don't get the light before my oil change.

Do you know what brand of oil is in your car now?
sgoldste01 is offline   Reply With Quote
Old 06-20-2013, 02:00 PM   #3705
nubsub
Scooby Specialist
 
Member#: 313575
Join Date: Mar 2012
Location: SF Bay Area, CA
Vehicle:
2012 Impreza 2.0i HB

Default

Quote:
Originally Posted by ans2k View Post
So my light came on about 5000 miles after my last oil change. It was a quart low and I have 27, 000 on the clock. This is the first time it came on.
what has been your prior oil change interval? have you noticed a deficit of oil in your previous changes?

in my last change of around 4300mi, i guesstimated a 0.25qt consumption.

i'll actually be changing my oil again soon (6months which this time will be around a similar 4300mi since i haven't been driving as much), so i'll report back.
nubsub is offline   Reply With Quote
Old 06-20-2013, 04:24 PM   #3706
nubsub
Scooby Specialist
 
Member#: 313575
Join Date: Mar 2012
Location: SF Bay Area, CA
Vehicle:
2012 Impreza 2.0i HB

Default Oil change order...

hey, maybe a dumb topic, but i'll open myself up for critique rather than be ignorant.

my traditional oil change order is:

1. remove drain plug
2. let oil drain
3. remove oil filter
4. replace drain plug
5. replace oil filter
6. fill in new oil

etc.

what i have noticed when doing the order with the Impreza is a large amount of oil that drains downward out of the filter due to its positioning and location. is there any harm or benefit in removing the oil filter first? (ie, if there is some valve in there, which i was led to believe, would that allow less of a mess or pool of oil to be in the filter "holder"?

thanks for any thoughts/experiences/ideas...
nubsub is offline   Reply With Quote
Old 06-20-2013, 04:35 PM   #3707
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

What oil filter do you use? I use the black Subaru/Roki "160" filters, and I've never had one leak when I remove it. As with your process, I always drain the oil before removing the filter.

Before I remove my drain plug, I remove the oil fill cap on top of the engine so that the opening will allow air to flow into the engine, which speeds draining.

But I can't imagine that this has anything to do with your filter drainage problem.
sgoldste01 is offline   Reply With Quote
Old 06-20-2013, 04:43 PM   #3708
nubsub
Scooby Specialist
 
Member#: 313575
Join Date: Mar 2012
Location: SF Bay Area, CA
Vehicle:
2012 Impreza 2.0i HB

Default

Quote:
Originally Posted by sgoldste01 View Post
What oil filter do you use? I use the black Subaru/Roki "160" filters, and I've never had one leak when I remove it. As with your process, I always drain the oil before removing the filter.

Before I remove my drain plug, I remove the oil fill cap on top of the engine so that the opening will allow air to flow into the engine, which speeds draining.

But I can't imagine that this has anything to do with your filter drainage problem.
thanks for the feedback.

i'm using (until i run out) the same 160 filters. yet, i noticed that a small, yet significant amount of oil dripped out into the "cup receptacle" that holds the filter and i had to mop up the excess oil with an old rag. i noticed this on my last (2nd) oil change, yet don't recall it during my first oil change.
nubsub is offline   Reply With Quote
Old 06-20-2013, 05:17 PM   #3709
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

I'd say that if the receptacle was able to hold the drippings, then it performed its job and you shouldn't worry about it. As long as you don't get drippings all over the place, then you shouldn't be concerned.

My process is to always wipe clean any oil that I see in that receptacle, plus the filter gasket mating surface, before installing the new filter. Also, I rub clean oil on the new filter's gasket before screwing the filter in place. I tighten the filter as much as I can by hand, plus 1/4-turn more with a filter wrench.
sgoldste01 is offline   Reply With Quote
Old 06-20-2013, 05:26 PM   #3710
nubsub
Scooby Specialist
 
Member#: 313575
Join Date: Mar 2012
Location: SF Bay Area, CA
Vehicle:
2012 Impreza 2.0i HB

Default

Quote:
Originally Posted by sgoldste01 View Post
I'd say that if the receptacle was able to hold the drippings, then it performed its job and you shouldn't worry about it. As long as you don't get drippings all over the place, then you shouldn't be concerned.

My process is to always wipe clean any oil that I see in that receptacle, plus the filter gasket mating surface, before installing the new filter. Also, I rub clean oil on the new filter's gasket before screwing the filter in place. I tighten the filter as much as I can by hand, plus 1/4-turn more with a filter wrench.
good point about the receptacle doing it's job.

your method sounds similar to mine.

on my old Honda, i actually always only hand tightened and never had a problem with leaking. (it was in a very awkward place and always hard to remove even with hand tightening because of lack of leverage). yet, i too use the wrench for an extra bit on the Subaru since it's so easy to reach and tighten/untighten.
nubsub is offline   Reply With Quote
Old 06-20-2013, 10:57 PM   #3711
Commander Keen
Scooby Specialist
 
Member#: 319157
Join Date: May 2012
Chapter/Region: MAIC
Vehicle:
2012 Impreza 4DR 5MT

Default

For clean filter removal, this works pretty well for me:

-Get the engine and oil hot, then shut it off.
-Punch a hole in the top/outer edge of the filter with a screwdriver and hammer.
-Wait about an hour.
-Proceed normally with oil change.
Commander Keen is offline   Reply With Quote
Old 06-20-2013, 10:57 PM   #3712
ans2k
Scooby Specialist
 
Member#: 315631
Join Date: Apr 2012
Location: Bryant, AR
Vehicle:
2012 Impreza Sport

Default

Quote:
Originally Posted by sgoldste01 View Post
I'd say that 1 qt in 5k miles isn't too bad. If it was my car, I'd simply use a 5k mile oil change interval, and perhaps experiment with different oil brands to see if I could find one that would buy me a little cushion beyond 5k so that I don't get the light before my oil change.

Do you know what brand of oil is in your car now?
I have been getting free oil changes for the past 22, 000 miles from the Subaru dealership. I check the oil everytime after the oil change and the gas tank before thw oil change.
ans2k is online now   Reply With Quote
Old 06-21-2013, 08:46 AM   #3713
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Quote:
Originally Posted by Commander Keen View Post
-Punch a hole in the top/outer edge of the filter with a screwdriver and hammer.
-Wait about an hour.
-Proceed normally with oil change.
I'm not patient enough to wait an hour, especially since I've been able to avoid a mess without this extra wait time. I've never had significant (if any) amounts of oil drain from my old filter during an oil change on this Impreza, so I guess the filter's internal valve is doing its job.

If I'm ever not able to buy the black Subaru/Roki "160" filters anymore, I hope I can find another filter brand/model that behaves this way.

EDIT: If someone tries the highly-regarded Fram XG7317 synthetic filter, I'd be curious to know how well it holds the oil during removal.

Last edited by sgoldste01; 06-21-2013 at 09:41 AM.
sgoldste01 is offline   Reply With Quote
Old 06-21-2013, 08:51 AM   #3714
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Quote:
Originally Posted by ans2k View Post
I have been getting free oil changes for the past 22, 000 miles from the Subaru dealership. I check the oil everytime after the oil change and the gas tank before thw oil change.
OK. Do you get free oil changes for the life of the car, or does that benefit run out eventually? If this benefit does end, then that's when I would start testing other oils.

The Amsoil OE 0W-20 has worked well in my car so far (16k on the odometer right now; I've changed the oil 3x). My next two oil changes will be using Pennzoil Platinum 0W-20, which I've read is good stuff but I can't vouch for it personally yet.
sgoldste01 is offline   Reply With Quote
Old 06-21-2013, 12:05 PM   #3715
New_Subie_Owner
Scooby Newbie
 
Member#: 360116
Join Date: Jun 2013
Location: Connecticut
Vehicle:
2012 Impreza Prem HB
Ice Silver Metallic

Default oil consumption

I own a 2012 Impreza which is my first Subaru. I have to add a quart of oil every 4,000 miles. This seems wrong especially since my previous two Acuras had over 200,000 miles and I never added oil between changes. The dealer service rep told me that some owners have to add every 2,500 miles. Is this right?
New_Subie_Owner is offline   Reply With Quote
Old 06-21-2013, 12:19 PM   #3716
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Quote:
Originally Posted by New_Subie_Owner View Post
I own a 2012 Impreza which is my first Subaru. I have to add a quart of oil every 4,000 miles. This seems wrong especially since my previous two Acuras had over 200,000 miles and I never added oil between changes. The dealer service rep told me that some owners have to add every 2,500 miles. Is this right?
Yes, it's true for some owners. In fact, some owners need to add a quart every 1200 miles, which is Subaru's cutoff for justifying a replacement engine.

It's certainly not true for all Impreza owners.
sgoldste01 is offline   Reply With Quote
Old 06-21-2013, 02:50 PM   #3717
jbulls93
Scooby Newbie
 
Member#: 315840
Join Date: Apr 2012
Chapter/Region: Tri-State
Location: New York
Vehicle:
2000 2.5rs

Default

2012 Impreza Sport 2.0i 5 speed. Had it since May 12' 38,000 miles. Has burned .2-.3 qts per 1000 miles since day one. Check your damn oil, they burn it. I add oil about every 2 weeks, depending on miles driven. It's a noisy, oil burning engine. The company I work for has 3 XV Crosstreks, all with the CVT, the drivers of those cars report no oil consumption. I tend to engine brake often and I feel this is where the majority of the oil consumption comes from.
jbulls93 is online now   Reply With Quote
Old 06-21-2013, 03:15 PM   #3718
New_Subie_Owner
Scooby Newbie
 
Member#: 360116
Join Date: Jun 2013
Location: Connecticut
Vehicle:
2012 Impreza Prem HB
Ice Silver Metallic

Default Thank-You

Thank-you for all of your responses. After 23 years of driving Honda products, I was spoiled by not having to add oil to my car. This seems to be common for the Impreza. From now on, I will definitely check monthly based on my mileage.
New_Subie_Owner is offline   Reply With Quote
Old 06-21-2013, 03:36 PM   #3719
nubsub
Scooby Specialist
 
Member#: 313575
Join Date: Mar 2012
Location: SF Bay Area, CA
Vehicle:
2012 Impreza 2.0i HB

Default 3rd oil change

Quote:
Originally Posted by New_Subie_Owner View Post
Thank-you for all of your responses. After 23 years of driving Honda products, I was spoiled by not having to add oil to my car. This seems to be common for the Impreza. From now on, I will definitely check monthly based on my mileage.
Long time (~21 yrs) spoiled Honda guy here. i just changed my oil for the 3rd time on my 2012 CVT impreza. (first 2 changes at ~2600, ~7300mi)

i logged ~4200 miles since the last cbange (odometer currently at ~11.5k), and noted that at worst, i consumed 10 ounces of oil based on what i drained yesterday*. i'm guessing it was probably closer to 8 ounces (0.25 qt)

so far so good, but given the few problems reported here, i'll be keeping an eye on things each oil change (i am planning on a 6mo change sequence regardless of miles driven: i typically drive ~10,000 miles per year)

*the details: (Mobile 1 -- high efficiency 0w20)
- during last change, i put in 5 quarts + 10 ounces
- yesterday, i drained the used oil back into 5 quart container and the level was a smidge higher than the oil in the new 5 qt container. this ~5qts does not include any oil that i mopped up with old rags cleaning the pan, funnel, oil filter receptacle, and a few drops i spattered when i poured the oil into the container.


practically speaking, it's convenient that i consume a little, else, i would need another container to dispose of the used oil

in all seriousness, at some point, if i don't see any noticeable consumption down the road, i may just go with 5 qts of oil per change. right now i buy 5 qt jugs but pick up a quarter container to be used over 3 changes. (yesterday, i poured in 5 qt, 12 ounces)
nubsub is offline   Reply With Quote
Old 06-22-2013, 09:51 AM   #3720
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Quote:
Originally Posted by New_Subie_Owner View Post
Thank-you for all of your responses. After 23 years of driving Honda products, I was spoiled by not having to add oil to my car. This seems to be common for the Impreza. From now on, I will definitely check monthly based on my mileage.
I feel ya. My last Honda was a 91 CRX. I sold it to a friend and now with 200k++ miles it still isnt burning oil or at least any appreciable amount.
79letour is offline   Reply With Quote
Old 06-22-2013, 10:44 AM   #3721
Delnari
Scooby Newbie
 
Member#: 341694
Join Date: Dec 2012
Chapter/Region: MAIC
Location: Alexandria, VA
Vehicle:
2013 WRX
Gray

Default

Subaru dealerships use only synthetic oil which is good for 5K miles or more. I'm a do it yourself oil changer guy on all my cars and motorcycles. The local dealership charges $60 with tax for the change, provides a comfortable waiting room with TV, WiFi, sodas, coffee, and light snacks. I know time is money, but when I compare the cost and time of doing myself compare to them doing it I stop doing my WRX oil changes. Which has me changing the oil before 5K miles and stop having to check my oil as often. Now I check it once month or 1K miles and no problems these first 6K miles.
Delnari is offline   Reply With Quote
Old 06-23-2013, 04:28 AM   #3722
pRiMe DiReCtIvE
Scooby Newbie
 
Member#: 301387
Join Date: Nov 2011
Location: East Bay - Cali
Vehicle:
2012 Impreza HB
Black/Dark Grey

Default

Started an oil consumption tet with my dealer just last week. The low oil light came on at about 1200 miles. This is the second time it happened. The car has a little over 15k now. First time it happened was at 1700 miles. It's weird though, sometimes the light will turn off without any reason after a day or two of driving.
pRiMe DiReCtIvE is offline   Reply With Quote
Old 06-23-2013, 08:27 AM   #3723
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Quote:
Originally Posted by pRiMe DiReCtIvE View Post
It's weird though, sometimes the light will turn off without any reason after a day or two of driving.
Does this mean the oil level light comes on even when the oil level is good?
sgoldste01 is offline   Reply With Quote
Old 06-23-2013, 09:36 AM   #3724
gregorz4
Scooby Specialist
 
Member#: 316869
Join Date: Apr 2012
Location: Ontario, Canada
Vehicle:
2012 Impreza Sport
Dark Gray

Default

Quote:
Originally Posted by pRiMe DiReCtIvE View Post
Started an oil consumption tet with my dealer just last week. The low oil light came on at about 1200 miles. This is the second time it happened. The car has a little over 15k now. First time it happened was at 1700 miles. It's weird though, sometimes the light will turn off without any reason after a day or two of driving.
When I had my oil consumption problem the light would turn on, turn off after 30-50 km, come back on again after another 100-200, turn off again after another 30-50, then come back on again after another 100km or so until oil was added. It did that every time I was low on oil. It tricked me a few times when I would be going to Subaru to show theme situation, I would arrive there and then..SORRY! no low oil light.
You will get used to it if nothing is done about it.
gregorz4 is online now   Reply With Quote
Old 06-23-2013, 12:39 PM   #3725
Wayne Evans
Scooby Newbie
 
Member#: 360297
Join Date: Jun 2013
Default Oil use.

Watch carefully and be sure to have low oil recorded at the dealer. We have a 2012 Impreza that the oil light began coming on shortly after purchase. Long story short, the dealer went through oil consumption tracking over a period of time. Finally agreed they needed to replace the short block. After breaking in the "new" engine found that it was once again down 1 1/2 quarts (1500 Miles). Since then a new oil consumption tracking has begun with regular oil lights and visits to the dealer. We bought a Subaru for reliability. So far it has been at the dealers more times than the used VW we traded in. Very frustrating. Dealer says there are rumors that the cylinders are bored too smooth causing oil to pass by. Not sure where this is going to end.
Wayne Evans is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Are there any DIY independent fog lights write ups yet for 2012 impreza sports? JDMSTA Electrical & Lighting 59 07-21-2013 09:04 AM
2012 Impreza 2.0i Mobil1 oil filter model # jr0bb5 Service & Maintenance 27 01-04-2013 06:18 PM
('11-'14) OC interval and the first oil change on 2012 Impreza 2.0 Oceanguy Impreza Forum 80 11-18-2012 01:56 PM
My Oil Light is Flickering and I have No Leak??? kakarotoni Newbies & FAQs 39 08-16-2012 11:36 AM
('11-'14) 2012 Impreza High beams = Low beams lighting Jmzda Impreza Forum 28 06-01-2012 01:14 PM


All times are GMT -4. The time now is 09:17 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.