Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 06-22-2013, 02:32 PM   #11
USLiberty
Scooby Newbie
 
Member#: 294466
Join Date: Sep 2011
Chapter/Region: SWIC
Location: prescott az
Vehicle:
1993 Legacy SS
white

Default

I'm no subaru expert, just an electrician thats dismantled a couple legacies to make one. I used seafoam once in the gas, didn't notice any butt-dyno gains after or if it had done anything. It says on the back not to use in engine oil for turbo applications. I used it in project porschit, sucked it in thru a vacuum line and revved it for 20 minutes, so much white smoke came out, neighbors were kinda trippin at first. I think black chunks were coming out, but it could of been the rusted out muffler blowing apart. did almost the whole can, drove it a bit, pulled the intake off and it was still coated in black crud, but it was wet and when i wiped it, it came clean. So the solvent works but the crud was still there, maybe after a gallon of it it would clean itself. 02RS recommended marvel mystery oil to use in the oil and clean the internals, sometimes I get the noisey lifter annoyance, mostly under warm-up. Going to try it soon.

Last edited by USLiberty; 06-22-2013 at 02:44 PM.
USLiberty is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
So i might have converted an Acura driver to a Subaru driver! SpamMansXe Mid Atlantic Impreza Club -- MAIC 11 11-04-2012 11:49 AM
DFW Subaru drivers- Teape Subaru of Arlington is now open! wcbjr Texas Impreza Club Forum -- TXIC 22 06-21-2005 09:55 AM
DFW Subaru drivers- Teape Subaru of Arlington is now open! Ryan@Teape Subaru Texas Impreza Club Forum -- TXIC 1 06-20-2005 01:15 PM
DFW SUBARU DRIVERS! Teape Subaru of Arlington is now open! Ryan@Teape Subaru Private 'For Sale' Classifieds 0 06-20-2005 01:13 PM
Apparently Car and Driver thinks Subaru drivers are hippies... perret318 Off-Topic 45 03-03-2005 05:45 PM


All times are GMT -4. The time now is 03:37 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.