Welcome to the North American Subaru Impreza Owners Club Friday October 28, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Go Back   NASIOC > NASIOC Reviews > Dealership Reviews

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 07-24-2013, 08:52 AM   #1
Scooby Newbie
Member Sales Rating: (2)
Member#: 325140
Join Date: Jul 2012
Location: pennsylvania
2012 wrx

Default Welsh subaru in limerick, pa

I went to take my car in for state inspection, emissions, oil change, and reprogram my tpms because I put my summer rims back on. After they did the state, emissions and oil change first they tried getting me to do a 84$ cabin air filter and air filter ( I don't think so) and then the service writer comes back and says; well the technician went to reprogram your tpms sensors, than he went for a test drive and the light came right back on. So we have them in stock if you wanna do it right now it will 130$ for sensor plus diag to figure out what sensor. I told him I will wait, be also tells me oh I see those aren't the factory rims so we can't do warranty on the sensor. All said and done i payed for my service, left started my '12 wrx and NO LIGHT... I've driven for at least 100 miles and no light. They tried ripping me off 130$ I am pissed. Just thought everyone should know this if they go there to watch out. Ill be letting them know my next service.
ghynes440 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 05:39 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.