Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-26-2013, 07:36 PM   #1
jzehren11
Scooby Newbie
 
Member#: 357281
Join Date: May 2013
Chapter/Region: International
Location: Bragg, NC
Vehicle:
2004 WRX Wagon
WRB

Default JDM EJ205 heads on my USDM 205??

So pretty much, long story short.... replacing my head gaskets, and regasketing the the whole motor, and I found the VERY common cracks between the spark plug and the valve seals. Mine are pretty much cracked all the way through though :/

Found a look set of JDM heads with AVCS for $600, no cracks. Only thing is, will everything work out fine if I install them? Yes, I know the AVCS wont work.


Thanks in advance.

Justin
* Registered users of the site do not see these ads.

Last edited by jzehren11; 07-31-2013 at 08:20 AM.
jzehren11 is offline   Reply With Quote
Old 07-27-2013, 02:26 PM   #2
Shortpersonbk
Scooby Specialist
 
Member#: 319017
Join Date: May 2012
Chapter/Region: MWSOC
Location: Michigan
Vehicle:
91 Miata
slow sti 6266 e-85

Default

I am not sure if its true but I heard our ej205 heads partswise outside of avcs are about the same as ej207 heads but no big ports so you may want to look into that if ur just looking rev it out somewhat more.
Shortpersonbk is online now   Reply With Quote
Old 07-28-2013, 10:27 AM   #3
jzehren11
Scooby Newbie
 
Member#: 357281
Join Date: May 2013
Chapter/Region: International
Location: Bragg, NC
Vehicle:
2004 WRX Wagon
WRB

Default

bumppp anyone?
jzehren11 is offline   Reply With Quote
Old 07-28-2013, 01:16 PM   #4
rdieder
Scooby Specialist
 
Member#: 257818
Join Date: Sep 2010
Chapter/Region: SWIC
Location: ABQ, NM
Vehicle:
2007 STi
CGM

Default

What ecu are you using? Rumor has it that the Jdm and usdm short blocks are the same
rdieder is offline   Reply With Quote
Old 07-28-2013, 05:30 PM   #5
jzehren11
Scooby Newbie
 
Member#: 357281
Join Date: May 2013
Chapter/Region: International
Location: Bragg, NC
Vehicle:
2004 WRX Wagon
WRB

Default

I'll be using the usdm harness and ecu.....

I just want to know if the JDM heads will bolt up with no issues and work without issues.....
jzehren11 is offline   Reply With Quote
Old 07-29-2013, 06:43 AM   #6
jzehren11
Scooby Newbie
 
Member#: 357281
Join Date: May 2013
Chapter/Region: International
Location: Bragg, NC
Vehicle:
2004 WRX Wagon
WRB

Default

Bump...
jzehren11 is offline   Reply With Quote
Old 07-29-2013, 07:43 AM   #7
rdieder
Scooby Specialist
 
Member#: 257818
Join Date: Sep 2010
Chapter/Region: SWIC
Location: ABQ, NM
Vehicle:
2007 STi
CGM

Default

pretty much every motor from 2002+ on this forum has been mixed and matched. These motors are like legos. So it should bolt up together. You'll have to fool around to get it to work, you aren't using the correct ecu for those heads, so don't expect it to work without issues.
rdieder is offline   Reply With Quote
Old 07-29-2013, 07:58 AM   #8
jzehren11
Scooby Newbie
 
Member#: 357281
Join Date: May 2013
Chapter/Region: International
Location: Bragg, NC
Vehicle:
2004 WRX Wagon
WRB

Default

well I dont expect for the AVCS to work... but everything else should correct?
jzehren11 is offline   Reply With Quote
Old 07-29-2013, 11:04 AM   #9
ogboot
Scooby Specialist
 
Member#: 170906
Join Date: Feb 2008
Chapter/Region: South East
Vehicle:
2002 WRX
psm

Default

I'd recommend getting some USDM ej205 heads, i got mine on here cheaper than $300 shipped.
ogboot is offline   Reply With Quote
Old 07-30-2013, 01:38 AM   #10
jzehren11
Scooby Newbie
 
Member#: 357281
Join Date: May 2013
Chapter/Region: International
Location: Bragg, NC
Vehicle:
2004 WRX Wagon
WRB

Default

see I just dont want to have to deal with having to get them shipped... plus it would be going through military postal service...which has been known to break ****!
jzehren11 is offline   Reply With Quote
Old 07-30-2013, 10:49 AM   #11
jzehren11
Scooby Newbie
 
Member#: 357281
Join Date: May 2013
Chapter/Region: International
Location: Bragg, NC
Vehicle:
2004 WRX Wagon
WRB

Default

bump??
jzehren11 is offline   Reply With Quote
Old 07-31-2013, 01:01 PM   #12
rdieder
Scooby Specialist
 
Member#: 257818
Join Date: Sep 2010
Chapter/Region: SWIC
Location: ABQ, NM
Vehicle:
2007 STi
CGM

Default

what answer are you looking for? get them and install. Should be no different than deleting avcs as they do on the 2.5 heads
rdieder is offline   Reply With Quote
Old 08-01-2013, 02:13 AM   #13
jhayesvw
Scooby Newbie
 
Member#: 326502
Join Date: Jul 2012
Chapter/Region: SWIC
Location: Tucson AZ
Vehicle:
2003 WRX Wagon
Silver

Default

I think IA performance sells an easy wiring kit to make the avcs work.
You may want to check into it.
as for mechanically, there is no reason the heads wont work.
jhayesvw is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:58 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.