Welcome to the North American Subaru Impreza Owners Club Thursday July 10, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-22-2013, 07:58 PM   #3951
jr0bb5
Scooby Specialist
 
Member#: 315353
Join Date: Apr 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sp Prem
5MT OBP/DGM

Default

Honestly, I'm actually quite surprised at how much I like driving the CVT. I've always been a manual transmission type of guy, but I feel that the CVT goes well with this car. Also, the CVT equipped Impreza actually feels quicker and more responsive than my manual Impreza. As far as noise is concerned, I don't find the CVT to be any noisier than the 5-speed. I don't hear that "CVT whine" that everyone's always talking about. Gas mileage has also been better than in my 5-speed, but I expected as much. I'm quite pleased overall with the CVT. It's nowhere near as bad as I imagined it to be.

If I were to do it all over again, I would probably have to think long and hard about which transmission I would choose for my Impreza instead of just jumping into a manual.
* Registered users of the site do not see these ads.
jr0bb5 is offline   Reply With Quote
Old 07-22-2013, 08:13 PM   #3952
jr0bb5
Scooby Specialist
 
Member#: 315353
Join Date: Apr 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sp Prem
5MT OBP/DGM

Default

A couple of other notable things about my 2013 loaner:

It has a nice and firm, non squeaking driver's seat. Feels like Subaru may of implemented the seat fix in the 13 +. Also, no low oil light in almost 2000 miles! It's almost hard to believe considering I expect to see it illuminate every 900 miles or so.

I almost want to call the dealer and tell them that they can keep my car and I'll hold on to the loaner.

Last edited by jr0bb5; 07-22-2013 at 08:20 PM.
jr0bb5 is offline   Reply With Quote
Old 07-22-2013, 08:49 PM   #3953
G2Spfld
Scooby Specialist
 
Member#: 354284
Join Date: Apr 2013
Location: Midwest
Vehicle:
2013 Imp Sport CVT
SWP

Default

Quote:
Originally Posted by jr0bb5 View Post
A couple of other notable things about my 2013 loaner:

It has a nice and firm, non squeaking driver's seat. Feels like Subaru may of implemented the seat fix in the 13 +. Also, no low oil light in almost 2000 miles! It's almost hard to believe considering I expect to see it illuminate every 900 miles or so.

I almost want to call the dealer and tell them that they can keep my car and I'll hold on to the loaner.
That's exactly what I would do! Tell them you had enough and was ready to walk away, however the 13'CVT so far has no issues and its more of what you'd expect from Subaru. Lead them to believe it'll be their best option at this point to avoid any further actions. Of course do it with a smile and pleasant voice, but don't mix words. Make it pretty clear to them.
G2Spfld is offline   Reply With Quote
Old 07-22-2013, 09:02 PM   #3954
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

That^
what he said.
79letour is offline   Reply With Quote
Old 07-22-2013, 09:04 PM   #3955
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Quote:
Originally Posted by jr0bb5 View Post
A couple of other notable things about my 2013 loaner:

It has a nice and firm, non squeaking driver's seat. Feels like Subaru may of implemented the seat fix in the 13 +. Also, no low oil light in almost 2000 miles! It's almost hard to believe considering I expect to see it illuminate every 900 miles or so.

I almost want to call the dealer and tell them that they can keep my car and I'll hold on to the loaner.
That. was one major sellig point on the xv- the seats feel.much more firmly padded and less like a pile of gym shorts with a metal frame under it.
79letour is offline   Reply With Quote
Old 07-22-2013, 09:05 PM   #3956
lymphomaniac
Scooby Specialist
 
Member#: 334451
Join Date: Oct 2012
Chapter/Region: VIC
Location: YVR
Vehicle:
2013 Impreza2.0i CVT
DGM (sedan)

Default

Quote:
Originally Posted by jr0bb5 View Post
It has a nice and firm, non squeaking driver's seat. Feels like Subaru may of implemented the seat fix in the 13 +.
Just you wait for it... just you wait...

Mine is squeaking like an old bed in a nasty porno. This was about a few hundred kms into ownership. Then again, I'm overweight for my height (6'3"ish).
lymphomaniac is offline   Reply With Quote
Old 07-22-2013, 09:06 PM   #3957
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Btw- the XV has 1200 miles on it now. no oil lights and the dipstick is staying at the same level so far.
But I've been lazy and only check it once a week!
79letour is offline   Reply With Quote
Old 07-22-2013, 09:08 PM   #3958
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Quote:
Originally Posted by lymphomaniac View Post
Just you wait for it... just you wait...

Mine is squeaking like an old bed in a nasty porno. This was about a few hundred kms into ownership. Then again, I'm overweight for my height (6'3"ish).
Damn you!! Don't you put a hex on the seats!
79letour is offline   Reply With Quote
Old 07-22-2013, 09:23 PM   #3959
G2Spfld
Scooby Specialist
 
Member#: 354284
Join Date: Apr 2013
Location: Midwest
Vehicle:
2013 Imp Sport CVT
SWP

Default

My seats on my '13 sport have been great, no squeaks or rattles. I'm 5'10" and 190 or so. 8300 miles so far, and everything has improved from day 1, well..... All except the silly sound system.
G2Spfld is offline   Reply With Quote
Old 07-22-2013, 09:28 PM   #3960
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Thats VERY good to hear. I'm 5'10 and 190.
79letour is offline   Reply With Quote
Old 07-22-2013, 09:35 PM   #3961
jr0bb5
Scooby Specialist
 
Member#: 315353
Join Date: Apr 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sp Prem
5MT OBP/DGM

Default

Should of followed my own advice and the advice of many others and stayed far away from the first year of a newly designed model... Especially one with a new engine. :-/ I've definitely learned my lesson.

Last edited by jr0bb5; 07-22-2013 at 09:41 PM.
jr0bb5 is offline   Reply With Quote
Old 07-22-2013, 09:39 PM   #3962
lymphomaniac
Scooby Specialist
 
Member#: 334451
Join Date: Oct 2012
Chapter/Region: VIC
Location: YVR
Vehicle:
2013 Impreza2.0i CVT
DGM (sedan)

Default

Quote:
Originally Posted by 79letour View Post
Damn you!! Don't you put a hex on the seats!


Actually, mine was one of the first 2013s off the boat in Canada. It's entirely possible that they've fixed the issue later in the run, considering mine is basically just a re-badged 2012.
lymphomaniac is offline   Reply With Quote
Old 07-22-2013, 09:53 PM   #3963
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Quote:
Originally Posted by jr0bb5 View Post
Should of followed my own advice and the advice of many others and stayed far away from the first year of a newly designed model... Especially one with a new engine. :-/ I've definitely learned my lesson.
I think we all thought and knew that- but I think we can agree that tje new Impreza was very tempting...
Lesson learned is right!
79letour is offline   Reply With Quote
Old 07-22-2013, 09:55 PM   #3964
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Quote:
Originally Posted by lymphomaniac View Post


Actually, mine was one of the first 2013s off the boat in Canada. It's entirely possible that they've fixed the issue later in the run, considering mine is basically just a re-badged 2012.
Wow thats actually quite comforting.
So far so good. And the dealer I bought this car from know what tsb's are if it does end up squeaky.
79letour is offline   Reply With Quote
Old 07-22-2013, 10:09 PM   #3965
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Quote:
Originally Posted by jr0bb5 View Post
Should of followed my own advice and the advice of many others and stayed far away from the first year of a newly designed model... Especially one with a new engine. :-/ I've definitely learned my lesson.
Or at least avoid the early cars produced from the first year of a new design. Mine is a late 2012 car, and hasn't had problems.
sgoldste01 is online now   Reply With Quote
Old 07-22-2013, 10:33 PM   #3966
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by lymphomaniac View Post



Actually, mine was one of the first 2013s off the boat in Canada. It's entirely possible that they've fixed the issue later in the run, considering mine is basically just a re-badged 2012.
The tsb covered the 13 and the xv, but not my april '12 build even though I had all the symptoms.
flyboy1100 is offline   Reply With Quote
Old 07-22-2013, 10:52 PM   #3967
Dubie2012
Scooby Newbie
 
Member#: 353050
Join Date: Apr 2013
Default

That was probably me driving it, haha. The thing is fast as ****. Overall nice car. I had the cvt in the crosstrek and didn't like it too much. It seem like it still needs some fine tuning.
Dubie2012 is offline   Reply With Quote
Old 07-30-2013, 06:17 PM   #3968
shmoliken
Scooby Newbie
 
Member#: 361196
Join Date: Jul 2013
Location: delaware
Vehicle:
2012 impreza sport
sage/silver

Default oil level light on

in my 2012 impreza. been in the shop three times. no fix. yet dealership says "no problems can occur b/c of the light" i'm worried they are wrong. thread is way too long at 159 pgs for me to get any answers in old posts.
shmoliken is offline   Reply With Quote
Old 07-30-2013, 09:44 PM   #3969
Dubie2012
Scooby Newbie
 
Member#: 353050
Join Date: Apr 2013
Default

They're probably putting it off till you get out of the lemon law criteria. In my case it was exactly 1 year and 4 days old before they took the problem seriously.
Dubie2012 is offline   Reply With Quote
Old 07-30-2013, 10:48 PM   #3970
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Yeah they will blow smoke up your ass and the car's tailpipe!
79letour is offline   Reply With Quote
Old 07-30-2013, 10:49 PM   #3971
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Try to get an oil consumption test as soon as you notice the oil vanishing.
79letour is offline   Reply With Quote
Old 07-31-2013, 07:07 AM   #3972
shmoliken
Scooby Newbie
 
Member#: 361196
Join Date: Jul 2013
Location: delaware
Vehicle:
2012 impreza sport
sage/silver

Default

there is no excess oil consumption, only the light staying on.
shmoliken is offline   Reply With Quote
Old 07-31-2013, 07:54 AM   #3973
Dubie2012
Scooby Newbie
 
Member#: 353050
Join Date: Apr 2013
Default

I've noticed that it takes about 30 minutes for the light to go off after I fill the oil up.
Dubie2012 is offline   Reply With Quote
Old 07-31-2013, 08:12 AM   #3974
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Quote:
Originally Posted by shmoliken View Post
in my 2012 impreza. been in the shop three times. no fix. yet dealership says "no problems can occur b/c of the light" i'm worried they are wrong. thread is way too long at 159 pgs for me to get any answers in old posts.
There are two oil lights--one for oil level, and one for oil pressure. It would be true that no damage will occur if the oil level light is lit, as long as the oil pump has pressure (oil pressure light is not lit). So if the oil level is actually good even though the oil level light is lit, then your engine is safe.

Regardless, the oil level light is there to give you a heads up should your oil level ever get truly low, so you'll want to get that light's function working as designed. The oil level light is supposed to light before the oil level gets low enough to cause a loss of oil pressure, which could be catastrophic. Don't let the dealership try to convince you that you don't need to fix the oil level light. Insist that they make it work correctly.
sgoldste01 is online now   Reply With Quote
Old 07-31-2013, 09:14 AM   #3975
shmoliken
Scooby Newbie
 
Member#: 361196
Join Date: Jul 2013
Location: delaware
Vehicle:
2012 impreza sport
sage/silver

Default

i was sort of hoping that others had had a similar problem and they could tell me how it was resolved....the first fix from the dealer was to reground the sensor - they said that was the problem - seemed a bit odd to me, but it did fix it for awhile. however, it came on again, and the next fix was to replace the sensor and , they said, double-ground it. Which also worked for awhile, but now it's on again and it stays on for longer and longer periods.
i'd like to be able to have it fixed for just that reason - the car that cried wolf - i'll never know when i may actually have a problem short of checking it every week.
shmoliken is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Are there any DIY independent fog lights write ups yet for 2012 impreza sports? JDMSTA Electrical & Lighting 59 07-21-2013 08:04 AM
2012 Impreza 2.0i Mobil1 oil filter model # jr0bb5 Service & Maintenance 27 01-04-2013 05:18 PM
('11+) OC interval and the first oil change on 2012 Impreza 2.0 Oceanguy Impreza Forum 80 11-18-2012 12:56 PM
My Oil Light is Flickering and I have No Leak??? kakarotoni Newbies & FAQs 39 08-16-2012 10:36 AM
('11+) 2012 Impreza High beams = Low beams lighting Jmzda Impreza Forum 28 06-01-2012 12:14 PM


All times are GMT -4. The time now is 07:16 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.