Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Texas Impreza Club
Texas Impreza Club Forum sponsored by Gillman Subaru Houston
and Gillman Subaru San Antonio
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Texas Impreza Club Forum -- TXIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-15-2013, 03:06 PM   #1626
SnowmanFX
Scooby Specialist
 
Member#: 25753
Join Date: Oct 2002
Chapter/Region: TXIC
Location: San Antonio
Vehicle:
2002 Impreza WRX
Aspen White

Default

Quote:
Originally Posted by Rally STi Guy View Post
True, the turbo gasket can be cumbersome. The issue with the motor mounts is having to jack up the engine. If my case of having a lager front sway bar the factory U subframe had to come off to lower the sway bar out of the way to get at the nut on the motor mount. It's an afternoon project for sure. Let me know if you want any help
It should be a lot easier for me. I removed the U-brace and replaced it with an H-brace for weight savings.

I will most likely create a shop day next weekend. BYO FAN
* Registered users of the site do not see these ads.
SnowmanFX is offline   Reply With Quote
Old 08-22-2013, 12:52 PM   #1627
ntdemail
Scooby Newbie
 
Member#: 243692
Join Date: Apr 2010
Chapter/Region: TXIC
Location: New Braunsfels TX, 78132
Vehicle:
2004 WRX
Black

Default

In town again. Just saw a blue REX with green rims fly by on RITTIMAN. What's the face book page you guys use?
ntdemail is offline   Reply With Quote
Old 08-25-2013, 09:45 PM   #1628
Mr. Lin
Scooby Specialist
 
Member#: 344988
Join Date: Jan 2013
Chapter/Region: TXIC
Vehicle:
2013 WRX STi
ISM

Default



set my ride height and let it settle. washed her up real good too
Mr. Lin is offline   Reply With Quote
Old 08-26-2013, 10:11 AM   #1629
kenprice0
Scooby Newbie
 
Member#: 140017
Join Date: Feb 2007
Default

All new to forum. Need advice on good shop for rebuilding heads & valve job and cylinder hone on EJ25 from 97 outback. Head gaskets blown and most likely rings. Also looking at best bargain rebuild kit to buy. On a budget but no skimping. Please no advice motivated by profit. Thx Ken.
kenprice0 is offline   Reply With Quote
Old 08-26-2013, 10:12 AM   #1630
kenprice0
Scooby Newbie
 
Member#: 140017
Join Date: Feb 2007
Default Best rebuild shop in SA

All new to forum. Need advice on good shop for rebuilding heads & valve job and cylinder hone on EJ25 from 97 outback. Head gaskets blown and most likely rings. Also looking at best bargain rebuild kit to buy. On a budget but no skimping. Please no advice motivated by profit. Thx Ken.
kenprice0 is offline   Reply With Quote
Old 08-26-2013, 10:24 AM   #1631
HonduHunter
Scooby Guru
 
Member#: 28408
Join Date: Oct 2002
Chapter/Region: TXIC
Location: San Antonio, Tx
Vehicle:
2002 vf48ed WRX
PSM

Default

I took my head to miller machine shop off of Grissom.

They did a good job and took their time.

Unfortunately the turn around time was much longer than I was expecting. But the work was done well.
HonduHunter is online now   Reply With Quote
Old 08-26-2013, 06:57 PM   #1632
kenprice0
Scooby Newbie
 
Member#: 140017
Join Date: Feb 2007
Default

If I am ask what was the cost and services provided?
kenprice0 is offline   Reply With Quote
Old 08-26-2013, 08:20 PM   #1633
never_summer
Scooby Specialist
 
Member#: 114398
Join Date: May 2006
Chapter/Region: TXIC
Location: lubbock/san antonio
Vehicle:
2005 STI Stg2
CGM

Default

Any Tuesday or Wednesday meets in San Antonio?

Also I've been out of the Subaru game for awhile now, any idea what a perfect condition 2005 Sti cat back with 30 miles on it would cost? I've had it sitting in my garage since I brought the car home in 05!
never_summer is offline   Reply With Quote
Old 08-26-2013, 08:22 PM   #1634
HonduHunter
Scooby Guru
 
Member#: 28408
Join Date: Oct 2002
Chapter/Region: TXIC
Location: San Antonio, Tx
Vehicle:
2002 vf48ed WRX
PSM

Default

Quote:
Originally Posted by kenprice0 View Post
If I am ask what was the cost and services provided?
I think I spent about $400.

I had a valve job done and had them check the heads for cracks. Nothing fancy. Just basic stuff.
HonduHunter is online now   Reply With Quote
Old 08-27-2013, 03:22 AM   #1635
ntdemail
Scooby Newbie
 
Member#: 243692
Join Date: Apr 2010
Chapter/Region: TXIC
Location: New Braunsfels TX, 78132
Vehicle:
2004 WRX
Black

Default

Quote:
Originally Posted by never_summer View Post
Any Tuesday or Wednesday meets in San Antonio?

Also I've been out of the Subaru game for awhile now, any idea what a perfect condition 2005 Sti cat back with 30 miles on it would cost? I've had it sitting in my garage since I brought the car home in 05!
I know someone that wants one for about $100. Let me know if you'll let it go that. I got my full up pipe and turbo back for free.
ntdemail is offline   Reply With Quote
Old 08-27-2013, 09:16 AM   #1636
never_summer
Scooby Specialist
 
Member#: 114398
Join Date: May 2006
Chapter/Region: TXIC
Location: lubbock/san antonio
Vehicle:
2005 STI Stg2
CGM

Default

Quote:
Originally Posted by ntdemail View Post
I know someone that wants one for about $100. Let me know if you'll let it go that. I got my full up pipe and turbo back for free.
Pm'd ya
never_summer is offline   Reply With Quote
Old 08-29-2013, 10:51 PM   #1637
schplat
Scooby Newbie
 
Member#: 365000
Join Date: Aug 2013
Location: San Antonio
Vehicle:
2005 WRX STi
Blue

Default Selling my STi

Selling 2005 STi, 68k miles.

Completely stock
Interior is flawless
Exterior is in good shape for being 8 years old. Paint has normal road wear in it.
Mechanically Excellent
Original owner, non-smoking, garage kept, no accidents/clean title.

oil just changed, 5k miles on tires, 15k on brakes.

$16.000 O.B.O.

Pics: http://imgur.com/a/98rqD

If interested, text/leave message @ (210) 646-1663
schplat is offline   Reply With Quote
Old 08-30-2013, 12:28 AM   #1638
ntdemail
Scooby Newbie
 
Member#: 243692
Join Date: Apr 2010
Chapter/Region: TXIC
Location: New Braunsfels TX, 78132
Vehicle:
2004 WRX
Black

Default

Can someone accept me on Facebook? Is anyone out tonight?
ntdemail is offline   Reply With Quote
Old 08-30-2013, 12:29 AM   #1639
ntdemail
Scooby Newbie
 
Member#: 243692
Join Date: Apr 2010
Chapter/Region: TXIC
Location: New Braunsfels TX, 78132
Vehicle:
2004 WRX
Black

Default

Can someone accept me on Facebook? Is anyone out tonight? Also, does anyone have a blown up Scoob they want to sell? I'm looking for my next project.
ntdemail is offline   Reply With Quote
Old 09-03-2013, 12:49 AM   #1640
Luis Franco
Scooby Newbie
 
Member#: 263782
Join Date: Nov 2010
Location: Monterrey, Mexico
Vehicle:
2011 WRX STi
Satin White Pearl

Default

I have a couple of OEM parts from a 11 Sti to sell if anyone is interested, a TMIC and OEM Headers and DP.

Located in Selma, TX
Luis Franco is offline   Reply With Quote
Old 09-03-2013, 06:23 PM   #1641
protegeric
Scooby Newbie
 
Member#: 108733
Join Date: Feb 2006
Chapter/Region: TXIC
Location: TX
Vehicle:
2003 WRX

Default Having strange issues

Hey guys. I've been having some weird issues with my car lately, maybe someone here will have an idea or can help. I really need to get this cleared up. Here is what the car is doing...
The car for the most part, even in boost, has no power until it feels like waking up. And not because of turbo lag, it can be in or out of boost, no power no power, then maybe hit the gas a little more, little less, no change on the throttle and you might get something, might not.
Also, it will go in to boost when it shouldn't. When driving on flat road, not accelerating, it may go into somewhere around 1 psi of boost then go back into vacuum for no reason whatsoever.
It also likes to foul out spark plugs.
Very strange.
I understand that fouling out plugs may be a fuel problem, but that doesn't explain the erratic boost and complete lack of power (i have a COBB tuner with one of their tunes on it).
I bought a used waste gate actuator and installed that, but no change. I bought a brand new "universal" actuator but haven't got that on because it doesn't fit.

Please help! If anyone knows anything about this or can point me toward someone, i will gladly pay someone if they can seriously fix the problem. If you know someone or can help, please PM me i would really appreciate it.

03 WRX

Edit: Victor is a bad ass mechanic/bad ass dude. But he doesn't like doing aftermarket stuff and my car isn't really stock. Also while I'm thinking about it, the car was running great for years then all of a sudden one day, poop. If it would help to know something specific about the car, just ask me. Thanks!

Last edited by protegeric; 09-03-2013 at 06:58 PM.
protegeric is offline   Reply With Quote
Old 09-03-2013, 11:14 PM   #1642
spinx2005
Scooby Specialist
 
Member#: 166276
Join Date: Dec 2007
Chapter/Region: TXIC
Vehicle:
1991 panda gsx
monster

Default

Quote:
Originally Posted by protegeric View Post
Hey guys. I've been having some weird issues with my car lately, maybe someone here will have an idea or can help. I really need to get this cleared up. Here is what the car is doing...
The car for the most part, even in boost, has no power until it feels like waking up. And not because of turbo lag, it can be in or out of boost, no power no power, then maybe hit the gas a little more, little less, no change on the throttle and you might get something, might not.
Also, it will go in to boost when it shouldn't. When driving on flat road, not accelerating, it may go into somewhere around 1 psi of boost then go back into vacuum for no reason whatsoever.
It also likes to foul out spark plugs.
Very strange.
I understand that fouling out plugs may be a fuel problem, but that doesn't explain the erratic boost and complete lack of power (i have a COBB tuner with one of their tunes on it).
I bought a used waste gate actuator and installed that, but no change. I bought a brand new "universal" actuator but haven't got that on because it doesn't fit.

Please help! If anyone knows anything about this or can point me toward someone, i will gladly pay someone if they can seriously fix the problem. If you know someone or can help, please PM me i would really appreciate it.

03 WRX

Edit: Victor is a bad ass mechanic/bad ass dude. But he doesn't like doing aftermarket stuff and my car isn't really stock. Also while I'm thinking about it, the car was running great for years then all of a sudden one day, poop. If it would help to know something specific about the car, just ask me. Thanks!

already put the stock tune back on?
spinx2005 is offline   Reply With Quote
Old 09-04-2013, 12:10 AM   #1643
05spyvsspy
Scooby Newbie
 
Member#: 360360
Join Date: Jun 2013
Default

Start by checking vacuum hoses
05spyvsspy is offline   Reply With Quote
Old 09-04-2013, 09:14 AM   #1644
SnowmanFX
Scooby Specialist
 
Member#: 25753
Join Date: Oct 2002
Chapter/Region: TXIC
Location: San Antonio
Vehicle:
2002 Impreza WRX
Aspen White

Default

Sounds like an intercooler leak or the piping after the turbo. Our cars should never be below 7psi. That is waste gate pressure. If it is lower than that you have a serious leak.
SnowmanFX is offline   Reply With Quote
Old 09-04-2013, 01:24 PM   #1645
protegeric
Scooby Newbie
 
Member#: 108733
Join Date: Feb 2006
Chapter/Region: TXIC
Location: TX
Vehicle:
2003 WRX

Default

Quote:
Originally Posted by SnowmanFX View Post
Sounds like an intercooler leak or the piping after the turbo. Our cars should never be below 7psi. That is waste gate pressure. If it is lower than that you have a serious leak.
Well, if it decides to actually get moving, it'll boost to low double digits (COBB tune lvl 2). When it boosts very low it's just driving on flat road no extra accelerator pedal, so it's weird. But other than that, no power, no boost/erratic boost. Spinx, I've tried a couple different tunes. Possible vacuum leaks have been checked pretty well. The only things i haven't tried are swapping injectors, getting that new wastegate actuator on and new boost controller.
protegeric is offline   Reply With Quote
Old 09-04-2013, 01:32 PM   #1646
texasboost
Scooby Newbie
 
Member#: 345105
Join Date: Jan 2013
Chapter/Region: TXIC
Location: new braunfels
Vehicle:
2013 wrx
ice silver

Default

What do you want for the tmic luis?
texasboost is offline   Reply With Quote
Old 09-04-2013, 06:37 PM   #1647
StackSmasher
Scooby Specialist
 
Member#: 316928
Join Date: Apr 2012
Location: TX
Vehicle:
2012 STI limited

Default

Quote:
Originally Posted by protegeric View Post
Edit: Victor is a bad ass mechanic/bad ass dude. But he doesn't like doing aftermarket stuff
Quoted for truth.
StackSmasher is offline   Reply With Quote
Old 09-05-2013, 04:24 AM   #1648
HonduHunter
Scooby Guru
 
Member#: 28408
Join Date: Oct 2002
Chapter/Region: TXIC
Location: San Antonio, Tx
Vehicle:
2002 vf48ed WRX
PSM

Default

Quote:
Originally Posted by StackSmasher View Post

Quoted for truth.
What was it?
HonduHunter is online now   Reply With Quote
Old 09-05-2013, 08:15 PM   #1649
jey
Scooby Specialist
 
Member#: 32503
Join Date: Feb 2003
Chapter/Region: TXIC
Location: Johnson City, TX
Vehicle:
2011 Tribeca
1995 Legacy Wagon

Default

Quote:
Originally Posted by kenprice0 View Post
All new to forum. Need advice on good shop for rebuilding heads & valve job and cylinder hone on EJ25 from 97 outback. Head gaskets blown and most likely rings. Also looking at best bargain rebuild kit to buy. On a budget but no skimping. Please no advice motivated by profit. Thx Ken.
I had Duffin rebuild my EJ25 heads and they did a good job. I had to adjust the valve lash myself but I think that is standard.
jey is offline   Reply With Quote
Old 09-09-2013, 03:20 PM   #1650
Mr. Lin
Scooby Specialist
 
Member#: 344988
Join Date: Jan 2013
Chapter/Region: TXIC
Vehicle:
2013 WRX STi
ISM

Default

there was some broad on 1604 by bitters heading west around 9am today in a ism 11+ wrx 4dr with gold maybe meisters/d2s and a rear fog lamp. anyone?
Mr. Lin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rally San Antonio, San Marcos, Austin RichardM Texas Impreza Club Forum -- TXIC 6 05-11-2011 11:56 AM
ATX/San Marcos/San Antonio photoshoot aznburn210 Texas Impreza Club Forum -- TXIC 74 01-13-2008 11:31 PM
San Antonio Raceway thread Richardcranium419 Texas Impreza Club Forum -- TXIC 19 11-29-2007 08:08 PM
Tint/Inspection San Antonio/New Braunfels/San Marcos Area Yogiwerx Texas Impreza Club Forum -- TXIC 2 09-01-2006 04:06 PM
The San Antonio State Meet Thread Lux Texas Impreza Club Forum -- TXIC 33 01-25-2005 04:24 AM


All times are GMT -4. The time now is 04:35 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.