Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-04-2013, 03:38 PM   #1
xHairyBuffalo
Scooby Newbie
 
Member#: 239576
Join Date: Feb 2010
Chapter/Region: TXIC
Location: Fort Hood, TX
Vehicle:
2010 463WHP
Stock 5-speed

Default 93/E85 injectors for FP Red?

I'm currently running a 93 tune on my FP Red WRX with 1000cc injectors. I was previously running a dual fuel 93/e85 tune on the 1000s, but that was on the VF-52. I was told my injectors would be too small to make any significant gains on e85 since the FP Red is so much larger, so I opted out of the e85 tune. Now, I plan on going back to a 93/e85 dual fuel tune. So, my question is this:

What would the ideal injectors/size be to run a 93/e85 dual fuel tune for an FP Red, with a Walbro 400e85 pump? I would like for them to be big enough to not limit the power of the FP Red, but still be drivable on 93. My tuner is recommending five-0 1400cc, but Im pretty sure that's only because they have a contract with them... I've seen posts about them having horrible drivability and constant mis-fires. Thanks!
* Registered users of the site do not see these ads.

Last edited by xHairyBuffalo; 08-04-2013 at 03:43 PM.
xHairyBuffalo is offline   Reply With Quote
Old 08-04-2013, 03:50 PM   #2
Shortpersonbk
Scooby Specialist
 
Member#: 319017
Join Date: May 2012
Chapter/Region: MWSOC
Location: Michigan
Vehicle:
91 Miata
slow sti 6266 e-85

Default

Find some id1300s i believe they are out now
----
Im scared of all injectors but id because horror stories from other brands then them lately. Im not sure about Five-O but at least they didnt suggest DWs lol.
Shortpersonbk is online now   Reply With Quote
Old 08-04-2013, 05:13 PM   #3
xHairyBuffalo
Scooby Newbie
 
Member#: 239576
Join Date: Feb 2010
Chapter/Region: TXIC
Location: Fort Hood, TX
Vehicle:
2010 463WHP
Stock 5-speed

Default

Wow, thanks for the heads up. Those ID1300s look perfect for my setup, exactly what I was looking for. Thanks!
xHairyBuffalo is offline   Reply With Quote
Old 08-04-2013, 05:35 PM   #4
bjohnson_55
Scooby Specialist
 
Member#: 216580
Join Date: Jul 2009
Chapter/Region: MWSOC
Location: Indy- johnsontuning
Vehicle:
2004 STi-Sold
Java Black Pearl

Default

+1 for the ID1300's. Just a good as the ID1000's. Don't waste your money on anything else.
bjohnson_55 is offline   Reply With Quote
Old 08-18-2013, 04:59 PM   #5
Bizko1288
Scooby Newbie
 
Member#: 151260
Join Date: Jun 2007
Chapter/Region: MAIC
Location: Annapolis, MD
Vehicle:
2005 Sti
423whp/422wtq on 93

Default

You could save some money and just bump your fuel pressure to get more CC out of your ID1000s. That is the route I am going. ID1300s are so expensive, and I was told you can still only get them from T1.

I have an FP Red and am installing ID1000s next week to run E85 and plan on doing just that.

I'll bump this thread once I log what my duty cycles are at higher pressures

Edit: It worked for this guy.

http://forums.nasioc.com/forums/show....php?t=2453554

Last edited by Bizko1288; 08-18-2013 at 05:31 PM.
Bizko1288 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:37 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.