Welcome to the North American Subaru Impreza Owners Club Saturday July 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-21-2013, 04:55 AM   #1
youngw682eni
Scooby Newbie
 
Member#: 317050
Join Date: Apr 2012
Chapter/Region: MAIC
Vehicle:
2007 Subaru Wrx
Garnet Red Pearl

Default

Here is a video of the problem. I am unsure what the problem is so looking for some help. It happens in 4th and 5th gear from mid throttle onwards (most noticeable). Revs build as of the clutch was depressed although its not. Any help is appreciated. Thanks in advance.

http://m.youtube.com/watch?v=vB2wzJq...e_gdata_player
* Registered users of the site do not see these ads.

Last edited by youngw682eni; 08-21-2013 at 05:18 AM.
youngw682eni is offline   Reply With Quote
Old 08-21-2013, 05:36 AM   #2
Minorthreat7171
Scooby Newbie
 
Member#: 288712
Join Date: Jul 2011
Chapter/Region: MAIC
Location: Lancaster, PA
Vehicle:
2007 WRX IAP Stage2
WRB

Default

have you recently gone stage 2 using a Cobb OTS map?
Minorthreat7171 is online now   Reply With Quote
Old 08-21-2013, 05:41 AM   #3
JonnyV2889
Scooby Specialist
 
Member#: 197384
Join Date: Dec 2008
Chapter/Region: NESIC
Location: MWV NH
Vehicle:
2006 WRX Ltd
OBP

Default

Looks like another clutch bit the dust.
JonnyV2889 is online now   Reply With Quote
Old 08-21-2013, 05:42 AM   #4
youngw682eni
Scooby Newbie
 
Member#: 317050
Join Date: Apr 2012
Chapter/Region: MAIC
Vehicle:
2007 Subaru Wrx
Garnet Red Pearl

Default

I haven't. The Car is tuned and has been for some time. Simple mods. K/N Filter, Exhuast, Lightweight Crank Pulley.
youngw682eni is offline   Reply With Quote
Old 08-21-2013, 05:46 AM   #5
Minorthreat7171
Scooby Newbie
 
Member#: 288712
Join Date: Jul 2011
Chapter/Region: MAIC
Location: Lancaster, PA
Vehicle:
2007 WRX IAP Stage2
WRB

Default

Then I'd have to agree with JonnyV.
Minorthreat7171 is online now   Reply With Quote
Old 08-22-2013, 11:11 AM   #6
krylon
Scooby Specialist
 
Member#: 56761
Join Date: Mar 2004
Chapter/Region: Tri-State
Location: NYC
Vehicle:
9599 EJ255 EJ257 GC8
Rally Blues

Default

Is the rev due to you applying pressure to throttle pedal, or just a random surge?

If it is due to you, how old is your clutch. Sure signs of wear, when you are asking for the mid range punch. Very commonly seen on 2,3,6 picks style discs. Do you get any chatter when you get going from zero?
krylon is offline   Reply With Quote
Old 08-22-2013, 12:25 PM   #7
youngw682eni
Scooby Newbie
 
Member#: 317050
Join Date: Apr 2012
Chapter/Region: MAIC
Vehicle:
2007 Subaru Wrx
Garnet Red Pearl

Default

I do have chatter from Zero. I am unsure how old the clutch is as the car was purchased by me just over a year ago. I have ordered a replacement Clutch and flywheel. Should fix the problem.
youngw682eni is offline   Reply With Quote
Old 08-22-2013, 12:25 PM   #8
JonnyV2889
Scooby Specialist
 
Member#: 197384
Join Date: Dec 2008
Chapter/Region: NESIC
Location: MWV NH
Vehicle:
2006 WRX Ltd
OBP

Default

Quote:
Originally Posted by krylon View Post
Is the rev due to you applying pressure to throttle pedal, or just a random surge?

If it is due to you, how old is your clutch. Sure signs of wear, when you are asking for the mid range punch. Very commonly seen on 2,3,6 picks style discs. Do you get any chatter when you get going from zero?
Even if it's due to "surge" it's not getting to the tranny as speed didn't increase.
JonnyV2889 is online now   Reply With Quote
Old 08-22-2013, 01:58 PM   #9
krylon
Scooby Specialist
 
Member#: 56761
Join Date: Mar 2004
Chapter/Region: Tri-State
Location: NYC
Vehicle:
9599 EJ255 EJ257 GC8
Rally Blues

Default

^ this is true. Watching vid on POS phone, everything is fuzzy. Good analysis J5
krylon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:09 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.