Welcome to the North American Subaru Impreza Owners Club Sunday March 29, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-23-2013, 07:38 AM   #1
E-brake29
Scooby Newbie
 
Member#: 359107
Join Date: Jun 2013
Location: Orono, Maine
Vehicle:
2007 Impreza

Default 2007 Subaru Impreza shaking at startup

Hey guys. I'm trying to figure out what is wrong with my car. Cylinders 2 has been misfiring for a while, but it only seems really noticeable at startup. I've replaced my plugs, wires, coilpack, valve cover gasket, head gasket, and timing belt with no luck. A little bit of white smoke comes out the tailpipe when I first start it up. Could it be a dirty fuel injector? Any opinions are welcomed!

Thanks
* Registered users of the site do not see these ads.
E-brake29 is offline   Reply With Quote
Old 08-23-2013, 10:35 AM   #2
02boostman
Scooby Newbie
 
Member#: 313989
Join Date: Mar 2012
Default

sounds like a good place to turn to next. looks like you have knocked out a bunch of the usual suspects, but perhaps with a miss-fire, it could be due to not getting enough fuel?
02boostman is offline   Reply With Quote
Old 08-23-2013, 02:09 PM   #3
GrundleJuice
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: ლಠ益ಠ&
Default

White smoke could be an indication of an internal head gasket leak. You may be able to confirm this with a hot leak down test.

What is the coolant level at? Is the coolant dark in color or does the oil have a light, milky tint to it?
GrundleJuice is offline   Reply With Quote
Old 08-23-2013, 06:22 PM   #4
E-brake29
Scooby Newbie
 
Member#: 359107
Join Date: Jun 2013
Location: Orono, Maine
Vehicle:
2007 Impreza

Default

Quote:
Originally Posted by RaceFaceXC View Post
White smoke could be an indication of an internal head gasket leak. You may be able to confirm this with a hot leak down test.

What is the coolant level at? Is the coolant dark in color or does the oil have a light, milky tint to it?
The coolant level is at the same spot when I had the head gasket replaced a week ago. The coolant looks normal colored. Maybe it's running lean?
E-brake29 is offline   Reply With Quote
Old 08-23-2013, 08:22 PM   #5
GrundleJuice
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: ლಠ益ಠ&
Default

Quote:
Originally Posted by E-brake29 View Post

The coolant level is at the same spot when I had the head gasket replaced a week ago. The coolant looks normal colored. Maybe it's running lean?
Yes, that is certainly plausible. You could test the injector theory by swapping injectors with another cylinder and see if that misfire follows the injector. I would use new orings and a light smearing of fuel fitting lube, oring lube, silicone grease or anything that is for fuel systems. Would suck if the old oring rolled or leaked and fooled your diagnosis.
GrundleJuice is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 03:37 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.