Welcome to the North American Subaru Impreza Owners Club Saturday April 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-27-2013, 05:06 PM   #1
protivakid
Scooby Newbie
 
Member#: 265148
Join Date: Nov 2010
Location: MA
Vehicle:
2001 Legacy
Blue

Default Keyless entry Lock & the Hatch problem

I have a crosstrek but since it's pretty much the same as the impreza hatch figured I would ask here.

One annoyance I am having is that each time I get out of the car, open the hatch by pressing the button on the back of the car, close the hatch, and then press "Lock" on the keyless entry remote the car does not lock. I have to either wait a minute for the interior lights to turn off and then I can lock it with the remote, or open the driver door and press lock.

This seems like a "broken by design" issue but didn't know if others had a solution to this problem.
* Registered users of the site do not see these ads.
protivakid is offline   Reply With Quote
Old 08-27-2013, 11:48 PM   #2
hemophilic
Scooby Newbie
 
Member#: 301213
Join Date: Nov 2011
Chapter/Region: South East
Location: Raleigh, NC
Vehicle:
2012 Imp. Sp. Ltd.
Blue/Silver

Default

My '12 Sport Limited does not do that. I can lock my car immediately after closing the hatch or any door for that matter. I definitely would not like that "feature". Maybe there is a manual override?
hemophilic is offline   Reply With Quote
Old 08-28-2013, 07:43 AM   #3
KC
Scooby Guru
 
Member#: 442
Join Date: Oct 1999
Chapter/Region: NESIC
Location: SE Mass/RI
Vehicle:
2013 Crosstrek XV
00 Honda S2000

Default

My XV does not have to wait either. As soon as the hatch closes, I can lock it sucessfully.

--kC
KC is online now   Reply With Quote
Old 08-28-2013, 08:09 AM   #4
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

My XV will lock as soon as I hit the button.
79letour is offline   Reply With Quote
Old 08-28-2013, 10:23 AM   #5
protivakid
Scooby Newbie
 
Member#: 265148
Join Date: Nov 2010
Location: MA
Vehicle:
2001 Legacy
Blue

Default

Just tried opening the hatch from the keyless entry for the 1st time and that doesn't work either. Has been doing the no lock thing since day 1 too. Just thought it was another annoyance. I'll take it in to see whats wrong.
protivakid is offline   Reply With Quote
Old 08-28-2013, 10:54 AM   #6
KC
Scooby Guru
 
Member#: 442
Join Date: Oct 1999
Chapter/Region: NESIC
Location: SE Mass/RI
Vehicle:
2013 Crosstrek XV
00 Honda S2000

Default

Good idea. Could be a bad signal or bad programming from the factory.

I can lock the car, and then unlock the hatch using the key fob buttons (and the doors will remain locked except for the hatch.)

At that, if I don't open the hatch within something like 15 seconds or 30 seconds, it will lock by itself if the car is already locked.

The hatch will NOT unlock if the key is in the ignition and using the key to unlock it.

--kC
KC is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:08 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.