Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-29-2013, 05:41 PM   #1
subiedoutlegacy
Scooby Newbie
 
Member#: 357802
Join Date: May 2013
Chapter/Region: Tri-State
Location: Sussex County, NJ
Vehicle:
1991 Legacy SS
Mica Red

Default 1994 legacy ej22 engine tick!

I recently spent days removing the head gaskets on my 1994 Subaru legacy with 233, 000 miles on it I got the heads boured and resurfaced and put everything back together. I replaced the water pump, timing belt and changed oil now I seem to have a fairly decent engine tick. What could it be? Bad valves? Seals? Please help this is my only car and I've been without it for almost a week now.
subiedoutlegacy is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:48 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.