Welcome to the North American Subaru Impreza Owners Club Wednesday January 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-20-2013, 08:28 AM   #76
VTSubieRS
Scooby Specialist
 
Member#: 90608
Join Date: Jul 2005
Chapter/Region: South East
Location: Vermont & St. Simons Georgia
Vehicle:
2005 STI, '08 3.0R
05 2.5RS, 92 Legacy L

Default

someone please help me out. Someone else with an 05 sti must have done this mod, and/or someone else must have run into wiring color differences. i would love to get this mod done without process of trial and error.

theres no other red wire coming out of that relay on mine... just red/blue stripe- which you can see I cut. It looks like a different pinout than the OP. I thinnk the white/blue stripe looks like the same pinout, but I don't want to cut it and have it not be the right one again.

tapped orange wire..


only red wire on relay.. red/blue stripe:
* Registered users of the site do not see these ads.
VTSubieRS is offline   Reply With Quote
Old 05-04-2013, 05:26 AM   #77
jose_a_v31
Scooby Newbie
 
Member#: 280138
Join Date: Apr 2011
Chapter/Region: South East
Location: Jacksonville, FL
Vehicle:
2006 Impreza STi
WRB

Default

Nice write up, my only question is, does it stay off when the car is off? There is another mod that involves only one wire, but it gets tied to a constant 12v, so the lights stay on regardless if the car is off.
jose_a_v31 is offline   Reply With Quote
Old 05-04-2013, 12:47 PM   #78
rex.effect
Scooby Newbie
 
Member#: 99745
Join Date: Nov 2005
Location: Baltimore, MD
Vehicle:
2013 C-Max Hybrid
Titanium White TriCoat

Default

no, doing it this way powers them off when you take out the key.
rex.effect is offline   Reply With Quote
Old 05-07-2013, 06:13 PM   #79
ScoobyFreak86
Scooby Specialist
 
Member#: 338329
Join Date: Nov 2012
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2013 WRX Hatch
SWP

Default

Want to do this to my 2013 wrx hatch. Any DIY's for it?
ScoobyFreak86 is offline   Reply With Quote
Old 05-08-2013, 09:17 AM   #80
rex.effect
Scooby Newbie
 
Member#: 99745
Join Date: Nov 2005
Location: Baltimore, MD
Vehicle:
2013 C-Max Hybrid
Titanium White TriCoat

Default

Is the 13 model that much different than the 11's? I haven't had my subby for a while now, so I am a little out of the loop.

Here is my write-up for the Fog Light Bypass on an 11' STi Limited.

Last edited by rex.effect; 05-08-2013 at 09:36 AM.
rex.effect is offline   Reply With Quote
Old 05-08-2013, 12:40 PM   #81
ScoobyFreak86
Scooby Specialist
 
Member#: 338329
Join Date: Nov 2012
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2013 WRX Hatch
SWP

Default

^ Definitely a great write up, but still a little confusing to me. Not great with electrical work as I feel I would get a bit overwhelmed with the different colors and what to actually do. I would feel more comfortable having someone there that knows what they are doing. Thanks though!
ScoobyFreak86 is offline   Reply With Quote
Old 05-08-2013, 01:00 PM   #82
rex.effect
Scooby Newbie
 
Member#: 99745
Join Date: Nov 2005
Location: Baltimore, MD
Vehicle:
2013 C-Max Hybrid
Titanium White TriCoat

Default

Quote:
Originally Posted by ScoobyFreak86 View Post
^ Definitely a great write up, but still a little confusing to me. Not great with electrical work as I feel I would get a bit overwhelmed with the different colors and what to actually do. I would feel more comfortable having someone there that knows what they are doing. Thanks though!
I understand you apprehensiveness. Yes, it is all a little confusing, but the premise should be the same through all the model years. Find the lead from the stalk, sever it. Find the lead from the module, severe it. Run a "jumper" wire from stalk lead to "out" side module lead. All this process is doing, is literally taking the start of a wire, removing the "middle man" control module, and reconnecting the wire on the other side.

If your concerns come from the wire colors, i.e. you get under there with the panels off and don't see the wire colors mentioned in the write up, then all you need is a volt meter.

Turn the fogs on, test each wire at stalk side for voltage, note color. If you get more than one positive result, then turn off the fogs and try your wires again. Do the same thing on the back side of the control module. Once you have the correct wires noted, then you just cut and connect as described in each of the write ups.

Anyone local to Northeast Baltimore with a 2013 can feel free to contact me for a meet up. I can climb under there and figure things out pretty quickly to tell if the wires are still the same colors.

PS - I did this mod in my 04 WRX, 05 STI, and 11 STI.
rex.effect is offline   Reply With Quote
Old 05-08-2013, 05:22 PM   #83
wrxposer
Scooby Newbie
 
Member#: 188219
Join Date: Aug 2008
Chapter/Region: VIC
Location: Vernon, BC
Vehicle:
2007 2.5i Ltd.
CGM

Default

Quote:
Originally Posted by rex.effect View Post
I understand you apprehensiveness. Yes, it is all a little confusing, but the premise should be the same through all the model years. Find the lead from the stalk, sever it. Find the lead from the module, severe it. Run a "jumper" wire from stalk lead to "out" side module lead. All this process is doing, is literally taking the start of a wire, removing the "middle man" control module, and reconnecting the wire on the other side.

If your concerns come from the wire colors, i.e. you get under there with the panels off and don't see the wire colors mentioned in the write up, then all you need is a volt meter.

Turn the fogs on, test each wire at stalk side for voltage, note color. If you get more than one positive result, then turn off the fogs and try your wires again. Do the same thing on the back side of the control module. Once you have the correct wires noted, then you just cut and connect as described in each of the write ups.

Anyone local to Northeast Baltimore with a 2013 can feel free to contact me for a meet up. I can climb under there and figure things out pretty quickly to tell if the wires are still the same colors.

PS - I did this mod in my 04 WRX, 05 STI, and 11 STI.
Is 06-07 wired differently (see the diagram I posted in this thread) because this did not work on my 07? Can anybody else confirm this? This worked on your 04-05? I really wanna do this so I can shut off my HIDs when I want to. Right now I'm just running with them on all of the time with the DRL resistor bypassed.
wrxposer is offline   Reply With Quote
Old 05-08-2013, 09:04 PM   #84
rex.effect
Scooby Newbie
 
Member#: 99745
Join Date: Nov 2005
Location: Baltimore, MD
Vehicle:
2013 C-Max Hybrid
Titanium White TriCoat

Default

Quote:
Originally Posted by wrxposer View Post
Is 06-07 wired differently (see the diagram I posted in this thread) because this did not work on my 07? Can anybody else confirm this? This worked on your 04-05? I really wanna do this so I can shut off my HIDs when I want to. Right now I'm just running with them on all of the time with the DRL resistor bypassed.
I don't see your post containing the diagram.

Here is the thread for my 05 setup. The other person in the thread had an 06 and was able to follow the guide to get it working. Again, the 06 should be the same as 07 in wires color. Check my second thread and see if that helps you.

I miss my Subbie so much

Last edited by rex.effect; 05-10-2013 at 02:25 PM.
rex.effect is offline   Reply With Quote
Old 05-09-2013, 07:19 PM   #85
wrxposer
Scooby Newbie
 
Member#: 188219
Join Date: Aug 2008
Chapter/Region: VIC
Location: Vernon, BC
Vehicle:
2007 2.5i Ltd.
CGM

Default

Quote:
Originally Posted by rex.effect View Post
I don't see your post containing the diagram.
my bad, sorry I thought I was posting in the Fogs as DRLs thread that I'm also subscribed to.

Independent fogs with DRLs disabled will probably be the way I have to go though since I can't get the fogs as DRLs to work on my 07
wrxposer is offline   Reply With Quote
Old 05-10-2013, 11:05 AM   #86
rex.effect
Scooby Newbie
 
Member#: 99745
Join Date: Nov 2005
Location: Baltimore, MD
Vehicle:
2013 C-Max Hybrid
Titanium White TriCoat

Default

Quote:
Originally Posted by wrxposer View Post
my bad, sorry I thought I was posting in the Fogs as DRLs thread that I'm also subscribed to.

Independent fogs with DRLs disabled will probably be the way I have to go though since I can't get the fogs as DRLs to work on my 07
Are the 2.5i's wiring less involved than the wrx or sti? Where did you obtain that wiring diagram from? Are you absolutely sure it matches youR 2.5i.

Last edited by rex.effect; 05-10-2013 at 02:27 PM.
rex.effect is offline   Reply With Quote
Old 07-21-2013, 08:29 PM   #87
TheBOOSTisLOOSE
Scooby Newbie
 
Member#: 343493
Join Date: Jan 2013
Chapter/Region: MWSOC
Vehicle:
2002 WRX
Platinum Silver Metallic

Default

Just did this Foglight rewire today and It worked like a charm! great writeup!!!




TheBOOSTisLOOSE is offline   Reply With Quote
Old 07-22-2013, 08:22 PM   #88
silver_subaru
Scooby Newbie
 
Member#: 362756
Join Date: Jul 2013
Default

[quote=insane_one;35979489]

Maybe I missed this when I read through the thread. Do the fog lights work all alone? I keep seeing pics where the running a lights are still on!
silver_subaru is offline   Reply With Quote
Old 07-23-2013, 12:22 AM   #89
TheBOOSTisLOOSE
Scooby Newbie
 
Member#: 343493
Join Date: Jan 2013
Chapter/Region: MWSOC
Vehicle:
2002 WRX
Platinum Silver Metallic

Default

you have to have at least the switch turned to parking lights for the fogs to work. this is wiring to make the fogs work with running lights or with head lights
TheBOOSTisLOOSE is offline   Reply With Quote
Old 07-23-2013, 01:12 AM   #90
silver_subaru
Scooby Newbie
 
Member#: 362756
Join Date: Jul 2013
Default

Quote:
Originally Posted by TheBOOSTisLOOSE View Post
you have to have at least the switch turned to parking lights for the fogs to work. this is wiring to make the fogs work with running lights or with head lights

Oh ok I was hoping you could wire it with nothing but the fogs! Thanks for the tutorial! Can't wait to get it done!!!
silver_subaru is offline   Reply With Quote
Old 07-24-2013, 12:49 PM   #91
donnyjaguar
Scooby Newbie
 
Member#: 363137
Join Date: Jul 2013
Default Anyone have a wiring diagram for 2008 Legacy/Outback?

I'd like to modify my foglights to do the same but this modification doesn't look at all like my car. FWIW, my car uses the middle "parking" lights for the daytime running lights. Every wiring diagram I've seen shows the low-beam as being used for the DRLs. Any help/links appreciated.
donnyjaguar is offline   Reply With Quote
Old 08-18-2013, 12:26 AM   #92
emphrum26
Scooby Newbie
 
Member#: 287380
Join Date: Jul 2011
Chapter/Region: MWSOC
Location: Madison, WI
Vehicle:
2006 Legacy GT
Brilliant Silver

Default

Thanks for the great write up!



Here's mine
emphrum26 is offline   Reply With Quote
Old 08-21-2013, 08:03 PM   #93
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

i gotta mount my new led driving lights...install the new fog lights and re-wire the whole damned thing so i can light up the night....driving at night way out in the middle of nowhere where there isnt ANY light other than your lights, REALLY shows the weakness of the stock lighting.....im still diggin the osram rallye 65w H7 + 9011 combo in my 06 wrx but the stock fogs are garbage and a set of good, PROPERLY AIMED, driving lights has just gotta happen.
Uncle Scotty is offline   Reply With Quote
Old 09-09-2013, 05:11 PM   #94
rdeezWRX
Scooby Newbie
 
Member#: 349202
Join Date: Mar 2013
Chapter/Region: BAIC
Location: Bay Area, CA
Vehicle:
2002 WRX
Platinum Silver Metallic

Default

I just did a quick test before I ran to the store to get a terminal for the ground and it seems like the button is working without rerouting the green/yellow fog wire.. Should I reroute it anyway or can I leave it as is without touching it? Would it mess anything up specifically if I didn't?
rdeezWRX is offline   Reply With Quote
Old 10-18-2013, 04:46 PM   #95
Culti
Scooby Newbie
 
Member#: 248192
Join Date: May 2010
Location: Wayne, PA
Vehicle:
2007 STi
OBP

Default

No one seems to have answered the 2007 STi question so I'm going to ask again. There is no ORANGE wire to tap into for 12V constant power... Can someone please post a picture of the wire to tap into for power for 2007 STi. I've posted in 5 other suby forums for an answer because there seems to be no info on it... Thanks in advance.
Culti is offline   Reply With Quote
Old 10-24-2013, 03:57 AM   #96
tjmmason93
Scooby Newbie
 
Member#: 300250
Join Date: Nov 2011
Chapter/Region: MAIC
Location: va
Vehicle:
2004 Impreza WRX
JBP

Default

Quote:
Originally Posted by popeball View Post
i followed the instructions exactly but my foglights are not independent, they require the parking lights to be on. other than that everything works. is there any way for me to now get the foglights to run by themselves, without any other exterior lighting?
i have a 2006 2.5i
thanks

im wondering the same thing, how can you do this and have them 100% independent along with the indicator light stating that the fogs are on
tjmmason93 is offline   Reply With Quote
Old 11-19-2013, 11:15 PM   #97
shredhead511
Scooby Newbie
 
Member#: 371199
Join Date: Oct 2013
Chapter/Region: RMIC
Location: Colorado
Vehicle:
2007 Impreza Hatch

Default

Great write up man, worked great. Pictures like this are always helpful.
shredhead511 is offline   Reply With Quote
Old 11-25-2013, 10:04 AM   #98
Con6tY5efs
*** Banned ***
 
Member#: 374396
Join Date: Nov 2013
Default

neat soldering tip that is perfect for these kinds of wiring jobs.



Con6tY5efs is offline   Reply With Quote
Old 12-22-2013, 02:32 AM   #99
kozeeh
Scooby Newbie
 
Member#: 312098
Join Date: Mar 2012
Default

thanks insane_one for the awesome DIY ! just did this earlier took about 20mins, i followed the instructions to have the fog light button illuminate but mine is not working, maybe a bad ground? (1 of the 2 10mm nuts above fuse box) too lazy to go back under there and find good ground i will live with it for a bit until i decide its bothering me. THANKS !
kozeeh is offline   Reply With Quote
Old 04-26-2014, 11:25 AM   #100
Scuba Roo
Scooby Newbie
 
Member#: 384037
Join Date: Mar 2014
Location: Oklahoma
Vehicle:
2014 Bonestock hatch
Charcoal

Default

Quote:
Originally Posted by ScoobyFreak86 View Post
Want to do this to my 2013 wrx hatch. Any DIY's for it?
YES PLEASE! i have a 2014 and cant find a DIY similar to this one i really would rather do this then have to wire a separate relay and all that bs.
Scuba Roo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to DIY: DRL Disable insane_one Electrical & Lighting 22 01-06-2015 08:01 PM
Independent Foglight Mod writeup for the BE Guys MitchGT Legacy Forum 5 04-29-2005 01:20 AM
how to change the foglight bulb Grey Ghost Electrical & Lighting 12 04-27-2005 11:25 PM
how to aim my foglights? legacy2003 Electrical & Lighting 2 09-24-2004 10:14 AM
How to aim stock foglights? ShutUpGeek Electrical & Lighting 2 01-11-2004 08:20 PM


All times are GMT -4. The time now is 10:29 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.