Welcome to the North American Subaru Impreza Owners Club Sunday October 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > General Community

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-27-2013, 10:36 AM   #1
foof247
Scooby Specialist
 
Member#: 290623
Join Date: Aug 2011
Chapter/Region: MWSOC
Location: Detroit Metro, Michigan
Vehicle:
2015 Wrx
Dark grey

Default Weird turbo sound? video

I am getting this strange sound from my turbo every time i enter boost. I am not sure if it is coming from the inlet hose or the coupler. The coupler does keep coming loose and recently bought a new one but have not installed yet. Is that sound anything i should be worried about?
Sorry about the video orientation but it is more for the sound. My mods:
16g turbo, perrin inlet hose, external wastegate, support mods.

* Registered users of the site do not see these ads.

Last edited by foof247; 09-27-2013 at 10:49 AM.
foof247 is offline   Reply With Quote
Old 09-27-2013, 01:48 PM   #2
Back Road Runner
Scooby Guru
 
Member#: 60082
Join Date: Apr 2004
Chapter/Region: MWSOC
Location: Minnesota
Vehicle:
2004 Forester STI
Silver

Default

Does the car make boost? Does the boost come in later than normal?
Back Road Runner is offline   Reply With Quote
Old 09-27-2013, 02:50 PM   #3
GrimmSpeed
NASIOC Vendor
 
Member#: 136396
Join Date: Jan 2007
Chapter/Region: MWSOC
Location: Minneapolis, MN
Vehicle:
2013 BRZ
SWP

Default

The high pitched noise? It sounds like it could be a boost leak. I would do a smoke or pressure test to track down where the problem is coming from.

Mike
GrimmSpeed is offline   Reply With Quote
Old 09-27-2013, 05:54 PM   #4
foof247
Scooby Specialist
 
Member#: 290623
Join Date: Aug 2011
Chapter/Region: MWSOC
Location: Detroit Metro, Michigan
Vehicle:
2015 Wrx
Dark grey

Default

Boost comes in fine, but it does sound like air is coming from somewhere. when I get some time
Maybe I'll try to do that test
foof247 is offline   Reply With Quote
Old 09-27-2013, 05:57 PM   #5
funnky
Scooby Newbie
 
Member#: 330236
Join Date: Aug 2012
Chapter/Region: RMIC
Location: grand Junction,CO
Vehicle:
2002 wrx
blue and black

Default

turbo inlet gaskets. look at both of them and make sure they are in good shape. i had same problem and my gaskets were old and coming apart. id take a look and those and maybe replace them. the noise is the gasket vibrating under boost again the flange.
funnky is offline   Reply With Quote
Old 09-27-2013, 06:06 PM   #6
dirtcollector
Scooby Newbie
 
Member#: 357347
Join Date: May 2013
Chapter/Region: SCIC
Location: east county san diego
Vehicle:
2005 wrx sti
aspen white

Default

Quote:
Originally Posted by funnky View Post
turbo inlet gaskets. look at both of them and make sure they are in good shape. i had same problem and my gaskets were old and coming apart. id take a look and those and maybe replace them. the noise is the gasket vibrating under boost again the flange.

Wtf is a Turbo inlet gasket.....
dirtcollector is offline   Reply With Quote
Old 09-27-2013, 06:50 PM   #7
foof247
Scooby Specialist
 
Member#: 290623
Join Date: Aug 2011
Chapter/Region: MWSOC
Location: Detroit Metro, Michigan
Vehicle:
2015 Wrx
Dark grey

Default

Quote:
Originally Posted by dirtcollector View Post
Wtf is a Turbo inlet gasket.....
I didn't know they existed either but I'll look into that too
foof247 is offline   Reply With Quote
Old 09-27-2013, 11:16 PM   #8
Vertiay
Scooby Newbie
 
Member#: 124941
Join Date: Sep 2006
Chapter/Region: Tri-State
Location: Scranton, PA
Vehicle:
2014 WRX STI Hatch
2014 2.0 FXT Touring

Default

Quote:
Originally Posted by funnky View Post
turbo inlet gaskets. look at both of them and make sure they are in good shape. i had same problem and my gaskets were old and coming apart. id take a look and those and maybe replace them. the noise is the gasket vibrating under boost again the flange.
Up pipe gasket maybe. ...?
Vertiay is offline   Reply With Quote
Old 09-27-2013, 11:22 PM   #9
Red_Wrx
Scooby Specialist
 
Member#: 158658
Join Date: Sep 2007
Chapter/Region: SCIC
Location: California
Default

Could be your weak ass hose clamps and air is whisling.. But then again I couldn't hear anything on the vid and I'm just assuming off your guy's assumptions .. Lol GL
Red_Wrx is offline   Reply With Quote
Old 09-30-2013, 05:30 PM   #10
foof247
Scooby Specialist
 
Member#: 290623
Join Date: Aug 2011
Chapter/Region: MWSOC
Location: Detroit Metro, Michigan
Vehicle:
2015 Wrx
Dark grey

Default

Turns out my clamps were terrible. I'm changing to t bolts
foof247 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:26 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.