Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-28-2013, 09:21 PM   #1
Samiam1017
Scooby Specialist
 
Member#: 334068
Join Date: Oct 2012
Location: North eastern pa.
Default Installing 06wrx avcs heads on an 05 Wrx

I want to install 06 Wrx singls avcs heads onto an 05 Wrx. I've done a lot of searching but most turn up results for 207 swaps. I want the avcs to work and know I need a Jdm ecu. But I'm not sure of the correct version? Also the cam position sensors are different and use a different plug (avcs heads have three wires as opposed to two) whats the fix for this as I am using the 05 engine harrness? Thx
* Registered users of the site do not see these ads.
Samiam1017 is offline   Reply With Quote
Old 09-29-2013, 07:39 PM   #2
subaru_gc8
Scooby Specialist
 
Member#: 29292
Join Date: Nov 2002
Chapter/Region: SCIC
Location: Orange County CA
Vehicle:
2004 WRX wagon
silver

Default

I think there is a problem with the bore size/ the heads bore is too big for a 2.0.if you wanat avcs, you gotta do the jdm heads
subaru_gc8 is online now   Reply With Quote
Old 09-30-2013, 08:56 PM   #3
Samiam1017
Scooby Specialist
 
Member#: 334068
Join Date: Oct 2012
Location: North eastern pa.
Default

It's accually a 257 sti short block. I posted in the wrong area. But I want to use all the 2.0 05 Wrx stuff on the new long lock and make the avcs work
Samiam1017 is offline   Reply With Quote
Old 09-30-2013, 11:36 PM   #4
shredboostnburn420
Scooby Newbie
 
Member#: 277436
Join Date: Mar 2011
Chapter/Region: RMIC
Location: Lakewood Colorado
Vehicle:
2005 Impreza WRX STI
Aspen White

Default

It will work fine. depending on what cams you go with the avcs will have to be plugged in the cams if using sti cams. and your solid wrx cam gears used. you might need to buy a cam sensor bracket for the front pickup. If you want to use avcs look into a stand alone or sti ecu/engine harness swap.
shredboostnburn420 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:14 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.