Welcome to the North American Subaru Impreza Owners Club Thursday August 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-28-2013, 09:17 AM   #1
DOHBOYWRX
Scooby Newbie
 
Member#: 314698
Join Date: Mar 2012
Chapter/Region: South East
Location: Miami
Vehicle:
2005 WRX
White "Phatbotti Tuned"

Default 2007 Sti Tranny into 2005 Wrx

Hey guys whats going on. This question might of been answered in other threads but was unable to find an answer using the phone app.

This is my situation. I have a 2005 WRX and I just swapped in a 2007 Sti transmission. I used auto DS with my r160 and I used the dccd universal kit for the dccd controlling unit. My question is why are my speedometer and odometer not working? Could I have done something wrong or do i need to get the vsspro kit made by dccd for my swap?

Please help and thanks in advance for any information you can give me!
* Registered users of the site do not see these ads.
DOHBOYWRX is offline   Reply With Quote
Old 09-28-2013, 04:05 PM   #2
JarHarms
Scooby Specialist
 
Member#: 138994
Join Date: Jan 2007
Chapter/Region: MWSOC
Location: DeKalb-ish, IL
Vehicle:
06 WRX Ltd SGM 6MT
02 Forester S

Default

VSS harness plugged into sensor? VSS circuits check ok?
You do not need a VSSpro.
JarHarms is offline   Reply With Quote
Old 09-28-2013, 07:32 PM   #3
moby4dick
Scooby Newbie
 
Member#: 51901
Join Date: Jan 2004
Chapter/Region: Tri-State
Vehicle:
'04 WRX
WRB

Default

Agreed with above ^^^.
moby4dick is offline   Reply With Quote
Old 09-28-2013, 08:51 PM   #4
DOHBOYWRX
Scooby Newbie
 
Member#: 314698
Join Date: Mar 2012
Chapter/Region: South East
Location: Miami
Vehicle:
2005 WRX
White "Phatbotti Tuned"

Default

Awesome thanks, this weekend will be hard for me to check everything out but I will look in to it next weekend. Thanks a lot guys!

Quote:
Originally Posted by JarHarms View Post
VSS harness plugged into sensor? VSS circuits check ok? You do not need a VSSpro.
DOHBOYWRX is offline   Reply With Quote
Old 10-01-2013, 07:34 PM   #5
Tupass
Scooby Newbie
 
Member#: 219784
Join Date: Aug 2009
Chapter/Region: South East
Location: St.Pete FL
Vehicle:
2005 wrx
cgm

Default

Im getting ready to do this swap this weekend.I have a question. Does 02-07 auto DS are the same? and do I need to get a wrx or N/a,or any auto DS will work?
Tupass is offline   Reply With Quote
Old 10-01-2013, 09:16 PM   #6
DOHBOYWRX
Scooby Newbie
 
Member#: 314698
Join Date: Mar 2012
Chapter/Region: South East
Location: Miami
Vehicle:
2005 WRX
White "Phatbotti Tuned"

Default

Quote:
Originally Posted by Tupass View Post
Im getting ready to do this swap this weekend.I have a question. Does 02-07 auto DS are the same? and do I need to get a wrx or N/a,or any auto DS will work?
I used a 2002 rs auto DS and it worked fine. I am almost 100% sure that wrx and rs automatic use the exact same drive shaft
DOHBOYWRX is offline   Reply With Quote
Old 10-02-2013, 08:40 PM   #7
Tupass
Scooby Newbie
 
Member#: 219784
Join Date: Aug 2009
Chapter/Region: South East
Location: St.Pete FL
Vehicle:
2005 wrx
cgm

Default

Quote:
Originally Posted by DOHBOYWRX View Post
I used a 2002 rs auto DS and it worked fine. I am almost 100% sure that wrx and rs automatic use the exact same drive shaft
thanks for the info...next is dss axles so I can use the r180 and some fun on DRs lol Thanks again
Tupass is offline   Reply With Quote
Old 10-14-2013, 06:14 PM   #8
Tupass
Scooby Newbie
 
Member#: 219784
Join Date: Aug 2009
Chapter/Region: South East
Location: St.Pete FL
Vehicle:
2005 wrx
cgm

Default

So..I ordered an 06 n/a ds and was 2" short..ended up swaping the r180 flange into the r160 and using the Sti ds.Car feels amazing with the 6sp
Tupass is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:10 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.