Welcome to the North American Subaru Impreza Owners Club Saturday August 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-03-2013, 06:42 PM   #1
exemptrevision
Scooby Newbie
 
Member#: 328998
Join Date: Aug 2012
Chapter/Region: MWSOC
Location: Galesburg, IL
Vehicle:
2011 Impreza WRX STI
OBP

Default Lower Suspension Problems

2011 STI Sedan

So I lowered my car about 6 months ago, got the Whiteline Front Roll Center Adjustment Kit and Kartboy Endlinks, installed and got an alignment.

I decided now to switch over sway bars and when I get under there to switch it out notice the end link bushings are pushed and pinched. Obviously I didn't have any lying around but I am going to replace them. For now I'm stuck with these.

Do I need to push out my camber or something to make up for the lowering of the car or is there a solution of some kind I overlooked? I turned the endlink down to get a better view, it should actually be turned up so the pinched side is on the sway bar side.

Sorry for the quality:
* Registered users of the site do not see these ads.
exemptrevision is offline   Reply With Quote
Old 11-03-2013, 07:19 PM   #2
jaboyd
Scooby Newbie
 
Member#: 247304
Join Date: May 2010
Chapter/Region: South East
Location: Knoxville, TN
Vehicle:
2011 STI
WR Blue

Default Swaybar

I've found that the WL front bar end tabs aren't perpendicular with the normal position of the lower EL mounting point. I also had Kartboy end links and had a very similar issue, and I would occasionally get popping noises. I tightened and tightened thinking that would solve the problem, but unfortunately I couldn't resolve it even trying additional spacers to correct the mismatch. Finally I went to a KLC39 WL adjustable spherical link and it solved my problem. You can sometimes find these new on eBay.

Last edited by jaboyd; 11-03-2013 at 07:20 PM. Reason: spelling correction
jaboyd is offline   Reply With Quote
Old 11-03-2013, 07:34 PM   #3
Big-E
NASIOC Supporter
 
Member#: 123843
Join Date: Aug 2006
Chapter/Region: NESIC
Location: Connecticut
Vehicle:
2006 WRX Sedan SGM
Let LED's light your way!

Default

Those bushing are NG. If you keep the KB endlinks, replace the bushings and purchase a set of their aluminum spacers (top, between endlink and bar) to set the endlinks as parallel as possible:

Big-E is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 03:31 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.