Welcome to the North American Subaru Impreza Owners Club Wednesday April 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > General Community

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-30-2013, 07:58 AM   #326
SnowBRDGod247
Scooby Specialist
 
Member#: 319756
Join Date: May 2012
Chapter/Region: NESIC
Location: Rhode Island
Vehicle:
2002 V7 wrx wagon
silver

Default

Quote:
Originally Posted by Tony Bangma View Post
Somewhat recent pic of my 04 wrx odo and my dad's 97 legacy, wrx has had nothing replaced and still feels brand new, legacy has had some minor exhaust work, both are going strong!
Wow that is awesome
* Registered users of the site do not see these ads.
SnowBRDGod247 is offline   Reply With Quote
Old 12-02-2013, 12:54 AM   #327
coalslaw
Scooby Newbie
 
Member#: 324808
Join Date: Jul 2012
Chapter/Region: E. Canada
Location: Toronto, canada
Vehicle:
2006 IWL Stg2
OBP

Default

Quote:
Originally Posted by some dude View Post
176,000 miles now. Still on original clutch. I put it in 5th while stopped. It stalled after I let my clutch out a hair.
duhh. of coz it will! try atleast putting in 1st gear n the wheels will move and you give some gas and the wheels will move faster and your exhaust will have smoke and yu wilkl go straiiiit and never stop again in 5th
coalslaw is online now   Reply With Quote
Old 12-02-2013, 10:24 PM   #328
MF-DIF
Scooby Specialist
 
Member#: 62197
Join Date: May 2004
Chapter/Region: MWSOC
Location: 'Murica
Vehicle:
GTO /WRX

Default

176k on an 02 WRX. Just did a 1200mi road trip in it...no issues and got an all time high of 30mpg cruising at 75mph.
MF-DIF is offline   Reply With Quote
Old 12-02-2013, 10:26 PM   #329
SVO1
Scooby Newbie
 
Member#: 273287
Join Date: Feb 2011
Chapter/Region: MWSOC
Location: Marion, Iowa
Vehicle:
05 baja/95L/04wrx
RBP/red/WRB

Default

My wife's 04 wrx has 272k miles, still on the factory unrebuilt ej205, and td04.
SVO1 is offline   Reply With Quote
Old 12-02-2013, 11:02 PM   #330
Parkondakirb
Scooby Newbie
 
Member#: 374492
Join Date: Nov 2013
Location: Clinton, Illinois
Vehicle:
2003 Wrx wagon
Black/deep blue

Default

2003 WRX Wagon

220k miles

Original clutch

Crawford gymkhana catback with high flow downpipe
Parkondakirb is offline   Reply With Quote
Old 12-02-2013, 11:07 PM   #331
WorldRallyDrew
Scooby Newbie
 
Member#: 275970
Join Date: Mar 2011
Chapter/Region: MWSOC
Location: Indy
Vehicle:
04 Wheelgap Mobile
WRB

Default

Rolled over 140k this morning in my 04 WRX. I religiously maintain the thing, and it still runs like an absolute top. It's been garage-kept its entire life, and has never given me a single problem aside from the PS pump and radiator going out last year.

I will definitely be replacing it with another Subaru in the future.
WorldRallyDrew is offline   Reply With Quote
Old 12-03-2013, 09:16 AM   #332
some dude
Scooby Specialist
 
Member#: 100300
Join Date: Nov 2005
Chapter/Region: MWSOC
Location: MIC|-|IG/\N
Vehicle:
06 WRX
CGM

Default

I can't enlarge the pics, my iPhone says ' connection error '. How many miles on those two?

Quote:
Originally Posted by Tony Bangma View Post
Somewhat recent pic of my 04 wrx odo and my dad's 97 legacy, wrx has had nothing replaced and still feels brand new, legacy has had some minor exhaust work, both are going strong!
some dude is offline   Reply With Quote
Old 12-03-2013, 10:11 AM   #333
shamrock 05
Scooby Specialist
 
Member#: 120057
Join Date: Jul 2006
Chapter/Region: MWSOC
Location: *outskirts of motor city*
Vehicle:
2004 "Bugeye" WRX
WRB

Default

I have 146K on my 04 WRX


The rest of you with higher milaged cars, do you like the strange noises your getting? Espically in the cold start ups
shamrock 05 is offline   Reply With Quote
Old 12-03-2013, 11:03 AM   #334
Gam30vR
Scooby Newbie
 
Member#: 289486
Join Date: Jul 2011
Chapter/Region: NWIC
Location: Yakima
Vehicle:
03 WRX
WRB

Default

Quote:
Originally Posted by some dude View Post
I can't enlarge the pics, my iPhone says ' connection error '. How many miles on those two?
It was like 170 on Wrx and 270 on legacy.
Gam30vR is offline   Reply With Quote
Old 12-03-2013, 06:20 PM   #335
Daniel Dudley
Scooby Newbie
 
Member#: 307610
Join Date: Jan 2012
Location: Far Out
Vehicle:
2004 WRX Wagon

Default

Quote:
Originally Posted by shamrock 05 View Post
I have 146K on my 04 WRX


The rest of you with higher milaged cars, do you like the strange noises your getting? Espically in the cold start ups

I sold my 02 at 178,000, but it started up, ran and sounded like a low miles car. There was a slight whine in the transmission on the highway at 80, that was it.
Daniel Dudley is offline   Reply With Quote
Old 12-03-2013, 09:34 PM   #336
Tony Bangma
Scooby Newbie
 
Member#: 341689
Join Date: Dec 2012
Chapter/Region: NESIC
Location: Ticonderoga NY
Vehicle:
2004 wrx wagon
Wrb

Default

Quote:
Originally Posted by some dude View Post
I can't enlarge the pics, my iPhone says ' connection error '. How many miles on those two?


Quote:
Originally Posted by Gam30vR View Post
It was like 170 on Wrx and 270 on legacy.

It was actually 220k on the 04 wrx and almost 330k (327) on the 97 legacy

both are higher now, because it was an older picture.
Tony Bangma is offline   Reply With Quote
Old 12-04-2013, 06:18 AM   #337
shamrock 05
Scooby Specialist
 
Member#: 120057
Join Date: Jul 2006
Chapter/Region: MWSOC
Location: *outskirts of motor city*
Vehicle:
2004 "Bugeye" WRX
WRB

Default

I guess its with alot of old cars but when its cold and I start my car it basically looks at me like .................


She runs good tho.
shamrock 05 is offline   Reply With Quote
Old 12-06-2013, 12:07 PM   #338
some dude
Scooby Specialist
 
Member#: 100300
Join Date: Nov 2005
Chapter/Region: MWSOC
Location: MIC|-|IG/\N
Vehicle:
06 WRX
CGM

Default

Here is a cold start video. It wasn't too cold out. Around 45 degrees but car had been sitting. I figure my engine sounds pretty normal and decided to post on YT.


some dude is offline   Reply With Quote
Old 12-06-2013, 03:30 PM   #339
shamrock 05
Scooby Specialist
 
Member#: 120057
Join Date: Jul 2006
Chapter/Region: MWSOC
Location: *outskirts of motor city*
Vehicle:
2004 "Bugeye" WRX
WRB

Default

Quote:
Originally Posted by SVO1 View Post
My wife's 04 wrx has 272k miles, still on the factory unrebuilt ej205, and td04.
wow thats awesome.....musta been a weekday car You can call subaru and give them your vin and they can give you the exact build date. Mine was like 1/21/03, monday car .......
shamrock 05 is offline   Reply With Quote
Old 12-06-2013, 03:38 PM   #340
Mike05wrx
Scooby Newbie
 
Member#: 314747
Join Date: Mar 2012
Location: Long Island, NY
Vehicle:
2005 WRX

Default

i have just under 140k on the clock on my 05 wrx. original block, but only about 65k on the vf39. still running strong!
Mike05wrx is offline   Reply With Quote
Old 12-07-2013, 04:47 AM   #341
JeffrWRX
Scooby Specialist
 
Member#: 48589
Join Date: Nov 2003
Chapter/Region: SCIC
Location: Murrieta, CA + SAN DIEGO
Vehicle:
2002 PSM WAGON Stg2
FORTUNE/RPF1-17x9/2354017

Default

176000 on my 02 wagon. Just bought it with 175000 for 6k. Runs great!

Small idle dip when coming to stop. Maf was super dirty also cleaning icav to hopefully fix the issue.
JeffrWRX is online now   Reply With Quote
Old 12-07-2013, 12:15 PM   #342
Hawkeye006Wagon
Scooby Newbie
 
Member#: 361655
Join Date: Jul 2013
Chapter/Region: NESIC
Location: New York State
Vehicle:
2006 WRX
WRB

Default

2006 WRB WRX sportwagon

190,000 miles

With the Original clutch.
Hawkeye006Wagon is offline   Reply With Quote
Old 01-21-2014, 01:12 PM   #343
Hybridizer
Scooby Newbie
 
Member#: 73365
Join Date: Oct 2004
Chapter/Region: MWSOC
Location: Grand Haven, MI
Vehicle:
2005 Saab 92x Aero

Default

161,000 miles on my 2005 Saabaru 4EAT. Still original motor, trans, and turbo.
Hybridizer is offline   Reply With Quote
Old 01-21-2014, 06:45 PM   #344
PorkChopExpress
Scooby Newbie
 
Member#: 311392
Join Date: Feb 2012
Default

45k on my 2012, im on my way!
PorkChopExpress is offline   Reply With Quote
Old 03-31-2014, 11:26 AM   #345
SIMPFLY
Scooby Newbie
 
Member#: 54794
Join Date: Feb 2004
Vehicle:
2004 WRX ding dong
5 to 198xxx.... miles!!!!

Default

200,000 on my wrx; i got it brand new with 5 miles in 2004

SIMPFLY is offline   Reply With Quote
Old 03-31-2014, 12:02 PM   #346
SnowBRDGod247
Scooby Specialist
 
Member#: 319756
Join Date: May 2012
Chapter/Region: NESIC
Location: Rhode Island
Vehicle:
2002 V7 wrx wagon
silver

Default

Quote:
Originally Posted by SIMPFLY View Post
200,000 on my wrx; i got it brand new with 5 miles in 2004
Nice!
SnowBRDGod247 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:11 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.