Welcome to the North American Subaru Impreza Owners Club Friday August 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Built Motor Discussion

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-20-2013, 11:11 PM   #1
1MOFOSTI
Scooby Newbie
 
Member#: 375748
Join Date: Dec 2013
Location: 27PSI
Default Walbro 255L, Fuel Pressure SOLVED!

EJ207 JDM/AUS, 04 STi / FPRed @21 PSI / 90% IDC / DW1000cc / 55ft / 83mm MAF /3in inltet / walbro 255 / rails etc...


Ive been trying to figure out what is happening with the fuel press. There is no leaks anywhere i have triple checked.

What happens is, start the car ,255l walbro primes / cold start = 3.2bar (46PSI) / Warm idle = 2.7bar (39PSI) / WOT = 3.8bar (55PSI) i know these are all lower than normal but am stumped why?

Fuel Pressure SOLVED! see post #9

-1MOFO

Last edited by 1MOFOSTI; 12-28-2013 at 11:08 PM.
1MOFOSTI is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:34 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.