Welcome to the North American Subaru Impreza Owners Club Tuesday September 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-18-2013, 08:35 PM   #1
trbill2003
Scooby Newbie
 
Member#: 322643
Join Date: Jun 2012
Chapter/Region: W. Canada
Vehicle:
2012 Imprezza Tourin
Deep Cherry Pearl

Default CEL and VDC

CEL on and VDC on after block heater install. 2012 Imprezza. Subaru dealer did the work. Car runs good, coolant level is normal. Dealer says bring it in and they will switch the light off. Does this sound right? Other people have reported the same except with the cruise light on. I do not have the cruise light on, just the other two.

Ideas?
* Registered users of the site do not see these ads.
trbill2003 is offline   Reply With Quote
Old 12-19-2013, 01:57 PM   #2
trbill2003
Scooby Newbie
 
Member#: 322643
Join Date: Jun 2012
Chapter/Region: W. Canada
Vehicle:
2012 Imprezza Tourin
Deep Cherry Pearl

Default CEL and VDC light on

Just came back from the dealership. Apparently some antifreeze dripped on to the O2 sensor causing the CEL to activate. This in turn causes the VDC light to activate as well. Mechanic cleaned the sensor, cleared the code and all appears to be well.
trbill2003 is offline   Reply With Quote
Old 12-19-2013, 02:21 PM   #3
RaceFaceXC
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: stupid Florida
Vehicle:
2007 No YELLING
on the bus!

Default

Cleaned an O2 sensor? Either they did something stupid like forgot to plug something back in or your O2 sensor is not long for this world.
RaceFaceXC is offline   Reply With Quote
Old 12-19-2013, 06:36 PM   #4
trbill2003
Scooby Newbie
 
Member#: 322643
Join Date: Jun 2012
Chapter/Region: W. Canada
Vehicle:
2012 Imprezza Tourin
Deep Cherry Pearl

Default CEL and VDC

Service manager did say that if it, (the lights coming on again) happened again they would replace the sensor. So, you are probably right that it is not long for this world.
trbill2003 is offline   Reply With Quote
Old 12-21-2013, 06:47 PM   #5
trbill2003
Scooby Newbie
 
Member#: 322643
Join Date: Jun 2012
Chapter/Region: W. Canada
Vehicle:
2012 Imprezza Tourin
Deep Cherry Pearl

Default

After driving about 30kms the CEL and VDC lights are back on. So, back to the dealership. Does my car retain it's VDC capability even if the light is on?
trbill2003 is offline   Reply With Quote
Old 12-23-2013, 06:01 PM   #6
Tha Chakal
Scooby Specialist
 
Member#: 372100
Join Date: Oct 2013
Location: D.C.
Vehicle:
2013 Premium 5dr CVT
DGM

Default

Quote:
Originally Posted by trbill2003 View Post
After driving about 30kms the CEL and VDC lights are back on. So, back to the dealership. Does my car retain it's VDC capability even if the light is on?
No, if the VDC light is on with CEL, the car is in limp mode and it is disabled. The cruise symbol should blink too, because it's also disabled.
Tha Chakal is online now   Reply With Quote
Old 12-24-2013, 09:44 AM   #7
RaceFaceXC
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: stupid Florida
Vehicle:
2007 No YELLING
on the bus!

Default

Quote:
Originally Posted by trbill2003 View Post
After driving about 30kms the CEL and VDC lights are back on. So, back to the dealership. Does my car retain it's VDC capability even if the light is on?
I would express my disgust for their shoddy diagnostics and poor maintenance practices. Cleaning an O2 sensor is almost the dumbest thing I have ever heard. They are so sensitive that the stuff they are designed to be used in, exhaust, kills them. Who the f would think you could spill oil on one and just clean it up? Not to mention the time you waste during your holiday and the gas to take back and forth from this dick heads
RaceFaceXC is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:34 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.