Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Archives > NASIOC Archives > General Forum Archive

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 06-16-2000, 09:51 PM   #1
RallyeX
Guest
 
Member#:
Thumbs down Engne is using oil Again!


Well, it's using alot of oil again!

Back in February-March I noticed that my car was using a little bit of oil.Every 200-300 miles I would have to add about 1 qt of oil. By the end of March it was using about 2 to 2.75 qts every 200-300 miles.
So in late March I took my car to Thousand Oaks Subaru in SoCal to have them look at it. They had the car for a couple of days and when I picked it up they said that there was nothing wrong with it.
It's now April and I'm at the Rim of the World Rally. When I got there I was talking to Shiv and Scott from SPO Motorsports about my oil problem. Then Scott introduced me to Mark Budack (district service operations manager). I told him about my problem and he said he wanted to have me take my car to the best techs here in California. He had me take my car to Culver City Subaru (what a JOKE).So when I get my car there I tell them about the oil problem and the clutch chatter.So they said they would do an oil consumption test and the tech would drive my car to and from work for a couple of days.The tech ,Darrrel, called and instantly started off by telling me he was on my side, which instantly put me on my guard. A few days later they called and told me the left cyclinder head was bad. They (BRIAN BRANNAN) told me that Subaru had some heads that were too porous(OK!).So they have the car for 3.5 weeks.They replaced the left head and the car is ok now according to them.
The clutch,at first they told me the fly wheel and pressure plate needed to be changed but I would have to pay for the clutch plate and bearing. So I called SOA to see why they wouldn't cover the clutch plate if the fly wheel and pressure plate are bad. I thought they could cause premature wear on the clutch plate if they are defective.
So after I called SOA the dealers attitude changed. Now they told me that the clutch plate and bearing is what is causing my chatter.( they never took the trans out to look at the clutch and fly wheel). They said I had to pay for the clutch plate and bearing in full before they would work on it.So I said that I wanted to see the clutch plate before I would pay for a new one. Then they told me that the labor,fly wheel,an pressure plate was going to be covered under warranty as a goodwill gesture.(why fix if not broke)SOA.
So I picked up my car on June 1. No clutch work.
I've put about 850 miles on my car and have had to add 4.25 qrts of oil so far.Great job of repairng my oil problem(culver city subaru).
On my invoice it shows that when I dropped my car off it had 26,479 miles on it and when I picked it up they show 26,483 miles. Now thats a good oil consumption test. 4 miles?


So I have called SOA and Mark Budack,and Phil Pausmer about the oil leak that did not get fixed. So far nobody has called me back.
Monday I am going to try another dealer(Van Nuys Subaru).I hope they get it worked out.

Thanks for your ear,
RallyeX

PS: any feed back would be appreciated.

Outcome: Stay away from Culver City Subaru and Subaru of thousand Oaks.

had less problems when I had my YUGO!!!
Hahahahahaahaa!!!!!!
 
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Friend is using cocaine... again... :( anickode Off-Topic 48 10-11-2008 11:50 AM
95,000mi check in. The white 2.5Oontz mobile is holding oil again!! AcquaCow Mid Atlantic Impreza Club -- MAIC 20 11-04-2006 04:41 PM
Wagon is using oil...stock turbo b0rked? Jard Mid Atlantic Impreza Club -- MAIC 22 06-05-2006 03:40 PM
6,000 miles and my STi is using oil, THIS IS BS!!!!! SilverSTi STi Forum Archive 72 07-16-2003 06:25 PM


All times are GMT -4. The time now is 12:02 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.