Welcome to the North American Subaru Impreza Owners Club Friday August 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-10-2014, 09:30 PM   #1
trucker944
Scooby Newbie
 
Member#: 368196
Join Date: Sep 2013
Chapter/Region: NWIC
Location: Vancouver, WA
Vehicle:
2004 wrx sti
Silver

Default water pump leaking?

I realize this is a complete noob question, but I couldn't find a thread that related to my circumstances. Driving home from work today, started having steam coming out from under the hood. Smelled the antifreeze. Engine not overheating. Can't find any leaks from hoses etc. Refilled the reservoir and restarted the engine. Fluid leaking from just below and behind alternator. Water pump is bad. Right?
* Registered users of the site do not see these ads.
trucker944 is offline   Reply With Quote
Old 03-10-2014, 10:02 PM   #2
FrozenIce
Scooby Newbie
 
Member#: 349378
Join Date: Mar 2013
Chapter/Region: W. Canada
Location: SK, Canada
Vehicle:
1993 Impreza WRX Sti
Black

Default

Water pump and thermostat are just in front of the alternator.
I have a similar coolant leak, with smoke from under the hood when stopped. My engine had a slow drip from the back of the left head gasket. Just under the heater hose connections.
FrozenIce is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:36 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.