Welcome to the North American Subaru Impreza Owners Club Tuesday September 1, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-03-2013, 02:31 AM   #26
srREXed
Scooby Specialist
 
Member#: 72234
Join Date: Oct 2004
Chapter/Region: South East
Location: S. FL... Now Fort Polk, LA
Vehicle:
2004 WRX SRR
EJ257-35R-6MT

Default

The ej257 in the 05 sti motor in the car.
* Registered users of the site do not see these ads.
srREXed is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-17-2014, 02:32 PM   #27
ssotelo11
Scooby Newbie
 
Member#: 373870
Join Date: Nov 2013
Default

Help me my fellow friends I am doing version 7 swap here it is 02 Wrx usdm harness,jdm engine jdm ecu both version 7. what is the diagram for the repinning havin a hard time getting the car to fire.will the diagram up top work for my swap or is it for Australian cars? I tired the diagram no go??? Help a brother out
ssotelo11 is offline   Reply With Quote
Old 01-19-2014, 01:46 PM   #28
ssotelo11
Scooby Newbie
 
Member#: 373870
Join Date: Nov 2013
Default

help me out bros icant get the wiring hook up and car wont fire any ideas?
ssotelo11 is offline   Reply With Quote
Old 01-19-2014, 08:54 PM   #29
Zephyr
Scooby Specialist
 
Member#: 3362
Join Date: Dec 2000
Location: Central NJ
Vehicle:
2001 I've wired a
Few cars in my day

Default

All the info in this thread pertaining to the AVCS is correct. That is all that you need to change on a 02-05 USDM WRX to make a JDM STi engine work.

On some JDM engines there is an intake temp sensor that is under the intercooler that needs to be unplugged to make the car run. Check for that and if it is there unplug it and everything should work.

Without changing or adding anything tied to the AVCS the car should be able to start and run with either the USDM ECU or the JDM ECU.

PM me if you have any further questions.
Zephyr is offline   Reply With Quote
Old 03-24-2014, 06:46 PM   #30
02redwolf
Scooby Newbie
 
Member#: 382010
Join Date: Feb 2014
Default

Quote:
Originally Posted by ssotelo11 View Post
help me out bros icant get the wiring hook up and car wont fire any ideas?
So did you get it fixed? Was it the little plug under the TB?
02redwolf is offline   Reply With Quote
Old 08-18-2014, 10:06 PM   #31
ronf1964
Scooby Newbie
 
Member#: 398704
Join Date: Aug 2014
Default E1 Connector

Does anyone have the wire color pin out on the E1 Connector (Engine side). It was cut off on the EJ207 that I purchased. I have the old connector and pins but I need to know where the wires were supposed to go to.
ronf1964 is offline   Reply With Quote
Old 08-19-2014, 11:53 AM   #32
Zephyr
Scooby Specialist
 
Member#: 3362
Join Date: Dec 2000
Location: Central NJ
Vehicle:
2001 I've wired a
Few cars in my day

Default

Pin 1, Crank Position Sensor, W, Connects to OrL
Pin 2, Crank Position Sensor, B, Connects to WL
Pin 3, Cam Position Sensor, R, Connects to Or
Pin 4, Cam Position Sensor, G, Connects to W
Pin 6, Knock Sensor, Y, Connects to RL
Pin 7, ACTIVE VALVE CONTROL ANGLE SENSOR LH, B, Connects to WL
Pin 8, ACTIVE VALVE CONTROL ANGLE SENSOR RH, W, Connects to Or
Pin 9, ACTIVE VALVE CONTROL ANGLE SENSOR RH, G, Connects to W
Pin 10, ACTIVE VALVE CONTROL ANGLE SENSOR LH, R, Connects to OrL
Zephyr is offline   Reply With Quote
Old 08-24-2014, 09:07 AM   #33
Trboboost91
Scooby Newbie
 
Member#: 282961
Join Date: May 2011
Chapter/Region: MWSOC
Location: Des moines
Vehicle:
05 Saabaru

Default

Alright wiring masters, let's see if you can tackle this one.
I'm trying to get my jdm ej205 w/Avcs working in The saabaru.
My engine harness was also hacked off at the big connectors and I did not get the
Plugs. so I have the connectors for both cam sensors and both solenoids but basically need to know what terminals on the cam sensors/solenoids go to what terminal holes on the 3 big connectors. I have been using random wires so colors won't help me much.
I'm sure the IA performance Avcs engine harness would be a quick solution but I want to see if I can get it done myself. Just can't seem to figure this part out.
Trboboost91 is offline   Reply With Quote
Old 12-13-2014, 10:33 AM   #34
subarufan555
Scooby Specialist
 
Member#: 255117
Join Date: Aug 2010
Chapter/Region: MWSOC
Location: Chicago ,Illinois
Vehicle:
2000 RS
RED

Default

I just swapped JDm V8 engine and transmission in to my 05 Saab Aero Wagon.
I made the AvCS Wireing myself ( I have a IAP Performance instructions that they send with their kits)
I did switch pins on drivers side plug (black plug behind battery)
I switch pins in ECU plug According to DS 1 instructions.
I unplug Air temp sensor on intake

But according to IAP instructions there is 5 wires on Ecu side of their kit and 4 on passenger side plug engine bay.
They claim to plug the 5 wire in number 14 on Ecu plug.
They describe it as Shielded wire ground ( bare wire)
In the FAQ question they explain :
The shielded wiring bundle is a 4 wire cluster with 1 ground wire at Ecu end. The ground wire is intentionally bare wire with a piece of blue shrink tubing to signify it . Simply instal it do not fret that it is bare.


I didn't do this #14 pin
So as I understand from reading this I just take a bare wire attach a Ecu pin to it and stick it to #14 on
Ecu and leave it hanging there bare???!!!
Haw long it shudl be?

The reason I'm mentioning all of this is because my car runs Not right when AVCS is hooked up.... Like there is something missing.it runs low Rpm when idling like is missing fuel. When driven it feels like it is starving for fuel.
When I dysconect AVCs wires it runs great but no AVCS.

What can I do here?
subarufan555 is offline   Reply With Quote
Old 12-13-2014, 09:51 PM   #35
subarufan555
Scooby Specialist
 
Member#: 255117
Join Date: Aug 2010
Chapter/Region: MWSOC
Location: Chicago ,Illinois
Vehicle:
2000 RS
RED

Default

Bump...
subarufan555 is offline   Reply With Quote
Old 02-21-2015, 10:52 AM   #36
SubiSam
Scooby Newbie
 
Member#: 156401
Join Date: Aug 2007
Chapter/Region: South East
Location: Greensboro NC
Vehicle:
'03 WRB WAGON
2.1 stroker GTX3071R

Default

The shielding will not work if it is not grounded. This wire needs to be connected to the shielding of those wires. Otherwise, you will have EMF noise from AC current emitted from the AVCS solenoids. Unless the shield is grounded, you have unsheilded wire.
SubiSam is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS : PA: 2002 WRX Return to Stock!!! (exhaust, ecu, turbos, exterior, etc.) Bugeye_Bull Engine/Power/Exhaust 8 11-14-2011 12:29 PM
FS/FT : TN :*Going back to stock* 02 wrx harness to 04 Sti complete swap Bug_i_Sti Engine/Power/Exhaust 0 03-01-2011 07:09 PM
A/C wiring help, WRX harness with Legacy A/C compressor wiring help mutiger93gt Legacy Forum 3 03-01-2010 05:34 PM
So... 2002 WRX, Timing advance value in ECU = "1" Chi_San Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 08-12-2009 04:36 PM
2002 wrx harness urabus1 Private 'Wanted' Classifieds 9 12-22-2003 09:19 PM


All times are GMT -4. The time now is 11:55 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.