Welcome to the North American Subaru Impreza Owners Club Friday October 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-07-2014, 03:45 PM   #101
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Duct tape over em... thats what I did. can't see it and its easy enoigh to remove.


Had a Forester loaner recently. Rattle-free, solid and man am I jealous of those seats.
* Registered users of the site do not see these ads.
79letour is offline   Reply With Quote
Old 04-07-2014, 06:44 PM   #102
John451
Scooby Newbie
 
Member#: 321966
Join Date: Jun 2012
Location: Sydneys South, Australia
Vehicle:
2012 Impreza 2.0i H
Black Pearl

Default

Quote:
Originally Posted by 79letour View Post
Duct tape over em... thats what I did. can't see it and its easy enough to remove.

Had a Forester loaner recently. Rattle-free, solid and man am I jealous of those seats.
Black duct tape is an excellent idea to cover the hole, was going to to trim a bit of rubber matting but duct tape is easier.
John451 is offline   Reply With Quote
Old 04-07-2014, 09:45 PM   #103
lumpy
Scooby Specialist
 
Member#: 28410
Join Date: Oct 2002
Chapter/Region: MWSOC
Location: Cleveland, OH
Vehicle:
2012 Impreza Sport
SWP

Default

Ha, now I know the first place that I am going to look! Hopefully my fix will be as easy as yours was John. Thanks for posting your results.
lumpy is offline   Reply With Quote
Old 04-15-2014, 05:53 PM   #104
PropWashThePegasus
Scooby Newbie
 
Member#: 384949
Join Date: Mar 2014
Chapter/Region: Tri-State
Location: Long Island NY
Vehicle:
2014 Impreza
White

Default

Quote:
Originally Posted by r0dzilla7 View Post
Agreed. I didn't get a chance to talk to the guy that fixed it as I was given info from one of the service guys. He told me he had to do adjust my rally armor mud flap on that side.
Of course he's gonna tell you that. Anything excuse they have to not do warranty work is what they'll look for. I have a rattle too but I'm pretty sure it's just the loose change in my glove box. You want a bad rattle go drive a Cobalt, rattles like a helicopter lol.
PropWashThePegasus is offline   Reply With Quote
Old 04-22-2014, 01:36 PM   #105
RubyTheSubi
Scooby Newbie
 
Member#: 377058
Join Date: Dec 2013
Location: Cincinnati, OH
Vehicle:
2010 Impreza 2.5i

Default

My 2010 rattles from both front pillars as well as somewhere on the rear deck. I've tried stuffing padding in some crevices and it went away for a couple of days, but it's coming back. So annoying. a 4 year old car shouldn't have that issue.
RubyTheSubi is offline   Reply With Quote
Old 04-27-2014, 02:33 PM   #106
bradze
Scooby Specialist
 
Member#: 103208
Join Date: Dec 2005
Chapter/Region: NWIC
Location: Yelm, Wa
Vehicle:
2011 Outback
Azurite Blue

Default

hopefully that bolt in the corner is the problem, hafta get another socket to fix it though...
bradze is offline   Reply With Quote
Old 04-30-2014, 10:27 PM   #107
thagan
Scooby Newbie
 
Member#: 389560
Join Date: Apr 2014
Default

2014 with 2500 miles has a bunch of rattles. was to the dealer the day after i bought it for a rattle and has been to a dealer a second time. Rattles still there
thagan is offline   Reply With Quote
Old 05-03-2014, 10:01 PM   #108
Not Speeding
Scooby Newbie
 
Member#: 364684
Join Date: Aug 2013
Vehicle:
2007 STI Limited
Gray

Default

I also have squeaking and whistling from the back. I think it's coming from the trunk lid
Not Speeding is offline   Reply With Quote
Old 05-04-2014, 10:07 AM   #109
CalTech87
Scooby Specialist
 
Member#: 348055
Join Date: Feb 2013
Location: San Diego
Vehicle:
2013 Impreza 5MT
ISM

Default

Here's a new one. My passenger side front quarter window isn't sealing properly and getting lots of wind noise inside the cabin at higher speeds.

Should be able to wedge it with something, but no idea whatsoever what could have caused it.
CalTech87 is online now   Reply With Quote
Old 05-04-2014, 01:48 PM   #110
jr0bb5
Scooby Specialist
 
Member#: 315353
Join Date: Apr 2012
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sp Prem
5MT OBP/DGM

Default

Quote:
Originally Posted by CalTech87 View Post
Here's a new one. My passenger side front quarter window isn't sealing properly and getting lots of wind noise inside the cabin at higher speeds.

Should be able to wedge it with something, but no idea whatsoever what could have caused it.
Both of my front quarter windows leak water in my cabin when ever I go through the touchless automatic car wash.
jr0bb5 is online now   Reply With Quote
Old 05-04-2014, 03:45 PM   #111
CalTech87
Scooby Specialist
 
Member#: 348055
Join Date: Feb 2013
Location: San Diego
Vehicle:
2013 Impreza 5MT
ISM

Default

Don't know if it's reassuring knowing I'm not the onyly one. Maybe the dealer can give me a fix. Probably better off doing it myself? -_-
CalTech87 is online now   Reply With Quote
Old 05-06-2014, 12:02 AM   #112
SubaruSky
Scooby Newbie
 
Member#: 387688
Join Date: Apr 2014
Chapter/Region: NWIC
Location: Idaho
Vehicle:
2003 Impreza WRX
Silver

Default

Quote:
Originally Posted by CalTech87 View Post
Don't know if it's reassuring knowing I'm not the onyly one. Maybe the dealer can give me a fix. Probably better off doing it myself? -_-
Depends on where its rattling from. Im running a catless exhaust which increases the vibration. Thats where I get alot of my rattles. I have no clue about the leaking though, mine doesnt leak. Maybe door seals near the pillars?

Last edited by SubaruSky; 05-06-2014 at 12:07 AM.
SubaruSky is offline   Reply With Quote
Old 05-06-2014, 12:28 AM   #113
CalTech87
Scooby Specialist
 
Member#: 348055
Join Date: Feb 2013
Location: San Diego
Vehicle:
2013 Impreza 5MT
ISM

Default

Nah, my wife was in the passenger seat and pushed on the seal along the quarter window/door card area which helped and is obvious the problem is coming from there.

Just the fact that it IS a problem on a 1 year old car...
CalTech87 is online now   Reply With Quote
Old 05-06-2014, 12:54 PM   #114
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

I agree with you, caltech87.
79letour is offline   Reply With Quote
Old 05-11-2014, 10:12 AM   #115
TnDeadhead
Scooby Newbie
 
Member#: 379840
Join Date: Jan 2014
Chapter/Region: South East
Location: Chattanooga
Vehicle:
2012 Impreza Spt Ltd
CRP

Default

My rattle was definitely the Rally Armor flaps. What the heck is a vacuum cap? I can make it go away by tightening them up.

Googling now.
TnDeadhead is offline   Reply With Quote
Old 05-12-2014, 03:10 PM   #116
webster354
Scooby Newbie
 
Member#: 343343
Join Date: Jan 2013
Chapter/Region: VIC
Vehicle:
2014 Impreza 5dr Ltd
SWP

Default

Quote:
Originally Posted by TnDeadhead View Post
My rattle was definitely the Rally Armor flaps. What the heck is a vacuum cap? I can make it go away by tightening them up.

Googling now.
Did you not get any included with your mounting hardware? I got these included when I bought them in 2013 and 2014.

http://forums.nasioc.com/forums/show...8#post41752218

webster354 is offline   Reply With Quote
Old 05-14-2014, 12:09 PM   #117
SubaruSky
Scooby Newbie
 
Member#: 387688
Join Date: Apr 2014
Chapter/Region: NWIC
Location: Idaho
Vehicle:
2003 Impreza WRX
Silver

Default

Quote:
Originally Posted by CalTech87 View Post
Nah, my wife was in the passenger seat and pushed on the seal along the quarter window/door card area which helped and is obvious the problem is coming from there.

Just the fact that it IS a problem on a 1 year old car...
Now that is very weird, I have a bugeye and they dont even have the framed doors. Im assuming yours has the framed doors. Maybe somebody messed with the seal on your door?
SubaruSky is offline   Reply With Quote
Old 05-14-2014, 03:05 PM   #118
CalTech87
Scooby Specialist
 
Member#: 348055
Join Date: Feb 2013
Location: San Diego
Vehicle:
2013 Impreza 5MT
ISM

Default

Quote:
Originally Posted by SubaruSky View Post
Now that is very weird, I have a bugeye and they dont even have the framed doors. Im assuming yours has the framed doors. Maybe somebody messed with the seal on your door?
Ive taken my door card off about 100 times but havent recently and it only suddenly developed.

Dont know when someone would mess with the seal though since the only time anyone else is around my car I am also. Not even sure why someone WOULD mess it especially since its the quarter window, not exacly like you can break in that way short of smashing the glass.

Either way, after intially pushing on it the noise has gone down. Once I actually put a few minutes into it Im sure itll back to standard.
CalTech87 is online now   Reply With Quote
Old 05-14-2014, 04:26 PM   #119
jayman4312
Scooby Specialist
 
Member#: 228784
Join Date: Nov 2009
Chapter/Region: MWSOC
Location: Chicago, IL
Vehicle:
2004 wrx
black, stage 2+

Default

Not sure if this was covered, but with the passenger window open i get a "slapping" noise? sounds like air slapping the seatbelt around almost......like a fast flapping. only on that side.

anyone else? 2014 sport premium.
jayman4312 is offline   Reply With Quote
Old 10-19-2014, 05:56 PM   #120
AlexBmur
Scooby Newbie
 
Member#: 346912
Join Date: Feb 2013
Default

Quote:
Originally Posted by Oddbaru View Post
Solved my only long-term persistent rattle that I thought was coming from the passenger side a-pillar. It ended up being where the dashboard bolts to the body of the car under the speaker grille. I could duplicate the noise by hitting the bottom of the steering wheel (or the dashboard) with my fist every time, but if I placed a bit of pressure on the dashboard near the bolt it would stop the rattle. There's a few holes in the dashboard under the speaker grille where you can see the body paint. I shoved a lot of foam insulation between the dashboard around the bolt to create a barrier and pressure between the body and dashboard. With the grille on, you can't see anything. A washer might also do the trick, but the bolt is in an awkward place.

Been rattle-free to two weeks now. Yesterday was the ultimate test on a long gravel road riddled with potholes. No sound to be heard.

Prior to this attempt, I had taken off the a-pillar and placed foam and felt around every notable point of contact to no avail. I even lined the speaker grille. Nothing worked until now.
I have the exact same rattle/ticking noise that goes away when I apply pressure on top of the dash to the right of the speaker grill. I've taken the speaker grill off and removed the speaker and I see what you mean by the area around the bolt where the body paint is visible. But I can't I figure out how to stuff anything in between the dash and the metal around the bolt. The area is really small and tight so any advice or suggestions on how you did it would be great.

Thanks
AlexBmur is offline   Reply With Quote
Old 10-19-2014, 07:37 PM   #121
CalTech87
Scooby Specialist
 
Member#: 348055
Join Date: Feb 2013
Location: San Diego
Vehicle:
2013 Impreza 5MT
ISM

Default

Quote:
Originally Posted by AlexBmur View Post
I have the exact same rattle/ticking noise that goes away when I apply pressure on top of the dash to the right of the speaker grill. I've taken the speaker grill off and removed the speaker and I see what you mean by the area around the bolt where the body paint is visible. But I can't I figure out how to stuff anything in between the dash and the metal around the bolt. The area is really small and tight so any advice or suggestions on how you did it would be great.

Thanks
I dont know specifically where this is but if theres a really small area you can always use some a smal amount of butyl rope. It should remain solid while conforming to any shape, like Play Doh but... not.
CalTech87 is online now   Reply With Quote
Old 10-19-2014, 10:57 PM   #122
Xafen
Scooby Newbie
 
Member#: 306398
Join Date: Jan 2012
Location: Omaha, NE
Vehicle:
2012 Impreza Premium
Camellia Red

Default

And don't eat it, unlike play doh =0
Xafen is offline   Reply With Quote
Old 10-22-2014, 01:32 PM   #123
Oddbaru
Scooby Newbie
 
Member#: 315869
Join Date: Apr 2012
Chapter/Region: NWIC
Location: Oregon
Vehicle:
2012 Impreza Sp Ltd
Dark Grey Metallic

Default

Quote:
Originally Posted by AlexBmur View Post
I have the exact same rattle/ticking noise that goes away when I apply pressure on top of the dash to the right of the speaker grill. I've taken the speaker grill off and removed the speaker and I see what you mean by the area around the bolt where the body paint is visible. But I can't I figure out how to stuff anything in between the dash and the metal around the bolt. The area is really small and tight so any advice or suggestions on how you did it would be great.

Thanks
Nine months later and it's still gone.

My method was rather crude, but I just took a flathead screwdriver and shoved pieces of 1/4" weather stripping foam in there until I couldn't duplicate the noise. Perhaps it was just a representation of my frustration with the rattle, but it worked! You may want to put some tape over the screwdriver so you don't scratch the paint behind there. It's not visible anyways though.
Oddbaru is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:50 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.