Welcome to the North American Subaru Impreza Owners Club Saturday July 4, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-12-2013, 09:14 AM   #1
EDKEdwin
Scooby Newbie
 
Member#: 361912
Join Date: Jul 2013
Chapter/Region: E. Canada
Location: Toronto
Vehicle:
2013 Imp GP Touring
Satin White Pearl

Default Rallyarmor Noise (Help)

My Rallyarmor on my Impreza 13' is making noise on my front left side of the car. Basically, there is quite a lot of moving space for the Front Bracket, where the inner side of the bracket is able to flex. The long screw at the inner point of the bracket (green circled) is smacking against the inner wall of the car. During dry conditions, there is no noise, but the knocking sound gets a lot louder during rain, where the flaps 'flap' around the most.

Can someone offer some advise please?

* Registered users of the site do not see these ads.
EDKEdwin is online now   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-12-2013, 09:59 AM   #2
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

go buy some 5/32" vacuum caps, the longer ones if you can find them and put it over the end. no more noise, and is like a 3.00 solution

been working great for me for the last 7-8 months

i'm actually thinking of buying some longer screws to make the flaps sit more flush, ie the inner part always seems to angle back. I will also put a vacuum cap over that end.
flyboy1100 is offline   Reply With Quote
Old 09-12-2013, 04:37 PM   #3
EDKEdwin
Scooby Newbie
 
Member#: 361912
Join Date: Jul 2013
Chapter/Region: E. Canada
Location: Toronto
Vehicle:
2013 Imp GP Touring
Satin White Pearl

Default

thanks a lot, the vacuum cap worked for me. =)
EDKEdwin is online now   Reply With Quote
Old 02-15-2014, 04:42 PM   #4
n00b on demand
Scooby Newbie
 
Member#: 158355
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: White Plains NY
Vehicle:
2012 Sport 5MT
DGM

Default

Where would I get vacuum caps? It just goes on the end of the screw? It's such an infuriating noise
n00b on demand is offline   Reply With Quote
Old 02-15-2014, 05:52 PM   #5
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by n00b on demand View Post
Where would I get vacuum caps? It just goes on the end of the screw? It's such an infuriating noise
any parts store.

yup, just push it over the end.
flyboy1100 is offline   Reply With Quote
Old 04-08-2014, 01:04 AM   #6
webster354
Scooby Newbie
 
Member#: 343343
Join Date: Jan 2013
Chapter/Region: VIC
Vehicle:
2014 Impreza 5dr Ltd
SWP

Default

This weekend I installed my mud flaps on my '14 Impreza, and noticed these were included in the bag.



I looked in the bag I saved from my '13 Impreza and they had them as well.

Did you guys not get these caps with your hardware?
webster354 is offline   Reply With Quote
Old 04-08-2014, 04:19 PM   #7
flyboy1100
Scooby Specialist
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Quote:
Originally Posted by webster354 View Post
This weekend I installed my mud flaps on my '14 Impreza, and noticed these were included in the bag.



I looked in the bag I saved from my '13 Impreza and they had them as well.

Did you guys not get these caps with your hardware?
i did not with my '12's
flyboy1100 is offline   Reply With Quote
Old 04-09-2014, 02:09 AM   #8
basara808
Scooby Newbie
 
Member#: 262588
Join Date: Oct 2010
Location: HI
Vehicle:
2012 Impreza 5Dr CVT
Silver

Default

same here. I did email them to ask to include in future orders.
basara808 is offline   Reply With Quote
Old 04-09-2014, 02:27 PM   #9
apollo_f1
Scooby Newbie
 
Member#: 230535
Join Date: Nov 2009
Location: Mountlake Terrace, WA
Vehicle:
2013 Sport Prem. MT
Dark Grey Metallic

Default

Quote:
Originally Posted by webster354 View Post
This weekend I installed my mud flaps on my '14 Impreza, and noticed these were included in the bag.



I looked in the bag I saved from my '13 Impreza and they had them as well.

Did you guys not get these caps with your hardware?
I don't think there were any in my order when I installed them a year ago.

Paul
apollo_f1 is offline   Reply With Quote
Old 04-14-2014, 05:31 PM   #10
pezoldtk
Scooby Newbie
 
Member#: 352727
Join Date: Apr 2013
Chapter/Region: Tri-State
Location: Pennsylvania
Vehicle:
2012 Impreza 2.0i Pr
Deep Cherry Pearl

Default

I was had the same noise issue. My order included the caps, but the instructions did not describe their use. So, they got thrown away with my packaging materials. Got home from the first drive with my flaps on and immediately dug through the trash. Problem Solved.
pezoldtk is offline   Reply With Quote
Old 04-14-2014, 10:12 PM   #11
2014subbie
Scooby Newbie
 
Member#: 386361
Join Date: Mar 2014
Default

Quote:
Originally Posted by webster354 View Post
This weekend I installed my mud flaps on my '14 Impreza, and noticed these were included in the bag. I looked in the bag I saved from my '13 Impreza and they had them as well. Did you guys not get these caps with your hardware?
no noise here
2014subbie is offline   Reply With Quote
Old 04-14-2014, 10:12 PM   #12
2014subbie
Scooby Newbie
 
Member#: 386361
Join Date: Mar 2014
Default

No noise here 2014 wrx
2014subbie is offline   Reply With Quote
Old 04-15-2014, 06:12 PM   #13
PropWashThePegasus
Scooby Newbie
 
Member#: 384949
Join Date: Mar 2014
Chapter/Region: Tri-State
Location: Long Island NY
Vehicle:
2014 Impreza
White

Default

Those things came out of the bag when I was putting mine on and I just threw them out because I had no idea what they were.

****
PropWashThePegasus is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:01 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.