Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-16-2014, 10:11 AM   #1
disturbed-az
Scooby Newbie
 
Member#: 280562
Join Date: Apr 2011
Chapter/Region: SWIC
Location: Phoenix Area - East Valley
Vehicle:
2011 Impreza WRX 5dr
DGM

Default Anyone replace a power steering rack on a 08+ wrx yet?

2011 wrx here with a problem that evidentely has been on my car since I bought it new back in 2011. My first drive up to tortilla flats after doing a lot of twisty turns there was a whining noise which stopped after cooling off. I checked all fluids everything was okay until about 3 months ago it started whining again while driving on the 60. It definitely was steering related since the noise would come on when I turn the wheel. Checked the fluid it was low, put some more in there and the first chance I got I put the car on a ramp and well...there was a big puddle of power steering fluid covering the plastic that protects the undercarriage as well as on the rack itself / hard-lines, etc...

I'm at 50k miles - so outside of my warranty period so it seems I'm stuck at fixing this at my expense now.

So given that...has anyone run into same issues here from Arizona (...I know the problem is widespread across 08+ wrx/stis) and if you did where did you get a replacement rack? I'd love to have the dealership do the job but they want about 1100 which is more than I wanted to spend...new/re manufactured racks are about 350 from what I've seen.

Any input on this?
* Registered users of the site do not see these ads.
disturbed-az is offline   Reply With Quote
Old 04-16-2014, 06:33 PM   #2
Camelbacksubaru
Former Vendor
 
Member#: 178924
Join Date: May 2008
Chapter/Region: SWIC
Location: 1521 E. Camelback Rd. 85014
Vehicle:
602. 776.6400 Direct
Your home of Subaru Parts

Default

Check out Phoenix Rack and Axle off Washington and 32nd Street, they should be able to get you taken care of. They have good stuff for sure. We use them as alternatives to OEM if the customer specifies aftermarket.

-Markos
Camelbacksubaru is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:36 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.